aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--net/Makefile1
-rw-r--r--net/uproxy/Makefile40
-rw-r--r--net/uproxy/distinfo2
-rw-r--r--net/uproxy/files/patch-uproxy.c24
-rw-r--r--net/uproxy/files/uproxy.in54
-rw-r--r--net/uproxy/pkg-descr6
7 files changed, 1 insertions, 127 deletions
diff --git a/MOVED b/MOVED
index edc591f258e8..073160c415cc 100644
--- a/MOVED
+++ b/MOVED
@@ -2595,3 +2595,4 @@ irc/ptlink-ircd||2011-09-03|Has expired: No upstream source, no distfile and no
irc/ptlink-services||2011-09-03|Has expired: No upstream source, no distfile and no maintainer
www/mediawiki115||2011-09-03|unsupported upstream
www/p5-Catalyst-Plugin-Authentication-Store-DBIC||2011-09-03|Use p5-Catalyst-Authentication-Store-DBIx-Class instead
+net/uproxy||2011-09-04|Master site disappeared, abandonware
diff --git a/net/Makefile b/net/Makefile
index 0b6de41aeb6d..63d95daf63d0 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1126,7 +1126,6 @@
SUBDIR += unison232
SUBDIR += unix2tcp
SUBDIR += uplog
- SUBDIR += uproxy
SUBDIR += urelay
SUBDIR += uriparser
SUBDIR += urlendec
diff --git a/net/uproxy/Makefile b/net/uproxy/Makefile
deleted file mode 100644
index 7578a8feed4d..000000000000
--- a/net/uproxy/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# New ports collection makefile for: uproxy
-# Date created: 19 October 2006
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= uproxy
-PORTVERSION= 0.91
-PORTREVISION= 1
-CATEGORIES= net
-MASTER_SITES= http://www.geocities.com/SiliconValley/Vista/8155/uproxy/
-DISTNAME= ${PORTNAME}
-
-MAINTAINER= avl@FreeBSD.org
-COMMENT= Proxy for UDP protocols
-
-DEPRECATED= No Master Site
-EXPIRATION_DATE= 2011-09-01
-
-USE_ZIP= yes
-NO_WRKSUBDIR= yes
-USE_RC_SUBR= ${PORTNAME}
-USE_DOS2UNIX= ${DISTNAME}.c
-PORTDOCS= index.html
-PLIST_FILES= sbin/${PORTNAME}
-
-do-build:
- (cd ${WRKSRC} && ${CC} ${CFLAGS} -o t${PORTNAME} ${DISTNAME}.c)
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/t${PORTNAME} ${PREFIX}/sbin/${PORTNAME}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/net/uproxy/distinfo b/net/uproxy/distinfo
deleted file mode 100644
index 0d5acf2ef37a..000000000000
--- a/net/uproxy/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (uproxy.zip) = 960f61dbce2d83a856726a223136f6e5ac2dc31d75958e36ac01cdf17a589645
-SIZE (uproxy.zip) = 17541
diff --git a/net/uproxy/files/patch-uproxy.c b/net/uproxy/files/patch-uproxy.c
deleted file mode 100644
index 60eb094defde..000000000000
--- a/net/uproxy/files/patch-uproxy.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- uproxy.c.orig Thu Aug 10 11:05:10 2006
-+++ uproxy.c Fri Oct 20 13:17:01 2006
-@@ -25,11 +25,11 @@
- #include <winsock.h>
- #else
- #include <sys/ioctl.h>
-+ #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <sys/time.h>
-- #include <sys/types.h>
- #include <unistd.h>
- #include <stdlib.h>
- #endif
-@@ -50,7 +50,7 @@
-
- SOCKET ProxySocket;
- struct sockaddr_in ProxySAddr, ClientSAddr, TargetSAddr;
--struct sockaddr AnySAddr={AF_INET, {INADDR_ANY}};
-+struct sockaddr AnySAddr={AF_INET, INADDR_ANY};
- struct ClientList
- {
- SOCKET sock;
diff --git a/net/uproxy/files/uproxy.in b/net/uproxy/files/uproxy.in
deleted file mode 100644
index 75ff28cfb7ba..000000000000
--- a/net/uproxy/files/uproxy.in
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-#
-# PROVIDE: uproxy
-# REQUIRE: NETWORKING
-#
-# Add the following line to /etc/rc.conf to enable uproxy
-#
-# uproxy_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable uproxy.
-# uproxy_connections (str): Name for each uproxy connection.
-# uproxy_connectionname_options (str): Commandline for each uproxy connection.
-#
-
-. /etc/rc.subr
-
-name="uproxy"
-rcvar=${name}_enable
-
-load_rc_config $name
-
-: ${uproxy_enable="NO"}
-
-command="%%PREFIX%%/sbin/${name}"
-start_cmd="uproxy_startcmd"
-
-uproxy_startcmd()
-{
- if [ -z "$rc_fast" -a -n "$rc_pid" ]; then
- echo "${name} already running? (pid=$rc_pid)."
- return 1
- fi
- if [ -z "${uproxy_connections}" ]; then
- err 1 "can't find uproxy_connections in /etc/rc.conf"
- fi
- echo Starting ${name}.
- for connection in ${uproxy_connections}; do
- eval options=\$uproxy_${connection}_options
- if [ -z "${options}" ]; then
- continue
- fi
- command_args="${options}"
- cmd="${command} ${command_args}"
- if [ -n "$uproxy_user" ]; then
- cmd="su -m $uproxy_user -c '$cmd'"
- fi
- eval "$cmd > /dev/null &"
- sleep 1
- done
-}
-
-run_rc_command "$1"
diff --git a/net/uproxy/pkg-descr b/net/uproxy/pkg-descr
deleted file mode 100644
index 6bdcd50070f8..000000000000
--- a/net/uproxy/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Initially UProxy has been designed to allow playing
-Unreal Tournament matches over Internet on computers
-connected by a LAN sharing a dial up connection, but
-it could be used to play other games (such as Quake)
-and by every program using a UDP protocol where clients
-don't have to bind a fixed port (not only games!).