aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/dangerdeep/Makefile1
-rw-r--r--games/ishido/Makefile1
-rw-r--r--games/nadar/Makefile1
-rw-r--r--games/qnetchess/Makefile1
-rw-r--r--games/tetrons/Makefile1
-rw-r--r--games/tyrquake/Makefile2
-rw-r--r--games/xblood/Makefile1
-rw-r--r--games/xjumpx/Makefile1
-rw-r--r--multimedia/dtv/Makefile1
-rw-r--r--multimedia/fxtv/Makefile1
-rw-r--r--multimedia/nxtvepg/Makefile2
-rw-r--r--x11-clocks/eyeclock/Makefile1
-rw-r--r--x11-clocks/wmbday/Makefile2
-rw-r--r--x11-wm/nickleby/Makefile1
-rw-r--r--x11/xkeywrap/Makefile1
15 files changed, 15 insertions, 3 deletions
diff --git a/games/dangerdeep/Makefile b/games/dangerdeep/Makefile
index 902859beea1f..c579e7e5c5ac 100644
--- a/games/dangerdeep/Makefile
+++ b/games/dangerdeep/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
execinfo.1:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/maps/default.xml:${PORTSDIR}/games/dangerdeep-data
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_GL= yes
USE_SDL= sdl mixer image net
diff --git a/games/ishido/Makefile b/games/ishido/Makefile
index 9b961714d0c2..a340e1d1f884 100644
--- a/games/ishido/Makefile
+++ b/games/ishido/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= obrien
MAINTAINER= samorodi@NUXI.com
COMMENT= Tile placement game
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= x11
MAN6= ishido.6
diff --git a/games/nadar/Makefile b/games/nadar/Makefile
index d6a0421a985d..727dad7d6595 100644
--- a/games/nadar/Makefile
+++ b/games/nadar/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://ftp.vector.co.jp/pack/unix/game/action/
MAINTAINER= hsakai@m8.ffn.ne.jp
COMMENT= A network tank battle game
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= xpm
MAKE_JOBS_UNSAFE= yes
diff --git a/games/qnetchess/Makefile b/games/qnetchess/Makefile
index c854179b50d3..5106010a930e 100644
--- a/games/qnetchess/Makefile
+++ b/games/qnetchess/Makefile
@@ -17,6 +17,7 @@ COMMENT= Qt based chess multiplayer game
MAKEFILE= Makefile.FreeBSD
LOCALE_FILE= "${DATADIR}/${PORTNAME}_ru"
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_BZIP2= yes
USE_QT_VER= 3
diff --git a/games/tetrons/Makefile b/games/tetrons/Makefile
index fe0966e5b9a5..d56b8f22e0e3 100644
--- a/games/tetrons/Makefile
+++ b/games/tetrons/Makefile
@@ -15,6 +15,7 @@ COMMENT= Tetris(TM) clone for X11
MAKE_ARGS+= -DRANDOM
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= x11 xext xi
PLIST_FILES= bin/tetrons
diff --git a/games/tyrquake/Makefile b/games/tyrquake/Makefile
index e42f35065c5b..c96b9f05f1d6 100644
--- a/games/tyrquake/Makefile
+++ b/games/tyrquake/Makefile
@@ -18,7 +18,7 @@ USE_XORG= x11 xxf86vm xdamage xfixes xau xext xdmcp
USE_GL= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-MAKE_ENV= QBASEDIR="${Q1DIR}"
+MAKE_ENV= QBASEDIR="${Q1DIR}" X11BASE=${LOCALBASE}
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
X86_ASM "Enable x86 assembly code when possible" on
diff --git a/games/xblood/Makefile b/games/xblood/Makefile
index f28a58cacdab..24a302027e41 100644
--- a/games/xblood/Makefile
+++ b/games/xblood/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://kozos.jp/myfreesoft/
MAINTAINER= ports@FreeBSD.org
COMMENT= Makes the root window bloody
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= x11
MAN1= xblood.1
MANCOMPRESSED= yes
diff --git a/games/xjumpx/Makefile b/games/xjumpx/Makefile
index 2a44c62f5cf4..7bb26953d88b 100644
--- a/games/xjumpx/Makefile
+++ b/games/xjumpx/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://fenix.ne.jp/~cdrtk/soft/dl/
MAINTAINER= ports@FreeBSD.org
COMMENT= Improved version of xjump
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= xpm xaw
MAN1= xjumpx.1
diff --git a/multimedia/dtv/Makefile b/multimedia/dtv/Makefile
index 6297f7d236ea..d5d403f71060 100644
--- a/multimedia/dtv/Makefile
+++ b/multimedia/dtv/Makefile
@@ -16,6 +16,7 @@ COMMENT= A client/server based TV capture/display program
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= xau x11 xext xxf86dga
NOT_FOR_ARCHS= sparc64
diff --git a/multimedia/fxtv/Makefile b/multimedia/fxtv/Makefile
index 7afdf3fbdba3..3b20c489f923 100644
--- a/multimedia/fxtv/Makefile
+++ b/multimedia/fxtv/Makefile
@@ -19,6 +19,7 @@ COMMENT= X-based TV Display and Capture Application (for use with bt848 driver)
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= ice sm x11 xaw xext xmu xt xpm xxf86vm xxf86dga
USE_GMAKE= yes
MAKE_FLAGS= -e
diff --git a/multimedia/nxtvepg/Makefile b/multimedia/nxtvepg/Makefile
index d810d3f7ff8e..8bac7fa311d7 100644
--- a/multimedia/nxtvepg/Makefile
+++ b/multimedia/nxtvepg/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
NOT_FOR_ARCHS= sparc64
USE_GMAKE= yes
USE_XORG= x11 xmu
-MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} WRKSRC=${WRKSRC}
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} WRKSRC=${WRKSRC} X11BASE=${LOCALBASE}
MAN1= nxtvepg.1 nxtvepgd.1
MYPORTDOCS= README TODO CHANGES manual.html
diff --git a/x11-clocks/eyeclock/Makefile b/x11-clocks/eyeclock/Makefile
index 601dfc9f3576..2e0732c7dfe6 100644
--- a/x11-clocks/eyeclock/Makefile
+++ b/x11-clocks/eyeclock/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A clock with eyes following the mouse pointer
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= x11 xau xdmcp xpm xt ice
MAN1= eyeclock.1
diff --git a/x11-clocks/wmbday/Makefile b/x11-clocks/wmbday/Makefile
index a13ed428bfc4..aa3b01fafbec 100644
--- a/x11-clocks/wmbday/Makefile
+++ b/x11-clocks/wmbday/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= xmessage:${PORTSDIR}/x11/xmessage
HAS_CONFIGURE= yes
MAKEFILE= BSDmakefile
-MAKE_ENV+= ${CONFIGURE_ENV}
+MAKE_ENV+= ${CONFIGURE_ENV} X11BASE=${LOCALBASE}
MAN1= wmbday.1
MANCOMPRESSED= yes
diff --git a/x11-wm/nickleby/Makefile b/x11-wm/nickleby/Makefile
index 8735d5bfbd08..311437f5b05c 100644
--- a/x11-wm/nickleby/Makefile
+++ b/x11-wm/nickleby/Makefile
@@ -15,6 +15,7 @@ COMMENT= Simple window manager
MAN1= nickleby.1
MANCOMPRESSED= yes
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= x11
PLIST_FILES= bin/nickleby
diff --git a/x11/xkeywrap/Makefile b/x11/xkeywrap/Makefile
index a03dda0a7712..fea2595eb9de 100644
--- a/x11/xkeywrap/Makefile
+++ b/x11/xkeywrap/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://hp.vector.co.jp/authors/VA014157/myfreesoft/
MAINTAINER= sylvio@FreeBSD.org
COMMENT= Record, repeat, and play key sequence from keyboard
+MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= x11 xt
MAN1= xkeywrap.1
MANCOMPRESSED= yes