aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/colord-gtk/Makefile13
-rw-r--r--graphics/colord/Makefile17
-rw-r--r--graphics/colord/pkg-plist4
3 files changed, 19 insertions, 15 deletions
diff --git a/graphics/colord-gtk/Makefile b/graphics/colord-gtk/Makefile
index cd6a13b0f1ae..e29fd6478561 100644
--- a/graphics/colord-gtk/Makefile
+++ b/graphics/colord-gtk/Makefile
@@ -11,22 +11,21 @@ MAINTAINER= kwm@FreeBSD.org
COMMENT= Manage color profiles to accurately color input/output devices
BUILD_DEPENDS= colord>=0.1.20:${PORTSDIR}/graphics/colord
-LIB_DEPENDS= colord:${PORTSDIR}/graphics/colord \
- polkit-gobject-1:${PORTSDIR}/sysutils/polkit \
- dbus-1:${PORTSDIR}/devel/dbus \
- lcms2:${PORTSDIR}/graphics/lcms2
+LIB_DEPENDS= libcolord.so:${PORTSDIR}/graphics/colord \
+ libpolkit-gobject-1.so:${PORTSDIR}/sysutils/polkit \
+ libdbus-1.so:${PORTSDIR}/devel/dbus \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2
-USE_XZ= yes
USE_GNOME= gnomehier gtk30 intlhack introspection:build
-USES= gettext gmake pathfix pkgconfig
+USES= gettext gmake pathfix pkgconfig tar:xz
USE_SQLITE= 3
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-gtk-doc-html=no
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-Wclobbered||g' \
-e 's|-Wempty-body||g' \
diff --git a/graphics/colord/Makefile b/graphics/colord/Makefile
index d895b5b98fe1..110bd2e3a05f 100644
--- a/graphics/colord/Makefile
+++ b/graphics/colord/Makefile
@@ -11,16 +11,15 @@ MASTER_SITES= http://www.freedesktop.org/software/colord/releases/
MAINTAINER= kwm@FreeBSD.org
COMMENT= Manage color profiles to accurately color input/output devices
-LIB_DEPENDS= polkit-gobject-1:${PORTSDIR}/sysutils/polkit \
- dbus-1:${PORTSDIR}/devel/dbus \
- lcms2:${PORTSDIR}/graphics/lcms2
+LIB_DEPENDS= libpolkit-gobject-1.so:${PORTSDIR}/sysutils/polkit \
+ libdbus-1.so:${PORTSDIR}/devel/dbus \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2
USERS= colord
GROUPS= colord
-USE_XZ= yes
USE_GNOME= gnomehier glib20 intlhack introspection:build
-USES= gettext gmake pathfix pkgconfig
+USES= gettext gmake pathfix pkgconfig tar:xz
USE_SQLITE= 3
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -38,18 +37,20 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= USB_CFLAGS="-I/usr/include" \
USB_LIBS="-L/usr/lib -lusb"
+INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.freedesktop.ColorHelper.gschema.xml
OPTIONS_DEFINE= MANPAGES
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMANPAGES}
BUILD_DEPENDS+= docbook2html:${PORTSDIR}/textproc/docbook-utils \
${LOCALBASE}/share/sgml/docbook/4.1:${PORTSDIR}/textproc/docbook-sgml
-MAN1= cd-create-profile.1 cd-fix-profile.1 colormgr.1
+PLIST_SUB+= MAN=""
+.else
+PLIST_SUB+= MAN="@comment "
.endif
post-patch:
@@ -71,6 +72,6 @@ post-patch:
.endif
post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${MKDIR} ${STAGEDIR}/var/db/colord/icc
.include <bsd.port.mk>
diff --git a/graphics/colord/pkg-plist b/graphics/colord/pkg-plist
index bb35fb489274..975d1febba3a 100644
--- a/graphics/colord/pkg-plist
+++ b/graphics/colord/pkg-plist
@@ -48,6 +48,10 @@ lib/libcolordprivate.so.1
libdata/pkgconfig/colord.pc
libexec/colord
libexec/colord-session
+%%MAN%%man/man1/cd-create-profile.1.gz
+%%MAN%%man/man1/cd-fix-profile.1.gz
+%%MAN%%man/man1/colord.conf.1.gz
+%%MAN%%man/man1/colormgr.1.gz
share/color/icc/colord/AdobeRGB1998.icc
share/color/icc/colord/AppleRGB.icc
share/color/icc/colord/BestRGB.icc