aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/sgmltools-lite/Makefile32
2 files changed, 33 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 64dbf5b11d99..f19477c1c5f6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -86,6 +86,7 @@
SUBDIR += sgmlformat
SUBDIR += sgmls
SUBDIR += sgmltools
+ SUBDIR += sgmltools-lite
SUBDIR += sgrep
SUBDIR += sp
SUBDIR += texi2html
diff --git a/textproc/sgmltools-lite/Makefile b/textproc/sgmltools-lite/Makefile
new file mode 100644
index 000000000000..257fd86ee7ae
--- /dev/null
+++ b/textproc/sgmltools-lite/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: sgmltools
+# Date created: 7 Apr 2000
+# Whom: Benno Rice <benno@netizen.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sgmltools-lite
+PORTVERSION= 3.0.0
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sgmltools-lite
+
+MAINTAINER= benno@netizen.com.au
+
+BUILD_DEPENDS+= python:${PORTSDIR}/lang/python \
+ jade:${PORTSDIR}/textproc/jade \
+ ${LOCALBASE}/share/texmf:${PORTSDIR}/print/teTeX
+RUN_DEPENDS+= ${LOCALBASE}/share/sgml/docbook:${PORTSDIR}/textproc/docbook \
+ ${LOCALBASE}/share/sgml/docbook/dsssl:${PORTSDIR}/textproc/dsssl-docbook-modular
+
+MAN1= sgmltools.1
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-etcsgml=${PREFIX}/etc/sgml
+
+pre-configure:
+ ${RM} -f ${WRKSRC}/config.cache
+
+post-install:
+ ${ECHO} "3.0.0" > ${LOCALBASE}/share/sgml/misc/sgmltools/VERSION
+
+.include <bsd.port.mk>