aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING17
-rw-r--r--www/bricolage/Makefile13
-rw-r--r--www/bricolage/distinfo4
-rw-r--r--www/bricolage/pkg-plist8
4 files changed, 34 insertions, 8 deletions
diff --git a/UPDATING b/UPDATING
index 265199404ca7..8c0c591bd9e5 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,23 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
+20041116:
+ AFFECTS: users of www/bricolage
+ AUTHOR: ports@rbt.ca
+
+ Bricolage may now be run on mod_perl compiled as a DSO for Apache
+ when following these guidelines:
+
+ http://perl.apache.org/docs/1.0/guide/install.html#When_DSO_can_be_Used
+
+ To do this, you will need to:
+ pkg_delete -f apache-mod_perl
+ pkg_delete -f p5-libapreq-static
+ portupgrade -rR bricolage
+
+ Bricolage will rebuild mod_perl, apache and libapreq using their standard
+ versions.
+
20041115:
AFFECTS: users of sysutils/portupgrade
AUTHOR: lofi@FreeBSD.org
diff --git a/www/bricolage/Makefile b/www/bricolage/Makefile
index f2ba28119d9c..16a2859dd31a 100644
--- a/www/bricolage/Makefile
+++ b/www/bricolage/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bricolage
-PORTVERSION= 1.8.1
+PORTVERSION= 1.8.2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bricolage
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= bricolage
MAINTAINER= ports@rbt.ca
COMMENT= A full-featured, open-source content-management and publishing system
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13-modperl \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg \
${SITE_PERL}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM \
${SITE_PERL}/Cache/Cache.pm:${PORTSDIR}/devel/p5-Cache-Cache \
@@ -38,19 +37,21 @@ BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13-modperl \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session \
- ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq-static \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/MasonX/Interp/WithCallbacks.pm:${PORTSDIR}/www/p5-MasonX-Interp-WithCallbacks \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
${SITE_PERL}/HTTP/BrowserDetect.pm:${PORTSDIR}/www/p5-HTTP-BrowserDetect
-RUN_DEPENDS= ${BUILD_DEPENDS}
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+ ${BUILD_DEPENDS}
APXS?= ${LOCALBASE}/sbin/apxs
MAKE_ENV+= INSTALL_VERBOSITY="QUIET"
# Used to determine which versions we can upgrade from
-PREVIOUS_VERSIONS= 1.8.0 1.8.1
+PREVIOUS_VERSIONS= 1.8.0 1.8.1 ${PORTVERSION}
USE_REINPLACE= yes
PERL_CONFIGURE= yes
diff --git a/www/bricolage/distinfo b/www/bricolage/distinfo
index 2a81d003c049..2440f638d97b 100644
--- a/www/bricolage/distinfo
+++ b/www/bricolage/distinfo
@@ -1,2 +1,2 @@
-MD5 (bricolage-1.8.1.tar.gz) = 93525168d152ac12f438b3ae6b4ac669
-SIZE (bricolage-1.8.1.tar.gz) = 2267893
+MD5 (bricolage-1.8.2.tar.gz) = e91150571658a5289c0521b5bfa313b2
+SIZE (bricolage-1.8.2.tar.gz) = 2282281
diff --git a/www/bricolage/pkg-plist b/www/bricolage/pkg-plist
index e3b569e2db59..4743353cb77d 100644
--- a/www/bricolage/pkg-plist
+++ b/www/bricolage/pkg-plist
@@ -15,6 +15,13 @@ bricolage/upgrade/1.8.0/new_lang_pref_options.pl
bricolage/upgrade/1.8.1/contrib_type_secret.pl
bricolage/upgrade/1.8.1/fix_orphan_assets.pl
bricolage/upgrade/1.8.1/grp_grp_name.pl
+bricolage/upgrade/1.8.2/add_missing_job_constraints.pl
+bricolage/upgrade/1.8.2/add_missing_job_fks.pl
+bricolage/upgrade/1.8.2/default_media_type.pl
+bricolage/upgrade/1.8.2/delete_old_jobs.pl
+bricolage/upgrade/1.8.2/delete_template_obj_files.pl
+bricolage/upgrade/1.8.2/job_text_columns.pl
+bricolage/upgrade/1.8.2/media_type_not_null.pl
bricolage/comp/admin/alerts/dhandler
bricolage/comp/admin/alerts/recip
bricolage/comp/admin/control/change_user/dhandler
@@ -2771,6 +2778,7 @@ share/bricolage/Pg.sql
@dirrm %%SITE_PERL%%/Bric
@dirrm %%SITE_PERL%%/mach/auto/Bric
@dirrm %%SITE_PERL%%/mach/auto/bric_bin
+@dirrm bricolage/upgrade/1.8.2
@dirrm bricolage/upgrade/1.8.1
@dirrm bricolage/upgrade/1.8.0
@dirrm bricolage/upgrade/lib