aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/squirrelmail-email_footer-plugin/Makefile75
-rw-r--r--mail/squirrelmail-email_footer-plugin/distinfo3
-rw-r--r--mail/squirrelmail-email_footer-plugin/files/pkg-message.in5
-rw-r--r--mail/squirrelmail-email_footer-plugin/pkg-descr7
-rw-r--r--mail/squirrelmail-email_footer-plugin/pkg-plist10
6 files changed, 101 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index fad99696a2b2..ca961726316c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -511,6 +511,7 @@
SUBDIR += squirrelmail-change_ldappass-plugin
SUBDIR += squirrelmail-compatibility-plugin
SUBDIR += squirrelmail-devel
+ SUBDIR += squirrelmail-email_footer-plugin
SUBDIR += squirrelmail-vlogin-plugin
SUBDIR += sqwebmail
SUBDIR += ssmtp
diff --git a/mail/squirrelmail-email_footer-plugin/Makefile b/mail/squirrelmail-email_footer-plugin/Makefile
new file mode 100644
index 000000000000..0277c2222883
--- /dev/null
+++ b/mail/squirrelmail-email_footer-plugin/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: squirrelmail-email_footer-plugin
+# Date created: 10 Feb 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 0.4
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.4.2
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= View quota and current usage
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= email_footer
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+SUB_FILES= pkg-message
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-email_footer-plugin/distinfo b/mail/squirrelmail-email_footer-plugin/distinfo
new file mode 100644
index 000000000000..dc22e5f1c4d9
--- /dev/null
+++ b/mail/squirrelmail-email_footer-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/email_footer-0.4-1.4.2.tar.gz) = ad0f9e688fc4dc89a2f19bd17d1bc927
+SHA256 (squirrelmail/email_footer-0.4-1.4.2.tar.gz) = 14a0bc98e2a754bde03d6e4b2b542794e7400a1b5684444e6a291ec8fcda80fd
+SIZE (squirrelmail/email_footer-0.4-1.4.2.tar.gz) = 4079
diff --git a/mail/squirrelmail-email_footer-plugin/files/pkg-message.in b/mail/squirrelmail-email_footer-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..c8e521e65bec
--- /dev/null
+++ b/mail/squirrelmail-email_footer-plugin/files/pkg-message.in
@@ -0,0 +1,5 @@
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/login_notes/config.php.sample
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/login_notes/config.php
+and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-email_footer-plugin/pkg-descr b/mail/squirrelmail-email_footer-plugin/pkg-descr
new file mode 100644
index 000000000000..899c68121663
--- /dev/null
+++ b/mail/squirrelmail-email_footer-plugin/pkg-descr
@@ -0,0 +1,7 @@
+If you have an IMAP server with QUOTA Extension capability, you can use
+this plugin to view the current quota usage (both size and message count),
+which is displayed just above the folders list.
+A warning message can also be displayed to users upon login if desired.
+If no quota is set, nothing is displayed.
+
+WWW: http://www.squirrelmail.org
diff --git a/mail/squirrelmail-email_footer-plugin/pkg-plist b/mail/squirrelmail-email_footer-plugin/pkg-plist
new file mode 100644
index 000000000000..c4e3945086e2
--- /dev/null
+++ b/mail/squirrelmail-email_footer-plugin/pkg-plist
@@ -0,0 +1,10 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin email_footer; fi
+%%SQUIRRELDIR%%/plugins/email_footer/INSTALL
+%%SQUIRRELDIR%%/plugins/email_footer/README
+%%SQUIRRELDIR%%/plugins/email_footer/config.php.sample
+%%SQUIRRELDIR%%/plugins/email_footer/functions.php
+%%SQUIRRELDIR%%/plugins/email_footer/index.php
+%%SQUIRRELDIR%%/plugins/email_footer/setup.php
+%%SQUIRRELDIR%%/plugins/email_footer/version
+@dirrm %%SQUIRRELDIR%%/plugins/email_footer/
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin email_footer; fi