aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/launchy/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/deskutils/launchy/Makefile b/deskutils/launchy/Makefile
index 1c649e9ac369..a1c29c0b9cb8 100644
--- a/deskutils/launchy/Makefile
+++ b/deskutils/launchy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= launchy
PORTVERSION= 2.1.2
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= SF
@@ -14,15 +15,21 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= Access applications, files, and bookmarks with just a few keystrokes
BUILD_DEPENDS= ${LOCALBASE}/include/boost/spirit/core.hpp:${PORTSDIR}/devel/boost
+RUN_DEPENDS= ${LOCALBASE}/bin/xdg-open:${PORTSDIR}/devel/xdg-utils
USE_DOS2UNIX= readme.lyx readme.txt
+USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build uic_build gui network
MAKEFILE= makefile
ALL_TARGET= release
+MAKE_ARGS= PREFIX="${PREFIX}"
PORTDOCS= *
+post-patch:
+ @${REINPLACE_CMD} 's,make ,g&,' ${WRKSRC}/${MAKEFILE}
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}