aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/clearlooks-phenix-theme/Makefile20
-rw-r--r--x11-themes/clearlooks-phenix-theme/distinfo4
-rw-r--r--x11-themes/clearlooks-phenix-theme/files/patch-gtk-3.0__gtk-widgets.css62
3 files changed, 75 insertions, 11 deletions
diff --git a/x11-themes/clearlooks-phenix-theme/Makefile b/x11-themes/clearlooks-phenix-theme/Makefile
index a56ae7fc4141..c47e22fdd2b5 100644
--- a/x11-themes/clearlooks-phenix-theme/Makefile
+++ b/x11-themes/clearlooks-phenix-theme/Makefile
@@ -2,27 +2,29 @@
# $FreeBSD$
PORTNAME= clearlooks-phenix
-PORTVERSION= 3.0.15
+PORTVERSION= 3.0.16
CATEGORIES= x11-themes xfce
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= GENTOO
+MASTER_SITE_SUBDIR= distfiles
PKGNAMESUFFIX= -theme
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Gtk3 port of Clearlooks theme for the Xfce Desktop
-RUN_DEPENDS= gtk3-unico-engine>=1.0.1:${PORTSDIR}/x11-themes/gtk3-unico-engine
+RUN_DEPENDS= gtk-engines2>=2.20.2:${PORTSDIR}/x11-themes/gtk-engines2
-PROJECTHOST= olivier-freebsd-ports
-
-USE_XZ= yes
+WRKSRC= ${WRKDIR}/projets-divers-${PORTNAME}
NO_BUILD= yes
-NO_STAGE= yes
+post-patch:
+ @${RM} ${WRKSRC}/gtk-?.0/*.orig
+
do-install:
- @${MKDIR} ${PREFIX}/share/themes/Clearlooks-Phenix
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/themes/Clearlooks-Phenix
.for dir in gtk-2.0 gtk-3.0 xfwm4
@cd ${WRKSRC} && \
- ${COPYTREE_SHARE} ${dir} ${PREFIX}/share/themes/Clearlooks-Phenix
+ ${COPYTREE_SHARE} ${dir} \
+ ${STAGEDIR}${PREFIX}/share/themes/Clearlooks-Phenix
.endfor
.include <bsd.port.mk>
diff --git a/x11-themes/clearlooks-phenix-theme/distinfo b/x11-themes/clearlooks-phenix-theme/distinfo
index 77d6970bdcfe..30fb45abf364 100644
--- a/x11-themes/clearlooks-phenix-theme/distinfo
+++ b/x11-themes/clearlooks-phenix-theme/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clearlooks-phenix-3.0.15.tar.xz) = 9f62027e2afda6e19bd71efd9d25467b9058f70ddc75d40b6b7c67ca5be3030c
-SIZE (clearlooks-phenix-3.0.15.tar.xz) = 274676
+SHA256 (clearlooks-phenix-3.0.16.tar.gz) = 4a99d502d6ea76c9503a5612a815550d6037521c2023eb24ec82bd09f65cbe79
+SIZE (clearlooks-phenix-3.0.16.tar.gz) = 293595
diff --git a/x11-themes/clearlooks-phenix-theme/files/patch-gtk-3.0__gtk-widgets.css b/x11-themes/clearlooks-phenix-theme/files/patch-gtk-3.0__gtk-widgets.css
new file mode 100644
index 000000000000..a0b527accbd5
--- /dev/null
+++ b/x11-themes/clearlooks-phenix-theme/files/patch-gtk-3.0__gtk-widgets.css
@@ -0,0 +1,62 @@
+--- ./gtk-3.0/gtk-widgets.css.orig 2013-09-08 02:22:51.000000000 +0000
++++ ./gtk-3.0/gtk-widgets.css 2014-01-09 18:06:00.000000000 +0000
+@@ -416,7 +416,7 @@
+ border-color: @border_color;
+ border-style: solid;
+ border-radius: 3px;
+- background-color: @theme_base_color;
++ background-color: @theme_bg_color;
+ padding: 0;
+ }
+
+@@ -1057,7 +1057,7 @@
+ .menu {
+ background-color: @menu_bg_color;
+ color: @menu_fg_color;
+- padding: 0;
++ padding: 1px;
+ border-style: solid;
+ border-width: 1px;
+ border-color: @menu_border_color;
+@@ -1065,7 +1065,7 @@
+
+ .menu.button {
+ background-image: none;
+- background-color: @theme_base_color;
++ background-color: @menu_bg_color;
+ color: @internal_element_color;
+
+ border-image: none;
+@@ -1092,7 +1092,7 @@
+ /* this controls the general appearance of the menubar */
+ .menubar {
+ border-style: none;
+- padding: 4px;
++ padding: 1px;
+ -GtkWidget-window-dragging: true;
+ -GtkMenuBar-internal-padding: 1;
+ background-image: -gtk-gradient (linear,
+@@ -1106,6 +1106,7 @@
+ .menubar .menuitem {
+ border-style: none;
+ padding: 3px 5px;
++ background-color: transparent;
+ }
+
+ .menubar .menuitem:hover {
+@@ -1130,6 +1131,7 @@
+
+ .menu .menuitem {
+ -GtkMenuItem-arrow-scaling: 0.5;
++ background-color: @menu_bg_color;
+ padding: 4px;
+ }
+
+@@ -1184,6 +1186,7 @@
+
+ .menuitem.separator {
+ color: @menu_separator_color;
++ padding: 3px 1px 3px 1px;
+
+ -GtkMenuItem-horizontal-padding: 0;
+ }