aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/libxdg-basedir/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11/libxdg-basedir/Makefile b/x11/libxdg-basedir/Makefile
index fd8c1683bbc6..6b820560e746 100644
--- a/x11/libxdg-basedir/Makefile
+++ b/x11/libxdg-basedir/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libxdg-basedir
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://n.ethz.ch/student/nevillm/download/libxdg-basedir/
@@ -15,11 +16,15 @@ COMMENT= An implementation of the XDG Base Directory specification
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${LOCALBASE}
+USE_LDCONFIG= yes
pre-configure:
@${REINPLACE_CMD} -e \
's|$$(libdir)/pkgconfig|$${prefix}/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|"etc"|"${PREFIX}/etc"|' \
+ -e '/DefaultConfigDirectories\[\]/,/DefaultRelativeCacheHome\[\]/ s|"/\([^"]\)|"\1|' \
+ -e '/DefaultConfigDirectories\[\]/,/DefaultRelativeCacheHome\[\]/ s|/|" DIR_SEPARATOR_STR "|g' \
+ ${WRKSRC}/src/basedir.c
.include <bsd.port.mk>