aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/jvmtop/Makefile28
-rw-r--r--sysutils/jvmtop/distinfo2
-rw-r--r--sysutils/jvmtop/files/jvmtop.sh.in3
-rw-r--r--sysutils/jvmtop/pkg-descr9
5 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 87ba7e940698..06eeca83b1d2 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -423,6 +423,7 @@
SUBDIR += jps
SUBDIR += jtop
SUBDIR += jtopen
+ SUBDIR += jvmtop
SUBDIR += jx
SUBDIR += k3b
SUBDIR += k3b-kde4
diff --git a/sysutils/jvmtop/Makefile b/sysutils/jvmtop/Makefile
new file mode 100644
index 000000000000..f0690fa4a7b2
--- /dev/null
+++ b/sysutils/jvmtop/Makefile
@@ -0,0 +1,28 @@
+# Created by: Jason Helfman <jgh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jvmtop
+PORTVERSION= 0.6.0
+CATEGORIES= sysutils java
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Lightweight console application to monitor running jvms
+
+LICENSE= GPLv3
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
+ bin/${PORTNAME}
+SUB_LIST= JAVA_HOME=${JAVA_HOME}
+SUB_FILES= ${PORTNAME}.sh
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.jar ${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/jvmtop/distinfo b/sysutils/jvmtop/distinfo
new file mode 100644
index 000000000000..de53d3fc55a3
--- /dev/null
+++ b/sysutils/jvmtop/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jvmtop-0.6.0.tar.gz) = 0b849fe86c225aa1198376fa55872a66bc5008bf72e3672d1c7ee19aa30b9588
+SIZE (jvmtop-0.6.0.tar.gz) = 41570
diff --git a/sysutils/jvmtop/files/jvmtop.sh.in b/sysutils/jvmtop/files/jvmtop.sh.in
new file mode 100644
index 000000000000..e9d3e73ef67b
--- /dev/null
+++ b/sysutils/jvmtop/files/jvmtop.sh.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -cp "%%JAVAJARDIR%%/jvmtop.jar:%%JAVA_HOME%%/lib/tools.jar" com.jvmtop.JvmTop $1
diff --git a/sysutils/jvmtop/pkg-descr b/sysutils/jvmtop/pkg-descr
new file mode 100644
index 000000000000..49374848a920
--- /dev/null
+++ b/sysutils/jvmtop/pkg-descr
@@ -0,0 +1,9 @@
+Jvmtop is a lightweight console application to monitor all accessible, running
+jvms on a machine. In a top-like manner, it displays JVM internal metrics
+(e.g. memory information) of running java processes.
+
+It's tested with different releases of Oracle JDK, IBM JDK and OpenJDK on
+Linux, Solaris and Windows hosts. Jvmtop requires a JDK - a JRE will not
+suffice.
+
+WWW: http://code.google.com/p/jvmtop/