aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/netbox/Makefile1
-rw-r--r--net-mgmt/netbox/files/patch-netbox_ipam_tables.py20
2 files changed, 21 insertions, 0 deletions
diff --git a/net-mgmt/netbox/Makefile b/net-mgmt/netbox/Makefile
index da62903a1768..012dc7956ded 100644
--- a/net-mgmt/netbox/Makefile
+++ b/net-mgmt/netbox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netbox
DISTVERSIONPREFIX= v
DISTVERSION= 2.6.8
+PORTREVISION= 1
CATEGORIES= net-mgmt
MAINTAINER= kai@FreeBSD.org
diff --git a/net-mgmt/netbox/files/patch-netbox_ipam_tables.py b/net-mgmt/netbox/files/patch-netbox_ipam_tables.py
new file mode 100644
index 000000000000..616ff4000e09
--- /dev/null
+++ b/net-mgmt/netbox/files/patch-netbox_ipam_tables.py
@@ -0,0 +1,20 @@
+Fix unable to assign existing IP addresses to interfaces
+
+Obtained from:
+https://github.com/netbox-community/netbox/commit/1acdf58a4bb35d83a280464ac69aa961ff614df7
+
+--- netbox/ipam/tables.py.orig 2019-12-15 11:43:12 UTC
++++ netbox/ipam/tables.py
+@@ -85,7 +85,11 @@ IPADDRESS_LINK = """
+ """
+
+ IPADDRESS_ASSIGN_LINK = """
+-<a href="{% url 'ipam:ipaddress_edit' pk=record.pk %}?interface={{ record.interface.pk }}&return_url={{ request.path }}">{{ record }}</a>
++{% if request.GET %}
++ <a href="{% url 'ipam:ipaddress_edit' pk=record.pk %}?interface={{ request.GET.interface }}&return_url={{ request.GET.return_url }}">{{ record }}</a>
++{% else %}
++ <a href="{% url 'ipam:ipaddress_edit' pk=record.pk %}?interface={{ record.interface.pk }}&return_url={{ request.path }}">{{ record }}</a>
++{% endif %}
+ """
+
+ IPADDRESS_PARENT = """