aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/linux_devtools-7/Makefile17
-rw-r--r--emulators/linux_base-8/Makefile16
-rw-r--r--emulators/linux_base-rh-9/Makefile16
-rw-r--r--emulators/linux_base-suse-9.1/Makefile16
-rw-r--r--emulators/linux_base-suse-9.2/Makefile16
-rw-r--r--emulators/linux_base-suse-9.3/Makefile16
-rw-r--r--emulators/linux_base/Makefile16
7 files changed, 28 insertions, 85 deletions
diff --git a/devel/linux_devtools-7/Makefile b/devel/linux_devtools-7/Makefile
index e9464777f27a..e4a753c976a5 100644
--- a/devel/linux_devtools-7/Makefile
+++ b/devel/linux_devtools-7/Makefile
@@ -8,7 +8,8 @@
PORTNAME= linux_devtools
PORTVERSION= 7.1
CATEGORIES= devel emulators linux
-MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
DISTFILES= ${RPM_KERNEL_HEADERS} \
${RPM_GLIBC_DEVEL} \
${RPM_LIBSTDCXX_DEVEL} \
@@ -22,7 +23,8 @@ DISTFILES= ${RPM_KERNEL_HEADERS} \
${RPM_X_DEVEL}
EXTRACT_ONLY=
-PATCH_SITES= ${RPM_MIRRORS:S/__DIR__/${UPDDIR}/g}
+PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
+PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
PATCHFILES= ${UPDATES}
MAINTAINER= marcel@FreeBSD.org
@@ -43,17 +45,6 @@ MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
# Let's avoid hardcoding 'en' as the language.
LANG= en
-# XXX - Increase the number of mirrors. Favor those that also hold
-# the IA-64 packages.
-RPM_MIRRORS= \
- ftp://ftp.rutgers.edu/pub/redhat/__DIR__/ \
- ftp://ftp.redhat.com/redhat/__DIR__/ \
- ftp://ftp.nluug.nl/site/ftp.redhat.com/redhat/__DIR__/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/__DIR__/
-
-STDDIR= linux/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
-UPDDIR= linux/updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
-
.include <bsd.port.pre.mk>
.if (${MACHINE_ARCH} == "i386")
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index e767da3661c7..e6abd2b2a4a3 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -9,7 +9,8 @@ PORTNAME= linux_base
PORTVERSION= 7.1
PORTREVISION= 0
CATEGORIES= emulators linux
-MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
DISTFILES= ${RPM_GLIBC_COMMON} \
redhat-release-7.1-1.noarch.rpm \
${RPM_SETUP} \
@@ -39,7 +40,8 @@ DISTFILES= ${RPM_GLIBC_COMMON} \
${RPM_FREETYPE} \
${RPM_XFREE86_LIBS}
-PATCH_SITES= ${RPM_MIRRORS:S/__DIR__/${UPDDIR}/g}
+PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
+PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
PATCHFILES= ${UPDATES}
MAINTAINER= ports@FreeBSD.org
@@ -59,16 +61,6 @@ MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
# Let's avoid hardcoding 'en' as the language.
LANG= en
-# XXX - Increase the number of mirrors. Favor those that also hold
-# the IA-64 packages.
-RPM_MIRRORS= \
- ftp://ftp.redhat.com/pub/redhat/__DIR__/ \
- ftp://ftp.nluug.nl/site/ftp.redhat.com/redhat/__DIR__/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/__DIR__/
-
-STDDIR= linux/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
-UPDDIR= linux/updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
-
.include <bsd.port.pre.mk>
UPDATES= zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
diff --git a/emulators/linux_base-rh-9/Makefile b/emulators/linux_base-rh-9/Makefile
index e767da3661c7..e6abd2b2a4a3 100644
--- a/emulators/linux_base-rh-9/Makefile
+++ b/emulators/linux_base-rh-9/Makefile
@@ -9,7 +9,8 @@ PORTNAME= linux_base
PORTVERSION= 7.1
PORTREVISION= 0
CATEGORIES= emulators linux
-MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
DISTFILES= ${RPM_GLIBC_COMMON} \
redhat-release-7.1-1.noarch.rpm \
${RPM_SETUP} \
@@ -39,7 +40,8 @@ DISTFILES= ${RPM_GLIBC_COMMON} \
${RPM_FREETYPE} \
${RPM_XFREE86_LIBS}
-PATCH_SITES= ${RPM_MIRRORS:S/__DIR__/${UPDDIR}/g}
+PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
+PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
PATCHFILES= ${UPDATES}
MAINTAINER= ports@FreeBSD.org
@@ -59,16 +61,6 @@ MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
# Let's avoid hardcoding 'en' as the language.
LANG= en
-# XXX - Increase the number of mirrors. Favor those that also hold
-# the IA-64 packages.
-RPM_MIRRORS= \
- ftp://ftp.redhat.com/pub/redhat/__DIR__/ \
- ftp://ftp.nluug.nl/site/ftp.redhat.com/redhat/__DIR__/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/__DIR__/
-
-STDDIR= linux/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
-UPDDIR= linux/updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
-
.include <bsd.port.pre.mk>
UPDATES= zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
diff --git a/emulators/linux_base-suse-9.1/Makefile b/emulators/linux_base-suse-9.1/Makefile
index e767da3661c7..e6abd2b2a4a3 100644
--- a/emulators/linux_base-suse-9.1/Makefile
+++ b/emulators/linux_base-suse-9.1/Makefile
@@ -9,7 +9,8 @@ PORTNAME= linux_base
PORTVERSION= 7.1
PORTREVISION= 0
CATEGORIES= emulators linux
-MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
DISTFILES= ${RPM_GLIBC_COMMON} \
redhat-release-7.1-1.noarch.rpm \
${RPM_SETUP} \
@@ -39,7 +40,8 @@ DISTFILES= ${RPM_GLIBC_COMMON} \
${RPM_FREETYPE} \
${RPM_XFREE86_LIBS}
-PATCH_SITES= ${RPM_MIRRORS:S/__DIR__/${UPDDIR}/g}
+PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
+PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
PATCHFILES= ${UPDATES}
MAINTAINER= ports@FreeBSD.org
@@ -59,16 +61,6 @@ MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
# Let's avoid hardcoding 'en' as the language.
LANG= en
-# XXX - Increase the number of mirrors. Favor those that also hold
-# the IA-64 packages.
-RPM_MIRRORS= \
- ftp://ftp.redhat.com/pub/redhat/__DIR__/ \
- ftp://ftp.nluug.nl/site/ftp.redhat.com/redhat/__DIR__/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/__DIR__/
-
-STDDIR= linux/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
-UPDDIR= linux/updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
-
.include <bsd.port.pre.mk>
UPDATES= zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
diff --git a/emulators/linux_base-suse-9.2/Makefile b/emulators/linux_base-suse-9.2/Makefile
index e767da3661c7..e6abd2b2a4a3 100644
--- a/emulators/linux_base-suse-9.2/Makefile
+++ b/emulators/linux_base-suse-9.2/Makefile
@@ -9,7 +9,8 @@ PORTNAME= linux_base
PORTVERSION= 7.1
PORTREVISION= 0
CATEGORIES= emulators linux
-MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
DISTFILES= ${RPM_GLIBC_COMMON} \
redhat-release-7.1-1.noarch.rpm \
${RPM_SETUP} \
@@ -39,7 +40,8 @@ DISTFILES= ${RPM_GLIBC_COMMON} \
${RPM_FREETYPE} \
${RPM_XFREE86_LIBS}
-PATCH_SITES= ${RPM_MIRRORS:S/__DIR__/${UPDDIR}/g}
+PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
+PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
PATCHFILES= ${UPDATES}
MAINTAINER= ports@FreeBSD.org
@@ -59,16 +61,6 @@ MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
# Let's avoid hardcoding 'en' as the language.
LANG= en
-# XXX - Increase the number of mirrors. Favor those that also hold
-# the IA-64 packages.
-RPM_MIRRORS= \
- ftp://ftp.redhat.com/pub/redhat/__DIR__/ \
- ftp://ftp.nluug.nl/site/ftp.redhat.com/redhat/__DIR__/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/__DIR__/
-
-STDDIR= linux/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
-UPDDIR= linux/updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
-
.include <bsd.port.pre.mk>
UPDATES= zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
diff --git a/emulators/linux_base-suse-9.3/Makefile b/emulators/linux_base-suse-9.3/Makefile
index e767da3661c7..e6abd2b2a4a3 100644
--- a/emulators/linux_base-suse-9.3/Makefile
+++ b/emulators/linux_base-suse-9.3/Makefile
@@ -9,7 +9,8 @@ PORTNAME= linux_base
PORTVERSION= 7.1
PORTREVISION= 0
CATEGORIES= emulators linux
-MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
DISTFILES= ${RPM_GLIBC_COMMON} \
redhat-release-7.1-1.noarch.rpm \
${RPM_SETUP} \
@@ -39,7 +40,8 @@ DISTFILES= ${RPM_GLIBC_COMMON} \
${RPM_FREETYPE} \
${RPM_XFREE86_LIBS}
-PATCH_SITES= ${RPM_MIRRORS:S/__DIR__/${UPDDIR}/g}
+PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
+PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
PATCHFILES= ${UPDATES}
MAINTAINER= ports@FreeBSD.org
@@ -59,16 +61,6 @@ MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
# Let's avoid hardcoding 'en' as the language.
LANG= en
-# XXX - Increase the number of mirrors. Favor those that also hold
-# the IA-64 packages.
-RPM_MIRRORS= \
- ftp://ftp.redhat.com/pub/redhat/__DIR__/ \
- ftp://ftp.nluug.nl/site/ftp.redhat.com/redhat/__DIR__/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/__DIR__/
-
-STDDIR= linux/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
-UPDDIR= linux/updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
-
.include <bsd.port.pre.mk>
UPDATES= zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
diff --git a/emulators/linux_base/Makefile b/emulators/linux_base/Makefile
index e767da3661c7..e6abd2b2a4a3 100644
--- a/emulators/linux_base/Makefile
+++ b/emulators/linux_base/Makefile
@@ -9,7 +9,8 @@ PORTNAME= linux_base
PORTVERSION= 7.1
PORTREVISION= 0
CATEGORIES= emulators linux
-MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
DISTFILES= ${RPM_GLIBC_COMMON} \
redhat-release-7.1-1.noarch.rpm \
${RPM_SETUP} \
@@ -39,7 +40,8 @@ DISTFILES= ${RPM_GLIBC_COMMON} \
${RPM_FREETYPE} \
${RPM_XFREE86_LIBS}
-PATCH_SITES= ${RPM_MIRRORS:S/__DIR__/${UPDDIR}/g}
+PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
+PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
PATCHFILES= ${UPDATES}
MAINTAINER= ports@FreeBSD.org
@@ -59,16 +61,6 @@ MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
# Let's avoid hardcoding 'en' as the language.
LANG= en
-# XXX - Increase the number of mirrors. Favor those that also hold
-# the IA-64 packages.
-RPM_MIRRORS= \
- ftp://ftp.redhat.com/pub/redhat/__DIR__/ \
- ftp://ftp.nluug.nl/site/ftp.redhat.com/redhat/__DIR__/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/__DIR__/
-
-STDDIR= linux/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
-UPDDIR= linux/updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
-
.include <bsd.port.pre.mk>
UPDATES= zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm