aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/opendkim/Makefile164
-rw-r--r--mail/opendkim/Makefile.features168
-rw-r--r--mail/opendkim/Makefile.options85
-rw-r--r--mail/opendkim/distinfo4
-rw-r--r--mail/opendkim/files/patch-librbl__rbl.c10
-rw-r--r--mail/opendkim/files/patch-opendkim__opendkim.c33
-rw-r--r--mail/opendkim/pkg-plist125
7 files changed, 212 insertions, 377 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 9ca1ca2fb353..9b7f57ba1e40 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= opendkim
-PORTVERSION= 2.8.3
-PORTREVISION= 1
+PORTVERSION= 2.9.2
CATEGORIES= mail security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME} \
@@ -22,7 +21,7 @@ LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
GNU_CONFIGURE= yes
NO_OPTIONS_SORT=yes
-USES= pkgconfig perl5 shebangfix
+USES= pkgconfig perl5 shebangfix libtool
USE_PERL5= run
SHEBANG_FILES= opendkim/opendkim-genkey.in
SHEBANG_FILES= opendkim/opendkim-genkey* reputation/opendkim-* stats/opendkim-*
@@ -31,124 +30,132 @@ USE_LDCONFIG= yes
PORTDOCS= *
+CONFIGURE_ARGS+= --without-tre
+
+OPTIONS_SUB= yes
OPTIONS_SINGLE= RESOLV
OPTIONS_SINGLE_RESOLV= STOCK_RESOLVER UNBOUND
-OPTIONS_DEFINE= FILTER GNUTLS LUA MEMCACHED BDB_BASE OPENDBX OPENLDAP \
- POPAUTH QUERY_CACHE STATS DEBUG DOCS
+OPTIONS_DEFINE= FILTER CURL GNUTLS JANSSON LDNS LMDB LUA MEMCACHED \
+ BDB_BASE OPENDBX OPENLDAP POPAUTH QUERY_CACHE SASL
OPTIONS_DEFAULT= FILTER LUA UNBOUND
STOCK_RESOLVER_DESC= Use the stock resolver library
+
UNBOUND_DESC= Use unbound DNS library
+UNBOUND_CONFIGURE_WITH= unbound
+UNBOUND_LIB_DEPENDS= libunbound.so:${PORTSDIR}/dns/unbound
+
FILTER_DESC= OpenDKIM filter, requires libmilter/Sendmail
+FILTER_USE= RC_SUBR=milter-opendkim
+
+CURL_DESC= Use cURL for web queries
+CURL_CONFIGURE_WITH= libcurl
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
GNUTLS_DESC= Use GnuTLS instead of OpenSSL
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+GNUTLS_CONFIGURE_WITH= gnutls
+GNUTLS_CONFIGURE_OFF= --with-openssl=${OPENSSLBASE}
+
+JANSSON_DESC= Statistics and other output as JSON data
+JANSSON_CONFIGURE_WITH= libjansson
+JANSSON_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson
+
+LDNS_DESC= Use LDNS library for DNS queries
+LDNS_CONFIGURE_WITH= ldns
+LDNS_LIB_DEPENDS= libldns.so:${PORTSDIR}/dns/ldns
+
+LMDB_DESC= Use Lightning Memory-Mapped DB key-value store
+LMDB_CONFIGURE_WITH= lmdb
+LMDB_LIB_DEPENDS= liblmdb.so:${PORTSDIR}/databases/lmdb
+
LUA_DESC= Describe filter policy with lua
+LUA_CONFIGURE_WITH= lua
+LUA_USES= lua
+
MEMCACHED_DESC= Use memcached as a data set
+MEMCACHED_CONFIGURE_WITH= libmemcached
+MEMCACHED_LIB_DEPENDS= libmemcached.so:${PORTSDIR}/databases/libmemcached
+
BDB_BASE_DESC= Use Berkeley DB from base
+
OPENDBX_DESC= Store filter policies via OpenDBX
+OPENDBX_CONFIGURE_WITH= odbx
+OPENDBX_LIB_DEPENDS= libopendbx.so:${PORTSDIR}/databases/opendbx
+
OPENLDAP_DESC= Store filter policies in LDAP
+OPENLDAP_CONFIGURE_WITH=openldap
+OPENLDAP_USE= OPENLDAP=yes
+
POPAUTH_DESC= Use POP authentication DB
+POPAUTH_CONFIGURE_ENABLE= popauth
+
QUERY_CACHE_DESC= Cache DNS query results locally
-STATS_DESC= Setup statistics tools
-DEBUG_DESC= Build with debug symbols
+QUERY_CACHE_CONFIGURE_ENABLE= query_cache
+
+SASL_DESC= Enable SASL authentication with LDAP
+SASL_CONFIGURE_WITH= sasl
+
+DOCS_CONFIGURE_ON= --docdir=${WRKDIR}/doc
MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
.include "${.CURDIR}/Makefile.options"
+
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MSASL} && ${PORT_OPTIONS:MOPENLDAP}
+WANT_OPENLDAP_SASL= yes
+.endif
+
.if ${PORT_OPTIONS:MFILTER}
-USE_RC_SUBR= milter-opendkim
-PLIST_SUB+= FILTER=""
SUB_FILES= pkg-message
WITHOUT_MILTER_CFLAGS= yes
WITHOUT_MILTER_LDFLAGS= yes
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
CONFIGURE_ARGS+= --with-milter=${MILTERBASE}
-.else
-CONFIGURE_ARGS+= --disable-filter
-PLIST_SUB+= FILTER="@comment "
.endif
-.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --with-gnutls=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.if ${PORT_OPTIONS:MLUA_ONLY_SIGNING} || \
+ ${PORT_OPTIONS:MRBL}
+.if !${PORT_OPTIONS:MLUA}
+IGNORE= Options LUA_ONLY_SIGNING and RBL require LUA as well
.endif
-
-.include "${.CURDIR}/Makefile.features"
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
.endif
-.if ! ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+=--docdir=${WRKDIR}/doc
+.if ${PORT_OPTIONS:MREPUTATION}
+.if !${PORT_OPTIONS:MCURL} || !${PORT_OPTIONS:MJANNSON}
+IGNORE= Option REPUTATION requires CURL and JANSSON as well
+.endif
.endif
-.if ${PORT_OPTIONS:MSTATS}
-CONFIGURE_ARGS+= --enable-stats
-PLIST_SUB+= STATS=""
-.else
-PLIST_SUB+= STATS="@comment "
+.if ${PORT_OPTIONS:MSTATSEXT}
+.if !${PORT_OPTIONS:MSTATS} || !${PORT_OPTIONS:MLUA}
+IGNORE= Option STATSEXT requires STATS and LUA as well
.endif
-.if ${PORT_OPTIONS:MPOPAUTH} \
- || ${PORT_OPTIONS:MQUERY_CACHE} \
- || (${PORT_OPTIONS:MFFR} && ${PORT_OPTIONS:MLDAP_CACHING} ) \
- || (${PORT_OPTIONS:MFFR} && ${PORT_OPTIONS:MREPUTATION} ) \
+.endif
+
+.if ${PORT_OPTIONS:MPOPAUTH} \
+ || ${PORT_OPTIONS:MQUERY_CACHE} \
+ || ${PORT_OPTIONS:MLDAP_CACHING} \
+ || ${PORT_OPTIONS:MREPUTATION} \
|| ${PORT_OPTIONS:MSTATS}
. if ${PORT_OPTIONS:MBDB_BASE}
CONFIGURE_ARGS+= --with-db-lib=c
. else
CONFIGURE_ARGS+= --with-db-incdir=${BDB_INCLUDE_DIR} \
- --with-db-libdir=${BDB_LIB_DIR} \
+ --with-db-libdir=${BDB_LIB_DIR} \
--with-db-lib=${BDB_LIB_NAME}
USE_BDB= 40+
. endif
.endif
-.if ${PORT_OPTIONS:MUNBOUND}
-CONFIGURE_ARGS+= --with-unbound
-LIB_DEPENDS+= libunbound.so:${PORTSDIR}/dns/unbound
-.endif
-.if ${PORT_OPTIONS:MPOPAUTH}
-CONFIGURE_ARGS+= --enable-popauth
-.endif
-.if ${PORT_OPTIONS:MQUERY_CACHE}
-CONFIGURE_ARGS+= --enable-query_cache
-.endif
-.if ${PORT_OPTIONS:MMEMCACHED}
-CONFIGURE_ARGS+= --with-libmemcached
-LIB_DEPENDS+= libmemcached.so:${PORTSDIR}/databases/libmemcached
-.else
-CONFIGURE_ARGS+= --without-libmemcached
-.endif
-.if ${PORT_OPTIONS:MOPENDBX}
-CONFIGURE_ARGS+= --with-odbx
-LIB_DEPENDS+= libopendbx.so:${PORTSDIR}/databases/opendbx
-PLIST_SUB+= ODBX=""
-.else
-CONFIGURE_ARGS+= --without-odbx
-PLIST_SUB+= ODBX="@comment "
-.endif
-.if ${PORT_OPTIONS:MOPENLDAP}
-CONFIGURE_ARGS+= --with-openldap
-LIB_DEPENDS+= libldap.so:${PORTSDIR}/net/openldap24-sasl-client
-USE_OPENLDAP= yes
-.else
-CONFIGURE_ARGS+= --without-openldap
-.endif
-.if ${PORT_OPTIONS:MLUA}
-CONFIGURE_ARGS+= --with-lua
-PLIST_SUB+= LUA=""
-USES+= lua
-.else
-PLIST_SUB+= LUA="@comment "
-.endif
pre-configure:
- ${REINPLACE_CMD} -e '/PKG_CONFIG/s/lua5\.2/lua-${LUA_VER}/' \
- -e '/PKG_CONFIG/s/cyrussasl/libsasl2/' \
- ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e '/LIBLUA_LIBS/s/lua5\.[0-9]/lua-${LUA_VER}/' \
+ -e '/PKG_CONFIG/s/lua5\.[0-9]/lua-${LUA_VER}/' \
+ -e '/PKG_CONFIG/s/cyrussasl/libsasl2/' \
+ ${WRKSRC}/configure
post-patch:
.if ${PORT_OPTIONS:MLCOV}
@@ -158,12 +165,9 @@ post-patch:
.endif
post-install:
-.if ! ${PORT_OPTIONS:MDEBUG} && ${PORT_OPTIONS:MFILTER}
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/opendkim
-.endif
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopendkim.so.9
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/mail
- ${INSTALL_DATA} ${WRKSRC}/opendkim/opendkim.conf.sample ${STAGEDIR}${PREFIX}/etc/mail/
+ ${INSTALL_DATA} ${WRKSRC}/opendkim/opendkim.conf.sample \
+ ${STAGEDIR}${PREFIX}/etc/mail/
regression-test: build
cd ${WRKSRC} ; ${MAKE} check
diff --git a/mail/opendkim/Makefile.features b/mail/opendkim/Makefile.features
deleted file mode 100644
index b2af387aa483..000000000000
--- a/mail/opendkim/Makefile.features
+++ /dev/null
@@ -1,168 +0,0 @@
-# Created by: Hirohisa Yamaguchi <umq@ueo.co.jp>
-# $FreeBSD$
-
-# This file is used to tune build time options.
-# Please refer FEATURES file distributed with the source for details.
-
-.if ${PORT_OPTIONS:MFFR}
-
-.if ${PORT_OPTIONS:MADSP_LISTS}
-CONFIGURE_ARGS+= --enable-adsp_lists
-.endif
-
-.if ${PORT_OPTIONS:MALLSYMBOLS}
-CONFIGURE_ARGS+= --enable-allsymbols
-.endif
-
-.if ${PORT_OPTIONS:MATPS}
-CONFIGURE_ARGS+= --enable-atps
-MAN8+= opendkim-atpszone.8
-PLIST_SUB+= ATPS=""
-.else
-PLIST_SUB+= ATPS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MCODECOVERAGE}
-CONFIGURE_ARGS+= --enable-codecoverage
-.endif
-
-.if ${PORT_OPTIONS:MDB_HANDLE_POOLS}
-CONFIGURE_ARGS+= --enable-db_handle_pools
-.endif
-
-.if ${PORT_OPTIONS:MDEFAULT_SENDER}
-CONFIGURE_ARGS+= --enable-default_sender
-.endif
-
-.if ${PORT_OPTIONS:MDIFFHEADERS}
-CONFIGURE_ARGS+= --enable-diffheaders
-LIB_DEPENDS+= libtre.so:${PORTSDIR}/textproc/libtre
-.else
-CONFIGURE_ARGS+= --without-tre
-.endif
-
-.if ${PORT_OPTIONS:MDKIM_REPUTATION}
-CONFIGURE_ARGS+= --enable-dkim_reputation
-MAN3+= dkim-rep.3
-PLIST_SUB+= DKIMREP=""
-.else
-PLIST_SUB+= DKIMREP="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MERLANG}
-BUILD_DEPENDS+= erl:${PORTSDIR}/lang/erlang
-CONFIGURE_ARGS+= --with-erlang
-.else
-CONFIGURE_ARGS+= --without-erlang
-.endif
-
-.if ${PORT_OPTIONS:MIDENTITY_HEADER}
-CONFIGURE_ARGS+= --enable-identity_header
-.endif
-
-.if ${PORT_OPTIONS:MLCOV}
-BROKEN= Does not install
-BUILD_DEPENDS+= lcov:${PORTSDIR}/devel/lcov \
- p5-GD>=0:${PORTSDIR}/graphics/p5-GD
-CONFIGURE_ARGS+= --with-lcov
-.else
-CONFIGURE_ARGS+= --without-lcov
-.endif
-
-.if ${PORT_OPTIONS:MLDAP_CACHING}
-WITH_OPENLDAP= yes
-CONFIGURE_ARGS+= --enable-ldap_caching
-.endif
-
-.if ${PORT_OPTIONS:MPOSTGRES_RECONNECT_HACK}
-CONFIGURE_ARGS+= --enable-postgresql_reconnect_hack
-.endif
-
-.if ${PORT_OPTIONS:MRATE_LIMIT}
-CONFIGURE_ARGS+= --enable-rate_limit
-.endif
-
-.if ${PORT_OPTIONS:MRBL}
-CONFIGURE_ARGS+= --enable-rbl
-MAN3+= rbl.3
-PLIST_SUB+= RBL=""
-PORT_OPTIONS+= LUA
-.else
-PLIST_SUB+= RBL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MREDIRECT}
-CONFIGURE_ARGS+= --enable-redirect
-.endif
-
-.if ${PORT_OPTIONS:MREPLACE_RULES}
-CONFIGURE_ARGS+= --enable-replace_rules
-.endif
-
-.if ${PORT_OPTIONS:MREPRRD}
-CONFIGURE_ARGS+= --enable-reprrd
-MAN8+= opendkim-reprrdimport.8
-PLIST_SUB+= REPRRD=""
-BUILD_DEPENDS+= rrdtool>=0:${PORTSDIR}/databases/rrdtool
-.else
-CONFIGURE_ARGS+= --disable-reprrd
-PLIST_SUB+= REPRRD="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MREPUTATION}
-CONFIGURE_ARGS+= --enable-reputation \
- --with-libcurl
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-. if ${PORT_OPTIONS:MXML}
-CONFIGURE_ARGS+= --without-libjansson --with-libxml2
-LIB_DEPENDS+= libxml2.so:${PORTSDIR}/textproc/libxml2
-PLIST_SUB+= JANSSON="@comment "
-. else
-CONFIGURE_ARGS+= --with-libjansson
-LIB_DEPENDS+= libjansson.so:${PORTSDIR}/devel/jansson
-MAN8+= autobuild.8
-PLIST_SUB+= JANSSON=""
-. endif
-MAN3+= ut.3
-MAN8+= opendkim-genrates.8 opendkim-modtotals.8 \
- opendkim-rephistory.8
-PLIST_SUB+= REPUTE=""
-.else
-CONFIGURE_ARGS+= --without-libcurl
-PLIST_SUB+= REPUTE="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MRESIGN}
-CONFIGURE_ARGS+= --enable-resign
-.endif
-
-.if ${PORT_OPTIONS:MSENDER_MACRO}
-CONFIGURE_ARGS+= --enable-sender_macro
-.endif
-
-.if ${PORT_OPTIONS:MSOCKETDB}
-CONFIGURE_ARGS+= --enable-socketdb
-.endif
-
-.if ${PORT_OPTIONS:MSTATSEXT}
-CONFIGURE_ARGS+= --enable-statsext
-PORT_OPTIONS+= LUA STATS
-.endif
-
-.if ${PORT_OPTIONS:MVBR}
-CONFIGURE_ARGS+= --enable-vbr
-MAN3+= vbr.3
-PLIST_SUB+= VBR=""
-.else
-PLIST_SUB+= VBR="@comment "
-.endif
-
-.else # ${PORT_OPTIONS:MFFR}
-PLIST_SUB+= ATPS="@comment "
-PLIST_SUB+= DKIMREP="@comment "
-PLIST_SUB+= RBL="@comment "
-PLIST_SUB+= REPRRD="@comment "
-PLIST_SUB+= JANSSON="@comment "
-PLIST_SUB+= REPUTE="@comment "
-PLIST_SUB+= VBR="@comment "
-.endif # ${PORT_OPTIONS:MFFR}
diff --git a/mail/opendkim/Makefile.options b/mail/opendkim/Makefile.options
index 42d889629a37..5508aa13fef2 100644
--- a/mail/opendkim/Makefile.options
+++ b/mail/opendkim/Makefile.options
@@ -2,42 +2,95 @@
# $FreeBSD$
# This file is used to tune build time options.
-# Please refer FEATURES file distributed with the source for details.
-OPTIONS_DEFINE+= FFR
+OPTIONS_GROUP+= DEVELOPER
+DEVELOPER_DESC= Options useful for OpenDKIM development
+
+OPTIONS_GROUP_DEVELOPER= ALLSYMBOLS CODECOVERAGE DEBUG
+
+ALLSYMBOLS_DESC= Export all internal symbols for better test coverage
+ALLSYMBOLS_CONFIGURE_ENABLE= allsymbols
+
+CODECOVERAGE_DESC= Enable internal code-coverage/profiling
+CODECOVERAGE_CONFIGURE_ENABLE= codecoverage
+
+DEBUG_DESC= Build with debug symbols
+DEBUG_CONFIGURE_ENABLE= debug
+
+## Please refer FEATURES file distributed with the source for details.
+
FFR_DESC= Use features marked as For-Future-Releases
OPTIONS_GROUP+= FFR
-OPTIONS_GROUP_FFR= ADSP_LISTS ALLSYMBOLS ATPS CODECOVERAGE \
- DB_HANDLE_POOLS DEFAULT_SENDER DIFFHEADERS \
- DKIM_REPUTATION ERLANG IDENTITY_HEADER LCOV \
+
+## _FFR_DNSSEC is referenced in the code, but does not appear to do
+## anything much.
+
+OPTIONS_GROUP_FFR= ADSP_LISTS ATPS DB_HANDLE_POOLS \
+ DEFAULT_SENDER DIFFHEADERS IDENTITY_HEADER \
LDAP_CACHING POSTGRES_RECONNECT_HACK \
- RATE_LIMIT RBL REDIRECT REPLACE_RULES REPRRD \
- REPUTATION RESIGN SENDER_MACRO SOCKETDB \
- STATSEXT VBR XML
+ RATE_LIMIT RBL REPLACE_RULES REPRRD \
+ REPUTATION RESIGN SENDER_MACRO \
+ SOCKETDB STATS STATSEXT VBR
ADSP_LISTS_DESC= ADSP filtering for lists (experimental)
-ALLSYMBOLS_DESC= Export internal symbols for test
+ADSP_LISTS_CONFIGURE_ENABLE= adsp_lists
+
ATPS_DESC= Authorized Third Party Sign check
-CODECOVERAGE_DESC= Include coverage/profile code
+ATPS_CONFIGURE_ENABLE= atps
+
DB_HANDLE_POOLS_DESC= Database handle pools (experimental)
+DB_HANDLE_POOLS_CONFIGURE_ENABLE= db_handle_pools
+
DEFAULT_SENDER_DESC= Default sender address
+DEFAULT_SENDER_CONFIGURE_ENABLE=default_sender
+
DIFFHEADERS_DESC= Compare signed and verified headers (experimental)
-DKIM_REPUTATION_DESC= DKIM reputation check (experimental)
-ERLANG_DESC= Support for Erlang datasets
+DIFFHEADERS_CONFIGURE_ENABLE= diffheaders
+
IDENTITY_HEADER_DESC= Special header to set identity
-LCOV_DESC= Profiling with LCOV
+IDENTITY_HEADER_CONFIGURE_ENABLE= identity_header
+
LDAP_CACHING_DESC= LDAP query piggybacking and caching
+LDAP_CACHING_CONFIGURE_ENABLE= ldap_caching
+LDAP_CACHING_USE= OPENLDAP=yes
+
+LUA_ONLY_SIGNING= Message signing by Lua only
+LUA_ONLY_SIGNING_CONFIGURE_ENABLE= lua_only_signing
+
POSTGRES_RECONNECT_HACK_DESC= PostgreSQL connection error detection bug hack
+POSTGRES_RECONNECT_HACK_CONFIGURE_ENABLE= postgresql_reconnect_hack
+
RATE_LIMIT_DESC= DKIM based rate limiting support
+RATE_LIMIT_CONFIGURE_ENABLE= rate_limit
+
RBL_DESC= Realtime Blacklist query support
-REDIRECT_DESC= Redirecting failed verification to a mailbox
+RBL_CONFIGURE_ENABLE= rbl
+
REPLACE_RULES_DESC= String substition when signing
+REPLACE_RULES_CONFIGURE_ENABLE= replace_rules
+
REPRRD_DESC= Support for collaborative reputation that uses rrdtool (experimental)
+REPRRD_CONFIGURE_ENABLE= reprrd
+REPRRD_LIB_DEPENDS= librrd.so:${PORTSDIR}/databases/rrdtool
+
REPUTATION_DESC= Reputation check (experimental)
+REPUTATION_CONFIGURE_ENABLE= reputation
+
RESIGN_DESC= One-step resigning
+RESIGN_CONFIGURE_ENABLE= resign
+
SENDER_MACRO_DESC= Macro to determine sender
+SENDER_MACRO_CONFIGURE_ENABLE= sender_macro
+
SOCKETDB_DESC= Arbitrary socket data sets
-STATSEXT_DESC= Extended stats
+SOCKETDB_CONFIGURE_ENABLE= socketdb
+
+STATS_DESC= Per-message and per-signature statistics
+STATS_CONFIGURE_ENABLE= stats
+
+STATSEXT_DESC= Localized stats extensions
+STATSEXT_CONFIGURE_ENABLE= statsext
+
VBR_DESC= Vouch-By-Reference support
-XML_DESC= Prefer textproc/libxml2 to devel/jansson for JSON processing
+VBR_CONFIGURE_ENABLE= vbr
diff --git a/mail/opendkim/distinfo b/mail/opendkim/distinfo
index 96a9e8bd60ad..de58b8ab9eb1 100644
--- a/mail/opendkim/distinfo
+++ b/mail/opendkim/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opendkim-2.8.3.tar.gz) = eb36003b0d2d7514312c65db2b45afd9ce4d02744fbf4b2fe6f8e1e2893ce989
-SIZE (opendkim-2.8.3.tar.gz) = 1182214
+SHA256 (opendkim-2.9.2.tar.gz) = 1f0c66afbe48f6223d2ab985b2c27594ae45035e3e81eba887d8ec6e5e1282c0
+SIZE (opendkim-2.9.2.tar.gz) = 1229383
diff --git a/mail/opendkim/files/patch-librbl__rbl.c b/mail/opendkim/files/patch-librbl__rbl.c
deleted file mode 100644
index bce732b45bdc..000000000000
--- a/mail/opendkim/files/patch-librbl__rbl.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./librbl/rbl.c.orig 2012-10-25 07:12:31.000000000 +0900
-+++ ./librbl/rbl.c 2013-03-21 02:26:41.000000000 +0900
-@@ -312,6 +312,7 @@
-
- free(tmp);
- #endif /* HAVE_RES_SETSERVERS */
-+ return 0;
- }
-
- /*
diff --git a/mail/opendkim/files/patch-opendkim__opendkim.c b/mail/opendkim/files/patch-opendkim__opendkim.c
deleted file mode 100644
index 6c75b0d31e17..000000000000
--- a/mail/opendkim/files/patch-opendkim__opendkim.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./opendkim/opendkim.c.orig 2013-03-20 03:02:40.000000000 +0900
-+++ ./opendkim/opendkim.c 2013-03-21 02:47:29.000000000 +0900
-@@ -12421,7 +12421,7 @@
- {
- syslog(LOG_INFO,
- "%s: can't parse default sender value '%s'",
-- dfc->mctx_jobid, from);
-+ dfc->mctx_jobid, conf->conf_defsender);
- }
- #endif /* _FFR_DEFAULT_SENDER */
- }
-@@ -14945,8 +14945,8 @@
- for (c = 0; c < nsigs && domain == NULL; c++)
- {
- if ((dkim_sig_getflags(sigs[c]) & DKIM_SIGFLAG_PASSED) == 0 ||
-- (dkim_sig_getflags(sigs[c]) & DKIM_SIGFLAG_TESTKEY) != 0 &&
-- dkim_sig_getbh(sigs[c]) != DKIM_SIGBH_MATCH)
-+ ((dkim_sig_getflags(sigs[c]) & DKIM_SIGFLAG_TESTKEY) != 0 &&
-+ dkim_sig_getbh(sigs[c]) != DKIM_SIGBH_MATCH))
- continue;
-
- cd = dkim_sig_getdomain(sigs[c]);
-@@ -15121,8 +15121,8 @@
- for (c = 0; c < nsigs; c++)
- {
- if ((dkim_sig_getflags(sigs[c]) & DKIM_SIGFLAG_PASSED) == 0 ||
-- (dkim_sig_getflags(sigs[c]) & DKIM_SIGFLAG_TESTKEY) != 0 &&
-- dkim_sig_getbh(sigs[c]) != DKIM_SIGBH_MATCH)
-+ ((dkim_sig_getflags(sigs[c]) & DKIM_SIGFLAG_TESTKEY) != 0 &&
-+ dkim_sig_getbh(sigs[c]) != DKIM_SIGBH_MATCH))
- continue;
-
- checked = TRUE;
diff --git a/mail/opendkim/pkg-plist b/mail/opendkim/pkg-plist
index 0d1fa1b7113e..59675ad4124c 100644
--- a/mail/opendkim/pkg-plist
+++ b/mail/opendkim/pkg-plist
@@ -1,94 +1,83 @@
-%%REPUTE%%%%JANSSON%%bin/autobuild
+%%ATPS%%man/man8/opendkim-atpszone.8.gz
+%%ATPS%%sbin/opendkim-atpszone
+%%FILTER%%man/man5/opendkim.conf.5.gz
+%%FILTER%%man/man8/opendkim.8.gz
+%%FILTER%%sbin/opendkim
+%%JANSSON%%bin/autobuild
+%%JANSSON%%man/man8/autobuild.8.gz
+%%LUA%%%%FILTER%%man/man3/opendkim-lua.3.gz
%%LUA%%bin/miltertest
-%%REPRRD%%bin/opendkim-reprrdimport
-%%ODBX%%%%STATS%%bin/opendkim-spam
-etc/mail/opendkim.conf.sample
-%%DKIMREP%%include/dkim-rep/dkim-rep.h
-include/opendkim/dkim.h
+%%LUA%%man/man3/opendkim-lua.3.gz
+%%LUA%%man/man8/miltertest.8.gz
+%%OPENDBX%%%%STATS%%bin/opendkim-spam
+%%OPENDBX%%%%STATS%%sbin/opendkim-importstats
%%RBL%%include/rbl/rbl.h
-%%REPRRD%%include/reprrd/reprrd.h
-%%REPUTE%%include/repute/repute.h
-%%REPUTE%%include/ut/ut.h
-%%VBR%%include/vbr/vbr.h
-%%DKIMREP%%lib/libdkimrep.a
-%%DKIMREP%%lib/libdkimrep.la
-%%DKIMREP%%lib/libdkimrep.so
-%%DKIMREP%%lib/libdkimrep.so.1
-lib/libopendkim.a
-lib/libopendkim.la
-lib/libopendkim.so
-lib/libopendkim.so.9
%%RBL%%lib/librbl.a
-%%RBL%%lib/librbl.la
%%RBL%%lib/librbl.so
%%RBL%%lib/librbl.so.1
+%%RBL%%libdata/pkgconfig/rbl.pc
+%%RBL%%man/man3/rbl.3.gz
+%%REPRRD%%bin/opendkim-reprrdimport
+%%REPRRD%%include/reprrd/reprrd.h
%%REPRRD%%lib/libreprrd.a
-%%REPRRD%%lib/libreprrd.la
%%REPRRD%%lib/libreprrd.so
%%REPRRD%%lib/libreprrd.so.1
-%%REPUTE%%lib/librepute.a
-%%REPUTE%%lib/librepute.la
-%%REPUTE%%lib/librepute.so
-%%REPUTE%%lib/librepute.so.1
-%%REPUTE%%lib/libut.a
-%%REPUTE%%lib/libut.la
-%%REPUTE%%lib/libut.so
-%%REPUTE%%lib/libut.so.1
-%%VBR%%lib/libvbr.a
-%%VBR%%lib/libvbr.la
-%%VBR%%lib/libvbr.so
-%%VBR%%lib/libvbr.so.2
-%%DKIMREP%%libdata/pkgconfig/dkim-rep.pc
-libdata/pkgconfig/opendkim.pc
-%%RBL%%libdata/pkgconfig/rbl.pc
-%%REPUTE%%libdata/pkgconfig/repute.pc
-%%REPUTE%%libdata/pkgconfig/ut.pc
-%%VBR%%libdata/pkgconfig/vbr.pc
-%%FILTER%%sbin/opendkim
-%%ATPS%%sbin/opendkim-atpszone
+%%REPRRD%%man/man8/opendkim-reprrdimport.8.gz
+%%REPUTATION%%include/repute/repute.h
+%%REPUTATION%%include/ut/ut.h
+%%REPUTATION%%lib/librepute.a
+%%REPUTATION%%lib/librepute.so
+%%REPUTATION%%lib/librepute.so.1
+%%REPUTATION%%lib/libut.a
+%%REPUTATION%%lib/libut.so
+%%REPUTATION%%lib/libut.so.1
+%%REPUTATION%%libdata/pkgconfig/repute.pc
+%%REPUTATION%%libdata/pkgconfig/ut.pc
+%%REPUTATION%%man/man3/ut.3.gz
+%%REPUTATION%%man/man8/opendkim-genrates.8.gz
+%%REPUTATION%%man/man8/opendkim-modtotals.8.gz
+%%REPUTATION%%man/man8/opendkim-rephistory.8.gz
+%%REPUTATION%%sbin/opendkim-genrates
+%%REPUTATION%%sbin/opendkim-modtotals
+%%REPUTATION%%sbin/opendkim-rephistory
+%%STATS%%%%OPENDBX%%man/man1/opendkim-spam.1.gz
+%%STATS%%%%OPENDBX%%man/man8/opendkim-importstats.8.gz
+%%STATS%%man/man8/opendkim-expire.8.gz
+%%STATS%%man/man8/opendkim-gengraphs.8.gz
+%%STATS%%man/man8/opendkim-genstats.8.gz
+%%STATS%%man/man8/opendkim-stats.8.gz
%%STATS%%sbin/opendkim-expire
%%STATS%%sbin/opendkim-gengraphs
-sbin/opendkim-genkey
-%%REPUTE%%sbin/opendkim-genrates
%%STATS%%sbin/opendkim-genstats
-sbin/opendkim-genzone
-%%ODBX%%%%STATS%%sbin/opendkim-importstats
-%%REPUTE%%sbin/opendkim-modtotals
-%%REPUTE%%sbin/opendkim-rephistory
%%STATS%%sbin/opendkim-reportstats
%%STATS%%sbin/opendkim-stats
-%%LUA%%%%FILTER%%man/man3/opendkim-lua.3.gz
-%%FILTER%%man/man5/opendkim.conf.5.gz
-%%LUA%%man/man8/miltertest.8.gz
+%%VBR%%include/vbr/vbr.h
+%%VBR%%lib/libvbr.a
+%%VBR%%lib/libvbr.so
+%%VBR%%lib/libvbr.so.2
+%%VBR%%libdata/pkgconfig/vbr.pc
+%%VBR%%man/man3/vbr.3.gz
+@sample etc/mail/opendkim.conf.sample
+include/opendkim/dkim.h
+lib/libopendkim.a
+lib/libopendkim.so
+lib/libopendkim.so.9
+lib/libopendkim.so.9.0.3
+libdata/pkgconfig/opendkim.pc
man/man8/opendkim-genkey.8.gz
man/man8/opendkim-genzone.8.gz
man/man8/opendkim-testadsp.8.gz
man/man8/opendkim-testkey.8.gz
man/man8/opendkim-testmsg.8.gz
-man/man8/opendkim.8.gz
+sbin/opendkim-genkey
+sbin/opendkim-genzone
sbin/opendkim-testadsp
sbin/opendkim-testkey
sbin/opendkim-testmsg
%%VBR%%@dirrm include/vbr
-%%REPUTE%%@dirrm include/ut
-%%REPUTE%%@dirrm include/repute
+%%REPUTATION%%@dirrm include/ut
+%%REPUTATION%%@dirrm include/repute
%%REPRRD%%@dirrm include/reprrd
%%RBL%%@dirrm include/rbl
@dirrm include/opendkim
-%%DKIMREP%%@dirrm include/dkim-rep
@dirrmtry etc/mail
-%%FILTER%%man/man5/opendkim.conf.5.gz
-%%LUA%%man/man8/miltertest.8.gz
-man/man8/opendkim-genkey.8.gz
-man/man8/opendkim-genzone.8.gz
-man/man8/opendkim-testadsp.8.gz
-man/man8/opendkim-testkey.8.gz
-man/man8/opendkim-testmsg.8.gz
-%%FILTER%%man/man8/opendkim.8.gz
-%%LUA%%%%FILTER%%man/man3/opendkim-lua.3.gz
-%%STATS%%man/man8/opendkim-expire.8.gz
-%%STATS%%man/man8/opendkim-gengraphs.8.gz
-%%STATS%%man/man8/opendkim-genstats.8.gz
-%%STATS%%man/man8/opendkim-stats.8.gz
-%%STATS%%%%ODBX%%man/man1/opendkim-spam.1.gz
-%%STATS%%%%ODBX%%man/man8/opendkim-importstats.8.gz