aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/p5-AnyEvent-HTTPD/Makefile3
-rw-r--r--www/p5-CGI-Application-PSGI/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-ValidateRM/Makefile3
-rw-r--r--www/p5-CGI-Session/Makefile3
-rw-r--r--www/p5-CSS-Inliner/Makefile3
-rw-r--r--www/p5-Catalyst-View-JSON/Makefile3
-rw-r--r--www/p5-CatalystX-Component-Traits/Makefile3
-rw-r--r--www/p5-Dancer-Plugin-SiteMap/Makefile3
-rw-r--r--www/p5-Fliggy/Makefile3
-rw-r--r--www/p5-Gtk2-WebKit/Makefile3
-rw-r--r--www/p5-HTML-FormFu-Model-DBIC/Makefile3
-rw-r--r--www/p5-HTML-FromText/Makefile3
-rw-r--r--www/p5-HTML-LinkExtractor/Makefile3
-rw-r--r--www/p5-Plack-Middleware-Auth-Digest/Makefile3
-rw-r--r--www/p5-Squatting-On-PSGI/Makefile3
-rw-r--r--www/p5-Template-Stash-AutoEscape/Makefile3
-rw-r--r--www/p5-W3C-LogValidator/Makefile3
-rw-r--r--www/p5-WWW-Google-News-TW/Makefile3
-rw-r--r--www/surfraw/Makefile2
19 files changed, 37 insertions, 19 deletions
diff --git a/www/p5-AnyEvent-HTTPD/Makefile b/www/p5-AnyEvent-HTTPD/Makefile
index 609f67b4e7b4..4cb4cde7729d 100644
--- a/www/p5-AnyEvent-HTTPD/Makefile
+++ b/www/p5-AnyEvent-HTTPD/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
p5-common-sense>=2.0:${PORTSDIR}/devel/p5-common-sense \
p5-URI>=1.40:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::HTTPD.3 AnyEvent::HTTPD::Request.3 AnyEvent::HTTPD::Util.3 AnyEvent::HTTPD::HTTPServer.3 AnyEvent::HTTPD::HTTPConnection.3
diff --git a/www/p5-CGI-Application-PSGI/Makefile b/www/p5-CGI-Application-PSGI/Makefile
index 14a13902f5bf..e8a736ab221b 100644
--- a/www/p5-CGI-Application-PSGI/Makefile
+++ b/www/p5-CGI-Application-PSGI/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-CGI-PSGI>0:${PORTSDIR}/www/p5-CGI-PSGI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Application::PSGI.3
diff --git a/www/p5-CGI-Application-Plugin-ValidateRM/Makefile b/www/p5-CGI-Application-Plugin-ValidateRM/Makefile
index d4e7c4c2ca4a..6fc48e2fb3bd 100644
--- a/www/p5-CGI-Application-Plugin-ValidateRM/Makefile
+++ b/www/p5-CGI-Application-Plugin-ValidateRM/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-HTML-FillInForm>=0:${PORTSDIR}/www/p5-HTML-FillInForm \
p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/www/p5-CGI-Session/Makefile b/www/p5-CGI-Session/Makefile
index bbe7347ac08f..f06b7bfd82ef 100644
--- a/www/p5-CGI-Session/Makefile
+++ b/www/p5-CGI-Session/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for persistent session management
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= \
CGI::Session.3 \
diff --git a/www/p5-CSS-Inliner/Makefile b/www/p5-CSS-Inliner/Makefile
index 31bbab29e662..3cc498fe2b4e 100644
--- a/www/p5-CSS-Inliner/Makefile
+++ b/www/p5-CSS-Inliner/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CSS::Inliner.3 CSS::Inliner::Parser.3
PLIST_FILES= %%SITE_PERL%%/CSS/Inliner.pm \
diff --git a/www/p5-Catalyst-View-JSON/Makefile b/www/p5-Catalyst-View-JSON/Makefile
index 1af397395f59..a3cf3aaedf8b 100644
--- a/www/p5-Catalyst-View-JSON/Makefile
+++ b/www/p5-Catalyst-View-JSON/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.6000:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-MRO-Compat>0:${PORTSDIR}/devel/p5-MRO-Compat
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Helper::View::JSON.3 Catalyst::View::JSON.3
diff --git a/www/p5-CatalystX-Component-Traits/Makefile b/www/p5-CatalystX-Component-Traits/Makefile
index c36477c01ca7..2072a04c23bf 100644
--- a/www/p5-CatalystX-Component-Traits/Makefile
+++ b/www/p5-CatalystX-Component-Traits/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Catalyst-Runtime>=5.80005:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CatalystX::Component::Traits.3
diff --git a/www/p5-Dancer-Plugin-SiteMap/Makefile b/www/p5-Dancer-Plugin-SiteMap/Makefile
index 931b3f4da11b..db4a85bcd8bc 100644
--- a/www/p5-Dancer-Plugin-SiteMap/Makefile
+++ b/www/p5-Dancer-Plugin-SiteMap/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Dancer>=1.175:${PORTSDIR}/www/p5-Dancer \
RUN_DEPENDS= p5-Dancer>=1.175:${PORTSDIR}/www/p5-Dancer \
p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dancer::Plugin::SiteMap.3
diff --git a/www/p5-Fliggy/Makefile b/www/p5-Fliggy/Makefile
index 607784a3b1cb..e261ca665d44 100644
--- a/www/p5-Fliggy/Makefile
+++ b/www/p5-Fliggy/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Fliggy.3 \
Fliggy::Server.3 \
diff --git a/www/p5-Gtk2-WebKit/Makefile b/www/p5-Gtk2-WebKit/Makefile
index c5984eccb28c..3a1fe3c1ccc3 100644
--- a/www/p5-Gtk2-WebKit/Makefile
+++ b/www/p5-Gtk2-WebKit/Makefile
@@ -28,7 +28,8 @@ MAKE_JOBS_UNSAFE= yes
NO_PACKAGE= Man page creation hangs on some systems for unknown reasons
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::WebKit.3 \
Gtk2::WebKit::Download.3 \
diff --git a/www/p5-HTML-FormFu-Model-DBIC/Makefile b/www/p5-HTML-FormFu-Model-DBIC/Makefile
index ec63b41fbd25..85a85dc6ae8f 100644
--- a/www/p5-HTML-FormFu-Model-DBIC/Makefile
+++ b/www/p5-HTML-FormFu-Model-DBIC/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DateTime-Format-SQLite>=0:${PORTSDIR}/devel/p5-DateTime-Format-SQLite \
p5-SQL-Translator>=0:${PORTSDIR}/databases/p5-SQL-Translator
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::FormFu::Constraint::DBIC::Unique.3 \
HTML::FormFu::Model::DBIC.3
diff --git a/www/p5-HTML-FromText/Makefile b/www/p5-HTML-FromText/Makefile
index a3d8a59c67ed..2056b35a5082 100644
--- a/www/p5-HTML-FromText/Makefile
+++ b/www/p5-HTML-FromText/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Email-Find>=0.09:${PORTSDIR}/mail/p5-Email-Find \
p5-HTML-Parser>=1.26:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= text2html.1
MAN3= HTML::FromText.3
diff --git a/www/p5-HTML-LinkExtractor/Makefile b/www/p5-HTML-LinkExtractor/Makefile
index 56eb5d1f9e8b..fab0f29dd3d7 100644
--- a/www/p5-HTML-LinkExtractor/Makefile
+++ b/www/p5-HTML-LinkExtractor/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-HTML-TokeParser-Simple>=0:${PORTSDIR}/www/p5-HTML-TokeParser-S
p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::LinkExtractor.3
diff --git a/www/p5-Plack-Middleware-Auth-Digest/Makefile b/www/p5-Plack-Middleware-Auth-Digest/Makefile
index 7cbf976cf396..b78585e01103 100644
--- a/www/p5-Plack-Middleware-Auth-Digest/Makefile
+++ b/www/p5-Plack-Middleware-Auth-Digest/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-TCP>=0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::Auth::Digest.3
diff --git a/www/p5-Squatting-On-PSGI/Makefile b/www/p5-Squatting-On-PSGI/Makefile
index 7065ccb82007..58345cb8b492 100644
--- a/www/p5-Squatting-On-PSGI/Makefile
+++ b/www/p5-Squatting-On-PSGI/Makefile
@@ -23,7 +23,8 @@ TEST_DEPENDS= \
p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Squatting::On::PSGI.3
diff --git a/www/p5-Template-Stash-AutoEscape/Makefile b/www/p5-Template-Stash-AutoEscape/Makefile
index 42a4d395adb6..9eb7680ea37f 100644
--- a/www/p5-Template-Stash-AutoEscape/Makefile
+++ b/www/p5-Template-Stash-AutoEscape/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Stash::AutoEscape.3
diff --git a/www/p5-W3C-LogValidator/Makefile b/www/p5-W3C-LogValidator/Makefile
index 92a0f1f48e45..7b7b4ac11dbe 100644
--- a/www/p5-W3C-LogValidator/Makefile
+++ b/www/p5-W3C-LogValidator/Makefile
@@ -24,7 +24,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
${LOCALBASE}/bin/checklink:${PORTSDIR}/www/p5-W3C-LinkChecker
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= W3C::LogValidator.3 \
W3C::LogValidator::Basic.3 \
diff --git a/www/p5-WWW-Google-News-TW/Makefile b/www/p5-WWW-Google-News-TW/Makefile
index 1cfb0bfa0a4b..eb1ece7e21c1 100644
--- a/www/p5-WWW-Google-News-TW/Makefile
+++ b/www/p5-WWW-Google-News-TW/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Google::News::TW.3
diff --git a/www/surfraw/Makefile b/www/surfraw/Makefile
index 3ad8a47c7a1c..4cd01d4a3c31 100644
--- a/www/surfraw/Makefile
+++ b/www/surfraw/Makefile
@@ -10,7 +10,7 @@ COMMENT= Command line interface to popular WWW search engines
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
MAN1= elvi.1sr \
opensearch-discover.1 \