aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/wiimms/Makefile50
-rw-r--r--sysutils/wiimms/distinfo2
-rw-r--r--sysutils/wiimms/files/patch-setup-load-titles.sh20
-rw-r--r--sysutils/wiimms/files/patch-setup.sh31
-rw-r--r--sysutils/wiimms/pkg-descr4
-rw-r--r--sysutils/wiimms/pkg-plist20
7 files changed, 128 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 53bc8a0e8fbc..61b9448063ca 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -945,6 +945,7 @@
SUBDIR += weedit
SUBDIR += whatpix
SUBDIR += whowatch
+ SUBDIR += wiimms
SUBDIR += wmapm
SUBDIR += wmapmload
SUBDIR += wmbattery
diff --git a/sysutils/wiimms/Makefile b/sysutils/wiimms/Makefile
new file mode 100644
index 000000000000..9f7e2bd45c29
--- /dev/null
+++ b/sysutils/wiimms/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: wiimms
+# Date created: 4 august 2011
+# Whom: Olivier Cochard-Labbe <olivier@cochard.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wiimms
+PORTVERSION= 2.00
+CATEGORIES= sysutils
+MASTER_SITES= http://gugus69.free.fr/wiimms/ \
+ LOCAL/martymac
+DISTNAME= wit-${PORTVERSION}
+
+MAINTAINER= olivier@cochard.me
+COMMENT= Wiimms ISO Tools
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|g' \
+ ${WRKSRC}/*.sh \
+ ${WRKSRC}/scripts/*.sh \
+ ${WRKSRC}/setup/*.sh \
+ ${WRKSRC}/Makefile
+
+pre-configure:
+ @${CHMOD} +x ${WRKSRC}/setup.sh
+
+do-configure:
+ @cd ${WRKSRC} && ./setup.sh
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/wit ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/wwt ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/wdf ${PREFIX}/bin
+ @${LN} -sf wdf ${PREFIX}/bin/wdf-cat
+ @${LN} -sf wdf ${PREFIX}/bin/wdf-dump
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/share/* ${DATADIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/load-titles.sh ${DATADIR}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/wiimms/distinfo b/sysutils/wiimms/distinfo
new file mode 100644
index 000000000000..069a023f5b42
--- /dev/null
+++ b/sysutils/wiimms/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wit-2.00.tar.gz) = f0585ee24493200904616005d4b67c30b710058f8a424e1e6f6810301c14bc89
+SIZE (wit-2.00.tar.gz) = 1391309
diff --git a/sysutils/wiimms/files/patch-setup-load-titles.sh b/sysutils/wiimms/files/patch-setup-load-titles.sh
new file mode 100644
index 000000000000..5e3634ac6c99
--- /dev/null
+++ b/sysutils/wiimms/files/patch-setup-load-titles.sh
@@ -0,0 +1,20 @@
+--- setup/load-titles.sh.orig 2011-08-04 07:50:20.000000000 +0200
++++ setup/load-titles.sh 2011-08-04 07:51:47.000000000 +0200
+@@ -28,7 +28,7 @@
+
+ #------------------------------------------------------------------------------
+
+-NEEDED="wit wget tr"
++NEEDED="wit tr"
+
+ BASE_PATH="@@INSTALL-PATH@@"
+ SHARE_PATH="@@SHARE-PATH@@"
+@@ -68,7 +68,7 @@
+
+ echo "*** load $DEST from $URI"
+
+- if wget -q -O- "$URI" | wit titles / - >"$DEST.tmp" && test -s "$DEST.tmp"
++ if fetch -q -o- "$URI" | wit titles / - >"$DEST.tmp" && test -s "$DEST.tmp"
+ then
+ if [[ $ADD != "" ]]
+ then
diff --git a/sysutils/wiimms/files/patch-setup.sh b/sysutils/wiimms/files/patch-setup.sh
new file mode 100644
index 000000000000..76b178295ded
--- /dev/null
+++ b/sysutils/wiimms/files/patch-setup.sh
@@ -0,0 +1,31 @@
+--- setup.sh.orig 2011-07-08 20:21:46.000000000 +0200
++++ setup.sh 2011-08-04 01:55:05.000000000 +0200
+@@ -19,8 +19,9 @@
+ tim=($(date '+%s %Y-%m-%d %T'))
+
+ have_fuse=0
+-[[ $NO_FUSE != 1 && -r /usr/include/fuse.h || -r /usr/local/include/fuse.h ]] \
+- && have_fuse=1
++# TO DO: Fix fuse compilation (need to add a dependency to the port Makefile too
++#[[ $NO_FUSE != 1 && -r /usr/include/fuse.h || -r /usr/local/include/fuse.h ]] \
++# && have_fuse=1
+
+ if [[ $M32 = 1 ]]
+ then
+@@ -38,9 +39,13 @@
+ && grep -qw fallocate /usr/include/bits/fcntl.h \
+ && defines="$defines -DHAVE_FALLOCATE=1"
+
+-[[ -r /usr/include/fcntl.h ]] \
+- && grep -qw posix_fallocate /usr/include/fcntl.h \
+- && defines="$defines -DHAVE_POSIX_FALLOCATE=1"
++# Wrong test: FreeBSD fcntl.h include a comment with string "posix_fallocate"
++#[[ -r /usr/include/fcntl.h ]] \
++# && grep -qw posix_fallocate /usr/include/fcntl.h \
++# && defines="$defines -DHAVE_POSIX_FALLOCATE=1"
++
++# FreeBSD didn't support Pre-alloc
++defines="$defines -DNO_PREALLOC"
+
+ [[ $STATIC = 1 ]] || STATIC=0
+
diff --git a/sysutils/wiimms/pkg-descr b/sysutils/wiimms/pkg-descr
new file mode 100644
index 000000000000..cfd73fa664cd
--- /dev/null
+++ b/sysutils/wiimms/pkg-descr
@@ -0,0 +1,4 @@
+Wiimms ISO Tools is a set of command line tools to manipulate Wii and GameCube
+ISO images and WBFS containers.
+
+WWW: http://wit.wiimm.de
diff --git a/sysutils/wiimms/pkg-plist b/sysutils/wiimms/pkg-plist
new file mode 100644
index 000000000000..18b036a67f67
--- /dev/null
+++ b/sysutils/wiimms/pkg-plist
@@ -0,0 +1,20 @@
+bin/wdf
+bin/wdf-cat
+bin/wdf-dump
+bin/wit
+bin/wwt
+%%DATADIR%%/load-titles.sh
+%%DATADIR%%/system-menu.txt
+%%DATADIR%%/titles-de.txt
+%%DATADIR%%/titles-es.txt
+%%DATADIR%%/titles-fr.txt
+%%DATADIR%%/titles-it.txt
+%%DATADIR%%/titles-ja.txt
+%%DATADIR%%/titles-ko.txt
+%%DATADIR%%/titles-nl.txt
+%%DATADIR%%/titles-pt.txt
+%%DATADIR%%/titles-ru.txt
+%%DATADIR%%/titles-zhcn.txt
+%%DATADIR%%/titles-zhtw.txt
+%%DATADIR%%/titles.txt
+@dirrm %%DATADIR%%