aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/gtk20/Makefile1
-rw-r--r--x11-toolkits/gtk20/files/patch-gdk_x11_gdkwindow-x11.c17
-rw-r--r--x11-toolkits/gtk30/Makefile1
-rw-r--r--x11-toolkits/gtk30/files/patch-gdk_x11_gdkwindow-x11.c17
4 files changed, 36 insertions, 0 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 5a7f53baf5fc..058ca497c8b7 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.0,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
diff --git a/x11-toolkits/gtk20/files/patch-gdk_x11_gdkwindow-x11.c b/x11-toolkits/gtk20/files/patch-gdk_x11_gdkwindow-x11.c
new file mode 100644
index 000000000000..404e798d5bce
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gdk_x11_gdkwindow-x11.c
@@ -0,0 +1,17 @@
+This is a temporary patch. It is already in GNOME CVS, and will be merged in
+the next gtk+-2.0.x release. More details on what this patch fixes can be
+found at:
+
+http://bugzilla.gnome.org/show_bug.cgi?id=94806
+
+--- gdk/x11/gdkwindow-x11.c.orig Sat Nov 16 19:25:15 2002
++++ gdk/x11/gdkwindow-x11.c Sat Nov 16 19:26:16 2002
+@@ -202,6 +202,8 @@
+ &window_attributes);
+ drawable_impl->colormap =
+ gdk_colormap_lookup (window_attributes.colormap);
++ if (drawable_impl->colormap)
++ g_object_ref (drawable_impl->colormap);
+ }
+
+ return drawable_impl->colormap;
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 5a7f53baf5fc..058ca497c8b7 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.0,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
diff --git a/x11-toolkits/gtk30/files/patch-gdk_x11_gdkwindow-x11.c b/x11-toolkits/gtk30/files/patch-gdk_x11_gdkwindow-x11.c
new file mode 100644
index 000000000000..404e798d5bce
--- /dev/null
+++ b/x11-toolkits/gtk30/files/patch-gdk_x11_gdkwindow-x11.c
@@ -0,0 +1,17 @@
+This is a temporary patch. It is already in GNOME CVS, and will be merged in
+the next gtk+-2.0.x release. More details on what this patch fixes can be
+found at:
+
+http://bugzilla.gnome.org/show_bug.cgi?id=94806
+
+--- gdk/x11/gdkwindow-x11.c.orig Sat Nov 16 19:25:15 2002
++++ gdk/x11/gdkwindow-x11.c Sat Nov 16 19:26:16 2002
+@@ -202,6 +202,8 @@
+ &window_attributes);
+ drawable_impl->colormap =
+ gdk_colormap_lookup (window_attributes.colormap);
++ if (drawable_impl->colormap)
++ g_object_ref (drawable_impl->colormap);
+ }
+
+ return drawable_impl->colormap;