aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/kolourpaint/Makefile33
-rw-r--r--graphics/kolourpaint/distinfo2
-rw-r--r--graphics/kolourpaint/pkg-descr5
-rw-r--r--graphics/kolourpaint/pkg-plist132
5 files changed, 173 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 77df40ddd911..88c18a47cb64 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -193,6 +193,7 @@
SUBDIR += kisomandel
SUBDIR += kix-kmod
SUBDIR += kludge3d
+ SUBDIR += kolourpaint
SUBDIR += landscape
SUBDIR += lcms
SUBDIR += leafpak
diff --git a/graphics/kolourpaint/Makefile b/graphics/kolourpaint/Makefile
new file mode 100644
index 000000000000..41bddfa296f9
--- /dev/null
+++ b/graphics/kolourpaint/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: kolourpaint
+# Date created: Fri May 7 10:13:12 CEST 2004
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= kolourpaint
+PORTVERSION= 1.0.2
+CATEGORIES= graphics kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= Paint program for KDE
+
+LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype:${PORTSDIR}/print/freetype2 \
+ lcms:${PORTSDIR}/graphics/lcms
+
+USE_KDELIBS_VER=3
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g; s|^tagnames=|#tagnames=|g;' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11/kde3/Makefile.kde"
+.include <bsd.port.post.mk>
diff --git a/graphics/kolourpaint/distinfo b/graphics/kolourpaint/distinfo
new file mode 100644
index 000000000000..734a703b5a73
--- /dev/null
+++ b/graphics/kolourpaint/distinfo
@@ -0,0 +1,2 @@
+MD5 (kolourpaint-1.0.2.tar.bz2) = 27e4c5ca5c3e083a7384f81a7c7af534
+SIZE (kolourpaint-1.0.2.tar.bz2) = 817048
diff --git a/graphics/kolourpaint/pkg-descr b/graphics/kolourpaint/pkg-descr
new file mode 100644
index 000000000000..b5280b2eb38b
--- /dev/null
+++ b/graphics/kolourpaint/pkg-descr
@@ -0,0 +1,5 @@
+KolourPaint is an easy-to-use paint program for KDE. Features include
+undo/redo, more than a dozen tools, selections, transparent image
+editing and zoom support (with an optional grid and thumbnail).
+
+WWW: http://kolourpaint.sourceforge.net/
diff --git a/graphics/kolourpaint/pkg-plist b/graphics/kolourpaint/pkg-plist
new file mode 100644
index 000000000000..9010eaabe3e3
--- /dev/null
+++ b/graphics/kolourpaint/pkg-plist
@@ -0,0 +1,132 @@
+bin/kolourpaint
+share/applications/kde/kolourpaint.desktop
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_brush.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_color_picker.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_color_washer.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_curve.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_ellipse.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_elliptical_selection.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_eraser.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_flood_fill.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_free_form_selection.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_line.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_pen.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_polygon.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_polyline.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_rect_selection.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_rectangle.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_rounded_rectangle.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_spraycan.png
+share/apps/kolourpaint/icons/hicolor/16x16/actions/tool_text.png
+share/apps/kolourpaint/icons/hicolor/16x16/apps/kolourpaint.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/text_bold.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/text_italic.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/text_strike.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/text_under.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_brush.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_color_picker.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_color_washer.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_curve.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_ellipse.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_elliptical_selection.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_eraser.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_flood_fill.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_free_form_selection.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_line.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_pen.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_polygon.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_polyline.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_rect_selection.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_rectangle.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_rounded_rectangle.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_spraycan.png
+share/apps/kolourpaint/icons/hicolor/22x22/actions/tool_text.png
+share/apps/kolourpaint/icons/hicolor/32x32/apps/kolourpaint.png
+share/apps/kolourpaint/icons/hicolor/48x48/apps/kolourpaint.png
+share/apps/kolourpaint/kolourpaintui.rc
+share/apps/kolourpaint/pics/color_transparent_26x26.png
+share/apps/kolourpaint/pics/colorbutton_swap_16x16.png
+share/apps/kolourpaint/pics/image_rotate_anticlockwise.png
+share/apps/kolourpaint/pics/image_rotate_clockwise.png
+share/apps/kolourpaint/pics/image_skew_horizontal.png
+share/apps/kolourpaint/pics/image_skew_vertical.png
+share/apps/kolourpaint/pics/option_opaque.png
+share/apps/kolourpaint/pics/option_transparent.png
+share/apps/kolourpaint/pics/resize_scale_apple_resize.png
+share/apps/kolourpaint/pics/resize_scale_apple_scale.png
+share/apps/kolourpaint/pics/tool_spraycan_17x17.png
+share/apps/kolourpaint/pics/tool_spraycan_29x29.png
+share/apps/kolourpaint/pics/tool_spraycan_9x9.png
+share/doc/HTML/en/kolourpaint/brush_shapes.png
+share/doc/HTML/en/kolourpaint/color_box.png
+share/doc/HTML/en/kolourpaint/common
+share/doc/HTML/en/kolourpaint/eraser_shapes.png
+share/doc/HTML/en/kolourpaint/fcc_std_text.png
+share/doc/HTML/en/kolourpaint/fcc_trans_text.png
+share/doc/HTML/en/kolourpaint/fill_style.png
+share/doc/HTML/en/kolourpaint/image_flip.png
+share/doc/HTML/en/kolourpaint/image_resize_scale.png
+share/doc/HTML/en/kolourpaint/image_rotate.png
+share/doc/HTML/en/kolourpaint/image_selection_dimensions.png
+share/doc/HTML/en/kolourpaint/image_skew.png
+share/doc/HTML/en/kolourpaint/index.cache.bz2
+share/doc/HTML/en/kolourpaint/index.docbook
+share/doc/HTML/en/kolourpaint/kde_logo.png
+share/doc/HTML/en/kolourpaint/kolourpaint-main.png
+share/doc/HTML/en/kolourpaint/line_width.png
+share/doc/HTML/en/kolourpaint/lines_30_45_deg.png
+share/doc/HTML/en/kolourpaint/lines_30_deg.png
+share/doc/HTML/en/kolourpaint/lines_45_deg.png
+share/doc/HTML/en/kolourpaint/selections_opaque_transparent.png
+share/doc/HTML/en/kolourpaint/spraycan_patterns.png
+share/doc/HTML/en/kolourpaint/tool_brush.png
+share/doc/HTML/en/kolourpaint/tool_color_picker.png
+share/doc/HTML/en/kolourpaint/tool_color_washer.png
+share/doc/HTML/en/kolourpaint/tool_curve.png
+share/doc/HTML/en/kolourpaint/tool_ellipse.png
+share/doc/HTML/en/kolourpaint/tool_elliptical_selection.png
+share/doc/HTML/en/kolourpaint/tool_eraser.png
+share/doc/HTML/en/kolourpaint/tool_flood_fill.png
+share/doc/HTML/en/kolourpaint/tool_free_form_selection.png
+share/doc/HTML/en/kolourpaint/tool_line.png
+share/doc/HTML/en/kolourpaint/tool_pen.png
+share/doc/HTML/en/kolourpaint/tool_polygon.png
+share/doc/HTML/en/kolourpaint/tool_polyline.png
+share/doc/HTML/en/kolourpaint/tool_polystar.png
+share/doc/HTML/en/kolourpaint/tool_rect_selection.png
+share/doc/HTML/en/kolourpaint/tool_rectangle.png
+share/doc/HTML/en/kolourpaint/tool_rectangles.png
+share/doc/HTML/en/kolourpaint/tool_rounded_rectangle.png
+share/doc/HTML/en/kolourpaint/tool_selections.png
+share/doc/HTML/en/kolourpaint/tool_spraycan.png
+share/doc/HTML/en/kolourpaint/tool_text.png
+share/icons/hicolor/16x16/apps/kolourpaint.png
+share/icons/hicolor/32x32/apps/kolourpaint.png
+share/icons/hicolor/48x48/apps/kolourpaint.png
+@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
+@unexec rmdir %D/share/icons 2>/dev/null || true
+@dirrm share/doc/HTML/en/kolourpaint
+@unexec rmdir %D/share/doc/HTML/en 2>/dev/null || true
+@unexec rmdir %D/share/doc/HTML 2>/dev/null || true
+@dirrm share/apps/kolourpaint/pics
+@dirrm share/apps/kolourpaint/icons/hicolor/48x48/apps
+@dirrm share/apps/kolourpaint/icons/hicolor/48x48
+@dirrm share/apps/kolourpaint/icons/hicolor/32x32/apps
+@dirrm share/apps/kolourpaint/icons/hicolor/32x32
+@dirrm share/apps/kolourpaint/icons/hicolor/22x22/actions
+@dirrm share/apps/kolourpaint/icons/hicolor/22x22
+@dirrm share/apps/kolourpaint/icons/hicolor/16x16/apps
+@dirrm share/apps/kolourpaint/icons/hicolor/16x16/actions
+@dirrm share/apps/kolourpaint/icons/hicolor/16x16
+@dirrm share/apps/kolourpaint/icons/hicolor
+@dirrm share/apps/kolourpaint/icons
+@dirrm share/apps/kolourpaint
+@unexec rmdir %D/share/apps 2>/dev/null || true
+@unexec rmdir %D/share/applications/kde 2>/dev/null || true
+@unexec rmdir %D/share/applications 2>/dev/null || true