aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/bind9-devel/Makefile2
-rw-r--r--dns/bind9-devel/files/named.in29
-rw-r--r--dns/bind910/Makefile2
-rw-r--r--dns/bind910/files/named.in29
-rw-r--r--dns/bind911/Makefile2
-rw-r--r--dns/bind911/files/named.in29
-rw-r--r--dns/bind99/Makefile2
-rw-r--r--dns/bind99/files/named.in29
8 files changed, 72 insertions, 52 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index c5455de35b86..9f6bd86126e7 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -8,7 +8,7 @@ PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
PORTREVISION= 0
.else
# dns/bind9xx here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= LOCAL/mat/bind
diff --git a/dns/bind9-devel/files/named.in b/dns/bind9-devel/files/named.in
index 5d5f92b45f84..33b76d151028 100644
--- a/dns/bind9-devel/files/named.in
+++ b/dns/bind9-devel/files/named.in
@@ -194,7 +194,7 @@ named_reload()
{
# This is a one line function, but ${named_program} is not defined early
# enough to be there when the reload_cmd variable is defined up there.
- ${_named_program_root}/sbin/rndc ${rndc_flags} reload
+ rndc reload
}
find_pidfile()
@@ -220,7 +220,7 @@ named_stop()
return 1
fi
echo 'Stopping named.'
- if ${_named_program_root}/sbin/rndc ${rndc_flags} stop 2>/dev/null; then
+ if rndc stop; then
wait_for_pids ${rc_pid}
else
echo -n 'rndc failed, trying kill: '
@@ -255,6 +255,21 @@ create_file()
install -o root -g wheel -m 0644 /dev/null $1
}
+rndc()
+{
+ if [ -z "${rndc_flags}" ]; then
+ if [ -s "${rndc_conf}" ] ; then
+ rndc_flags="-c ${rndc_conf}"
+ elif [ -s "${rndc_key}" ] ; then
+ rndc_flags="-k ${rndc_key}"
+ else
+ rndc_flags=""
+ fi
+ fi
+
+ ${_named_program_root}/sbin/rndc ${rndc_flags} "$@"
+}
+
named_prestart()
{
find_pidfile
@@ -270,16 +285,6 @@ named_prestart()
command_args="-u ${named_uid:=root} -c ${named_conf} ${command_args}"
- if [ -z "${rndc_flags}" ]; then
- if [ -s ${rndc_conf} ] ; then
- rndc_flags="-c ${rndc_conf}"
- elif [ -s ${rndc_key} ] ; then
- rndc_flags="-k ${rndc_key}"
- else
- rndc_flags=""
- fi
- fi
-
%%NATIVE_PKCS11%% if [ -z "${named_pkcs11_engine}"]; then
%%NATIVE_PKCS11%% err 3 "named_pkcs11_engine has to be set to the PKCS#11 engine's library you want to use"
%%NATIVE_PKCS11%% elif [ ! -f ${named_pkcs11_engine} ]; then
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 9c56ea4ae3a8..31eb20e44232 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 910
diff --git a/dns/bind910/files/named.in b/dns/bind910/files/named.in
index 5d5f92b45f84..33b76d151028 100644
--- a/dns/bind910/files/named.in
+++ b/dns/bind910/files/named.in
@@ -194,7 +194,7 @@ named_reload()
{
# This is a one line function, but ${named_program} is not defined early
# enough to be there when the reload_cmd variable is defined up there.
- ${_named_program_root}/sbin/rndc ${rndc_flags} reload
+ rndc reload
}
find_pidfile()
@@ -220,7 +220,7 @@ named_stop()
return 1
fi
echo 'Stopping named.'
- if ${_named_program_root}/sbin/rndc ${rndc_flags} stop 2>/dev/null; then
+ if rndc stop; then
wait_for_pids ${rc_pid}
else
echo -n 'rndc failed, trying kill: '
@@ -255,6 +255,21 @@ create_file()
install -o root -g wheel -m 0644 /dev/null $1
}
+rndc()
+{
+ if [ -z "${rndc_flags}" ]; then
+ if [ -s "${rndc_conf}" ] ; then
+ rndc_flags="-c ${rndc_conf}"
+ elif [ -s "${rndc_key}" ] ; then
+ rndc_flags="-k ${rndc_key}"
+ else
+ rndc_flags=""
+ fi
+ fi
+
+ ${_named_program_root}/sbin/rndc ${rndc_flags} "$@"
+}
+
named_prestart()
{
find_pidfile
@@ -270,16 +285,6 @@ named_prestart()
command_args="-u ${named_uid:=root} -c ${named_conf} ${command_args}"
- if [ -z "${rndc_flags}" ]; then
- if [ -s ${rndc_conf} ] ; then
- rndc_flags="-c ${rndc_conf}"
- elif [ -s ${rndc_key} ] ; then
- rndc_flags="-k ${rndc_key}"
- else
- rndc_flags=""
- fi
- fi
-
%%NATIVE_PKCS11%% if [ -z "${named_pkcs11_engine}"]; then
%%NATIVE_PKCS11%% err 3 "named_pkcs11_engine has to be set to the PKCS#11 engine's library you want to use"
%%NATIVE_PKCS11%% elif [ ! -f ${named_pkcs11_engine} ]; then
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index a10960aff03d..ba559395a9fc 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -8,7 +8,7 @@ PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
PORTREVISION= 0
.else
# dns/bind9xx here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
diff --git a/dns/bind911/files/named.in b/dns/bind911/files/named.in
index 5d5f92b45f84..33b76d151028 100644
--- a/dns/bind911/files/named.in
+++ b/dns/bind911/files/named.in
@@ -194,7 +194,7 @@ named_reload()
{
# This is a one line function, but ${named_program} is not defined early
# enough to be there when the reload_cmd variable is defined up there.
- ${_named_program_root}/sbin/rndc ${rndc_flags} reload
+ rndc reload
}
find_pidfile()
@@ -220,7 +220,7 @@ named_stop()
return 1
fi
echo 'Stopping named.'
- if ${_named_program_root}/sbin/rndc ${rndc_flags} stop 2>/dev/null; then
+ if rndc stop; then
wait_for_pids ${rc_pid}
else
echo -n 'rndc failed, trying kill: '
@@ -255,6 +255,21 @@ create_file()
install -o root -g wheel -m 0644 /dev/null $1
}
+rndc()
+{
+ if [ -z "${rndc_flags}" ]; then
+ if [ -s "${rndc_conf}" ] ; then
+ rndc_flags="-c ${rndc_conf}"
+ elif [ -s "${rndc_key}" ] ; then
+ rndc_flags="-k ${rndc_key}"
+ else
+ rndc_flags=""
+ fi
+ fi
+
+ ${_named_program_root}/sbin/rndc ${rndc_flags} "$@"
+}
+
named_prestart()
{
find_pidfile
@@ -270,16 +285,6 @@ named_prestart()
command_args="-u ${named_uid:=root} -c ${named_conf} ${command_args}"
- if [ -z "${rndc_flags}" ]; then
- if [ -s ${rndc_conf} ] ; then
- rndc_flags="-c ${rndc_conf}"
- elif [ -s ${rndc_key} ] ; then
- rndc_flags="-k ${rndc_key}"
- else
- rndc_flags=""
- fi
- fi
-
%%NATIVE_PKCS11%% if [ -z "${named_pkcs11_engine}"]; then
%%NATIVE_PKCS11%% err 3 "named_pkcs11_engine has to be set to the PKCS#11 engine's library you want to use"
%%NATIVE_PKCS11%% elif [ ! -f ${named_pkcs11_engine} ]; then
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index fb705d18c1ae..d774e2a12cdf 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 99
diff --git a/dns/bind99/files/named.in b/dns/bind99/files/named.in
index 46db01b9e090..8ded4afa39fe 100644
--- a/dns/bind99/files/named.in
+++ b/dns/bind99/files/named.in
@@ -192,7 +192,7 @@ named_reload()
{
# This is a one line function, but ${named_program} is not defined early
# enough to be there when the reload_cmd variable is defined up there.
- ${_named_program_root}/sbin/rndc ${rndc_flags} reload
+ rndc reload
}
find_pidfile()
@@ -218,7 +218,7 @@ named_stop()
return 1
fi
echo 'Stopping named.'
- if ${_named_program_root}/sbin/rndc ${rndc_flags} stop 2>/dev/null; then
+ if rndc stop; then
wait_for_pids ${rc_pid}
else
echo -n 'rndc failed, trying kill: '
@@ -253,6 +253,21 @@ create_file()
install -o root -g wheel -m 0644 /dev/null $1
}
+rndc()
+{
+ if [ -z "${rndc_flags}" ]; then
+ if [ -s "${rndc_conf}" ] ; then
+ rndc_flags="-c ${rndc_conf}"
+ elif [ -s "${rndc_key}" ] ; then
+ rndc_flags="-k ${rndc_key}"
+ else
+ rndc_flags=""
+ fi
+ fi
+
+ ${_named_program_root}/sbin/rndc ${rndc_flags} "$@"
+}
+
named_prestart()
{
find_pidfile
@@ -268,16 +283,6 @@ named_prestart()
command_args="-u ${named_uid:=root} -c ${named_conf} ${command_args}"
- if [ -z "${rndc_flags}" ]; then
- if [ -s ${rndc_conf} ] ; then
- rndc_flags="-c ${rndc_conf}"
- elif [ -s ${rndc_key} ] ; then
- rndc_flags="-k ${rndc_key}"
- else
- rndc_flags=""
- fi
- fi
-
local line nsip firstns
# Is the user using a sandbox?