aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/pear-Auth/Makefile21
-rw-r--r--security/pear-Auth/distinfo6
2 files changed, 17 insertions, 10 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index 4fd2f8eee938..2455ba35bfa4 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Auth
-PORTVERSION= 1.2.4
+PORTVERSION= 1.3.0
CATEGORIES= security pear
MAINTAINER= antonio@php.net
@@ -20,19 +20,22 @@ OPTIONS= PEAR_FILE_PASSWD "PEAR::File_Passwd support" off \
PEAR_NET_POP3 "PEAR::Net_POP3 support" off \
PEAR_DB "PEAR::DB support" off \
PEAR_MDB "PEAR::MDB support" off \
- PEAR_AUTH_RADIUS "PEAR::Auth_RADIUS support" off \
+ PEAR_MDB2 "PEAR::MDB2 support" off \
PEAR_FILE_SMBPASSWD "PEAR::File_SMBPasswd support" off
CATEGORY= Auth
FILES= Auth.php Auth/Auth.php Container.php Container/DB.php \
- Container/File.php Container/IMAP.php Container/POP3.php \
- Container/LDAP.php Container/MDB.php Container/RADIUS.php \
- Container/SMBPasswd.php Container/SOAP.php Container/vpopmail.php
+ Container/DBLite.php Container/File.php Container/IMAP.php \
+ Container/POP3.php Container/LDAP.php Container/MDB.php \
+ Container/MDB2.php Container/RADIUS.php Container/SMBPasswd.php \
+ Container/SOAP.php Container/vpopmail.php
TESTS= auth_container_db_options.php DBContainer.php \
auth_container_file_options.php FileContainer.php \
auth_container_pop3_options.php POP3Container.php \
- auth_container_pop3a_options.php POP3aContainer.php \
- TestAuthContainer.php users tests.php
+ auth_container_mdb_options.php MDBContainer.php \
+ auth_container_mdb2_options.php MDB2Container.php \
+ POP3Container.php auth_container_pop3a_options.php \
+ POP3aContainer.php TestAuthContainer.php users tests.php
DOCS= README.Auth
_DOCSDIR= .
@@ -57,6 +60,10 @@ RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
.endif
+.if defined(WITH_PEAR_MDB2)
+RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+.endif
+
.if defined(WITH_PEAR_AUTH_RADIUS)
RUN_DEPENDS+= ${PEARDIR}/Auth/RADIUS.php:${PORTSDIR}/net/pear-Auth_RADIUS
.endif
diff --git a/security/pear-Auth/distinfo b/security/pear-Auth/distinfo
index a7aa846bb7a6..ca8365e8a0a6 100644
--- a/security/pear-Auth/distinfo
+++ b/security/pear-Auth/distinfo
@@ -1,3 +1,3 @@
-MD5 (PEAR/Auth-1.2.4.tgz) = c1860f21a842aae14d3118bc97fc6417
-SHA256 (PEAR/Auth-1.2.4.tgz) = 016562c68cf88a534fade2d133ce89b3dfc510f2841afbe7c354324580aea440
-SIZE (PEAR/Auth-1.2.4.tgz) = 23387
+MD5 (PEAR/Auth-1.3.0.tgz) = bdeda8b053d87b948c2cea44378581b8
+SHA256 (PEAR/Auth-1.3.0.tgz) = e99158651c9a9b44096198653d2e5b4f845c41144b735fcb84ee21565196892a
+SIZE (PEAR/Auth-1.3.0.tgz) = 39759