aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-URI-FromHash/Makefile24
-rw-r--r--net/p5-URI-FromHash/distinfo3
-rw-r--r--net/p5-URI-FromHash/pkg-descr13
-rw-r--r--net/p5-URI-FromHash/pkg-plist2
5 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index cf6415d4fce0..9af43f8054fb 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -510,6 +510,7 @@
SUBDIR += p5-Spread-Message
SUBDIR += p5-Spread-Session
SUBDIR += p5-URI
+ SUBDIR += p5-URI-FromHash
SUBDIR += p5-URI-OpenURL
SUBDIR += p5-Validate-Net
SUBDIR += p5-What
diff --git a/net/p5-URI-FromHash/Makefile b/net/p5-URI-FromHash/Makefile
new file mode 100644
index 000000000000..6bf7c5a71828
--- /dev/null
+++ b/net/p5-URI-FromHash/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-URI-FromHash
+# Date created: 2 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-FromHash
+DISTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Create URI from hash of components
+
+BUILD_DEPENDS= p5-URI>=1.22:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= YES
+
+MAN3= ${PORTNAME:S/-/::/g}.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-URI-FromHash/distinfo b/net/p5-URI-FromHash/distinfo
new file mode 100644
index 000000000000..bbdf09c50e6a
--- /dev/null
+++ b/net/p5-URI-FromHash/distinfo
@@ -0,0 +1,3 @@
+MD5 (URI-FromHash-0.02.tar.gz) = d2181ba65982192f966039d653fb4ea9
+SHA256 (URI-FromHash-0.02.tar.gz) = 5803b59206e29078b7db584af09da9bc4c0fde23e0b7d2a83ff7e24d8c411d4b
+SIZE (URI-FromHash-0.02.tar.gz) = 5221
diff --git a/net/p5-URI-FromHash/pkg-descr b/net/p5-URI-FromHash/pkg-descr
new file mode 100644
index 000000000000..e389da6b80c6
--- /dev/null
+++ b/net/p5-URI-FromHash/pkg-descr
@@ -0,0 +1,13 @@
+This module provides a simple functional "named parameters" style interface
+for creating URIs. Underneath the hood it uses URI.pm, though because of
+the simplified interface it may not support all possible options for all
+types of URIs.
+
+It was created for the common case where you simply want to have a simple
+interface for creating syntactically correct URIs from known components
+(like a path and query string). Doing this using the native URI.pm
+interface is rather tedious, requiring a number of method calls, which is
+particularly ugly when done inside a templating system such as Mason or
+TT2.
+
+WWW: http://search.cpan.org/dist/URI-FromHash/
diff --git a/net/p5-URI-FromHash/pkg-plist b/net/p5-URI-FromHash/pkg-plist
new file mode 100644
index 000000000000..5e24ad4ac1a3
--- /dev/null
+++ b/net/p5-URI-FromHash/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/URI/FromHash.pm
+@dirrmtry %%SITE_PERL%%/URI