aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/boinc-client/Makefile1
-rw-r--r--net/boinc-client/files/patch-hostinfo_unix.cpp17
2 files changed, 18 insertions, 0 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index 733ae39e4dcb..53ea165c8b39 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -7,6 +7,7 @@
PORTNAME= boinc-client
PORTVERSION= 6.4.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
diff --git a/net/boinc-client/files/patch-hostinfo_unix.cpp b/net/boinc-client/files/patch-hostinfo_unix.cpp
new file mode 100644
index 000000000000..39fb4e9b5729
--- /dev/null
+++ b/net/boinc-client/files/patch-hostinfo_unix.cpp
@@ -0,0 +1,17 @@
+--- client/hostinfo_unix.cpp.orig 2008-12-28 11:11:26.000000000 +0100
++++ client/hostinfo_unix.cpp 2008-12-29 00:51:32.000000000 +0100
+@@ -809,14 +809,6 @@
+ int mem_size;
+ getsysinfo( GSI_PHYSMEM, (caddr_t) &mem_size, sizeof( mem_size));
+ m_nbytes = 1024.* (double)mem_size;
+-#elif defined(HW_PHYSMEM)
+- // for OpenBSD
+- mib[0] = CTL_HW;
+- int mem_size;
+- mib[1] = HW_PHYSMEM;
+- len = sizeof(mem_size);
+- sysctl(mib, 2, &mem_size, &len, NULL, 0);
+- m_nbytes = mem_size;
+ #elif defined(__FreeBSD__)
+ unsigned int mem_size;
+ mib[0] = CTL_HW;