aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-String-MkPasswd/Makefile23
-rw-r--r--security/p5-String-MkPasswd/distinfo2
-rw-r--r--security/p5-String-MkPasswd/pkg-descr6
-rw-r--r--security/p5-String-MkPasswd/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d0d2781b9588..0d9dddccaeb2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -541,6 +541,7 @@
SUBDIR += p5-SHA
SUBDIR += p5-Safe-Hole
SUBDIR += p5-Snort-Rule
+ SUBDIR += p5-String-MkPasswd
SUBDIR += p5-Sudo
SUBDIR += p5-Text-Password-Pronounceable
SUBDIR += p5-Tie-EncryptedHash
diff --git a/security/p5-String-MkPasswd/Makefile b/security/p5-String-MkPasswd/Makefile
new file mode 100644
index 000000000000..3e0e1abcd40b
--- /dev/null
+++ b/security/p5-String-MkPasswd/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-String-MkPasswd
+# Date created: Fri Apr 29 10:13:10 CEST 2011
+# Whom: Frank Wall <fw@moov.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-MkPasswd
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CGRAU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fw@moov.de
+COMMENT= A random password generator
+
+PERL_CONFIGURE= yes
+
+MAN1= mkpasswd.pl.1
+MAN3= String::MkPasswd.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-String-MkPasswd/distinfo b/security/p5-String-MkPasswd/distinfo
new file mode 100644
index 000000000000..8a1161916616
--- /dev/null
+++ b/security/p5-String-MkPasswd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (String-MkPasswd-0.03.tar.gz) = 19abf73573e138659d833fad539b3252287baa0a49328b14c2a59cdd21970fce
+SIZE (String-MkPasswd-0.03.tar.gz) = 7326
diff --git a/security/p5-String-MkPasswd/pkg-descr b/security/p5-String-MkPasswd/pkg-descr
new file mode 100644
index 000000000000..9a1c98973ab0
--- /dev/null
+++ b/security/p5-String-MkPasswd/pkg-descr
@@ -0,0 +1,6 @@
+This Perl library defines a single function, mkpasswd(), to generate
+random passwords. The function is meant to be a simple way for
+developers and system administrators to easily generate a relatively
+secure password.
+
+WWW: http://search.cpan.org/dist/String-MkPasswd
diff --git a/security/p5-String-MkPasswd/pkg-plist b/security/p5-String-MkPasswd/pkg-plist
new file mode 100644
index 000000000000..fa536cc2a73b
--- /dev/null
+++ b/security/p5-String-MkPasswd/pkg-plist
@@ -0,0 +1,6 @@
+bin/mkpasswd.pl
+%%SITE_PERL%%/String/MkPasswd.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/MkPasswd/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/MkPasswd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String
+@dirrmtry %%SITE_PERL%%/String