aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/googler/Makefile31
-rw-r--r--www/googler/distinfo3
-rw-r--r--www/googler/pkg-descr7
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1e8694f3e88e..658ae5621523 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -209,6 +209,7 @@
SUBDIR += google-appengine
SUBDIR += google-sitemapgen
SUBDIR += googlebook_dl
+ SUBDIR += googler
SUBDIR += goose
SUBDIR += gotty
SUBDIR += gpx2map
diff --git a/www/googler/Makefile b/www/googler/Makefile
new file mode 100644
index 000000000000..d34ef16ae35a
--- /dev/null
+++ b/www/googler/Makefile
@@ -0,0 +1,31 @@
+# Created by: Nicola Stanislao Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= googler
+PORTVERSION= 2.8
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Google Search, Google Site Search, Google News from the terminal
+
+LICENSE= GPLv3
+
+GH_ACCOUNT= jarun
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/googler man/man1/googler.1.gz
+
+USE_GITHUB= yes
+USES= python:3.3+
+
+post-patch:
+ @${SED} -i.bak 's/^\(ENABLE_SELF_UPGRADE_MECHANISM=\)True$$/\1False/' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}/${MANPREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/www/googler/distinfo b/www/googler/distinfo
new file mode 100644
index 000000000000..73bf43ff419b
--- /dev/null
+++ b/www/googler/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476807829
+SHA256 (jarun-googler-v2.8_GH0.tar.gz) = 5a9a128180992c0f6b6b7f0bd9d13191cd83cf56ff7e185fcb0e48e79740b355
+SIZE (jarun-googler-v2.8_GH0.tar.gz) = 54839
diff --git a/www/googler/pkg-descr b/www/googler/pkg-descr
new file mode 100644
index 000000000000..01d834e64149
--- /dev/null
+++ b/www/googler/pkg-descr
@@ -0,0 +1,7 @@
+googler is a power tool to Google (Web & News) and Google Site Search
+from the command-line. It shows the title, URL and abstract for each result,
+which can be directly opened in a browser from the terminal. Results are
+fetched in pages (with page navigation). Supports sequential searches
+in a single googler instance.
+
+WWW: https://github.com/jarun/googler