aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Helper-Controller-Scaffold/Makefile36
-rw-r--r--www/p5-Catalyst-Helper-Controller-Scaffold/distinfo2
-rw-r--r--www/p5-Catalyst-Helper-Controller-Scaffold/pkg-descr8
-rw-r--r--www/p5-Catalyst-Helper-Controller-Scaffold/pkg-plist9
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb55a77f9a3e..8cf559655464 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -464,6 +464,7 @@
SUBDIR += p5-CGI.pm
SUBDIR += p5-CGI_Lite
SUBDIR += p5-Catalyst
+ SUBDIR += p5-Catalyst-Helper-Controller-Scaffold
SUBDIR += p5-Catalyst-Model-CDBI
SUBDIR += p5-Catalyst-Model-CDBI-Sweet
SUBDIR += p5-Catalyst-Plugin-FillInForm
diff --git a/www/p5-Catalyst-Helper-Controller-Scaffold/Makefile b/www/p5-Catalyst-Helper-Controller-Scaffold/Makefile
new file mode 100644
index 000000000000..79fc8e1a1a5b
--- /dev/null
+++ b/www/p5-Catalyst-Helper-Controller-Scaffold/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: www/p5-Catalyst-Helper-Controller-Scaffold
+# Date created: 2005-07-11
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Helper-Controller-Scaffold
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Catalyst helper for Scaffolding
+
+BUILD_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst \
+ ${SITE_PERL}/Catalyst/Plugin/FormValidator.pm:${PORTSDIR}/www/p5-Catalyst-Plugin-FormValidator \
+ ${SITE_PERL}/Catalyst/View/TT.pm:${PORTSDIR}/www/p5-Catalyst-View-TT \
+ ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
+ ${SITE_PERL}/Class/DBI/AsForm.pm:${PORTSDIR}/databases/p5-Class-DBI-AsForm \
+ ${SITE_PERL}/Class/DBI/FromForm.pm:${PORTSDIR}/www/p5-Class-DBI-FromForm \
+ ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
+ ${SITE_PERL}/Template/Plugin/Class.pm:${PORTSDIR}/www/p5-Template-Plugin-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Helper::Controller::Scaffold.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Helper-Controller-Scaffold/distinfo b/www/p5-Catalyst-Helper-Controller-Scaffold/distinfo
new file mode 100644
index 000000000000..4c5f08fd263b
--- /dev/null
+++ b/www/p5-Catalyst-Helper-Controller-Scaffold/distinfo
@@ -0,0 +1,2 @@
+MD5 (Catalyst-Helper-Controller-Scaffold-0.02.tar.gz) = 18acf3f904a653521afbe3f69c78b6cb
+SIZE (Catalyst-Helper-Controller-Scaffold-0.02.tar.gz) = 2980
diff --git a/www/p5-Catalyst-Helper-Controller-Scaffold/pkg-descr b/www/p5-Catalyst-Helper-Controller-Scaffold/pkg-descr
new file mode 100644
index 000000000000..0b7d68b7ae3b
--- /dev/null
+++ b/www/p5-Catalyst-Helper-Controller-Scaffold/pkg-descr
@@ -0,0 +1,8 @@
+Catalyst::Helper::Controller::Scaffold is a helper for scaffolding for
+Catalyst, which adds easy scaffolding:
+
+ # Imagine you want to generate a scaffolding controller MyApp::C::SomeTable
+ # for a CDBI table class MyApp::M::CDBI::SomeTable
+ script/myapp_create.pl controller SomeTable Scaffold CDBI::SomeTable
+
+WWW: http://search.cpan.org/dist/Catalyst-Helper-Controller-Scaffold/
diff --git a/www/p5-Catalyst-Helper-Controller-Scaffold/pkg-plist b/www/p5-Catalyst-Helper-Controller-Scaffold/pkg-plist
new file mode 100644
index 000000000000..5d7351c68a51
--- /dev/null
+++ b/www/p5-Catalyst-Helper-Controller-Scaffold/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Catalyst/Helper/Controller/Scaffold.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Helper/Controller/Scaffold/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Helper/Controller/Scaffold 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Helper/Controller 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Helper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Helper/Controller 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Helper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true