aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-ActionRole-ACL/Makefile32
-rw-r--r--www/p5-Catalyst-ActionRole-ACL/distinfo2
-rw-r--r--www/p5-Catalyst-ActionRole-ACL/pkg-descr5
-rw-r--r--www/p5-Catalyst-ActionRole-ACL/pkg-plist8
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 174635011f34..bfb1c129105b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -781,6 +781,7 @@
SUBDIR += p5-CSS-Inliner
SUBDIR += p5-Catalyst-Action-REST
SUBDIR += p5-Catalyst-Action-RenderView
+ SUBDIR += p5-Catalyst-ActionRole-ACL
SUBDIR += p5-Catalyst-Authentication-Credential-HTTP
SUBDIR += p5-Catalyst-Authentication-Credential-OpenID
SUBDIR += p5-Catalyst-Authentication-Store-DBIx-Class
diff --git a/www/p5-Catalyst-ActionRole-ACL/Makefile b/www/p5-Catalyst-ActionRole-ACL/Makefile
new file mode 100644
index 000000000000..75e7d8755466
--- /dev/null
+++ b/www/p5-Catalyst-ActionRole-ACL/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Catalyst-ActionRole-ACL
+# Date created: 2011-05-08
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-ActionRole-ACL
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CONVERTER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= User role-based authorization action class
+
+BUILD_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Catalyst-Controller-ActionRole>=0:${PORTSDIR}/www/p5-Catalyst-Controller-ActionRole \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Catalyst-Controller-ActionRole>=0:${PORTSDIR}/www/p5-Catalyst-Controller-ActionRole \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Action::Role::ACL.3 Catalyst::ActionRole::ACL.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-ActionRole-ACL/distinfo b/www/p5-Catalyst-ActionRole-ACL/distinfo
new file mode 100644
index 000000000000..5131ad26cf24
--- /dev/null
+++ b/www/p5-Catalyst-ActionRole-ACL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Catalyst-ActionRole-ACL-0.05.tar.gz) = f5bb7827445143fd85567be052028bfb762d231466c2ec136e79d6fa4765039a
+SIZE (Catalyst-ActionRole-ACL-0.05.tar.gz) = 21150
diff --git a/www/p5-Catalyst-ActionRole-ACL/pkg-descr b/www/p5-Catalyst-ActionRole-ACL/pkg-descr
new file mode 100644
index 000000000000..4821c9f404c3
--- /dev/null
+++ b/www/p5-Catalyst-ActionRole-ACL/pkg-descr
@@ -0,0 +1,5 @@
+Provides a Catalyst reusable action role for user role-based authorization.
+ACLs are applied via the assignment of attributes to application action
+subroutines.
+
+WWW: http://search.cpan.org/dist/Catalyst-ActionRole-ACL/
diff --git a/www/p5-Catalyst-ActionRole-ACL/pkg-plist b/www/p5-Catalyst-ActionRole-ACL/pkg-plist
new file mode 100644
index 000000000000..3aa046312fe3
--- /dev/null
+++ b/www/p5-Catalyst-ActionRole-ACL/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Catalyst/Action/Role/ACL.pm
+%%SITE_PERL%%/Catalyst/ActionRole/ACL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/ActionRole/ACL/.packlist
+@dirrmtry %%SITE_PERL%%/Catalyst/Action/Role
+@dirrmtry %%SITE_PERL%%/Catalyst/Action
+@dirrmtry %%SITE_PERL%%/Catalyst/ActionRole
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/ActionRole/ACL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/ActionRole