aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile6
-rw-r--r--games/cowsay/Makefile24
-rw-r--r--games/cowsay/distinfo1
-rw-r--r--games/cowsay/pkg-comment1
-rw-r--r--games/cowsay/pkg-descr5
-rw-r--r--games/cowsay/pkg-plist51
6 files changed, 83 insertions, 5 deletions
diff --git a/games/Makefile b/games/Makefile
index 46903f198b5b..994023fb8c00 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -35,11 +35,7 @@
SUBDIR += connect4
SUBDIR += corewars
SUBDIR += cosmo
- SUBDIR += crafty
- SUBDIR += crafty-open-large
- SUBDIR += crafty-open-medium
- SUBDIR += crafty-open-rock
- SUBDIR += crafty-open-small
+ SUBDIR += cowsay
SUBDIR += crossfire
SUBDIR += cursive
SUBDIR += digger-vgl
diff --git a/games/cowsay/Makefile b/games/cowsay/Makefile
new file mode 100644
index 000000000000..8d58329d1889
--- /dev/null
+++ b/games/cowsay/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: cowsay
+# Date created: 01 Sep 2000
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cowsay
+PORTVERSION= 3.03
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.nog.net/pub/tony/cowsay/
+
+MAINTAINER= kris@FreeBSD.org
+
+USE_PERL5= yes
+
+NO_BUILD= # defined
+
+MAN1= cowsay.1
+
+do-install:
+ cd ${WRKSRC}; ${SH} install.sh ${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/games/cowsay/distinfo b/games/cowsay/distinfo
new file mode 100644
index 000000000000..90315732514c
--- /dev/null
+++ b/games/cowsay/distinfo
@@ -0,0 +1 @@
+MD5 (cowsay-3.03.tar.gz) = b29169797359420dadb998079021a494
diff --git a/games/cowsay/pkg-comment b/games/cowsay/pkg-comment
new file mode 100644
index 000000000000..005444310ad6
--- /dev/null
+++ b/games/cowsay/pkg-comment
@@ -0,0 +1 @@
+Configurable talking characters in ASCII art
diff --git a/games/cowsay/pkg-descr b/games/cowsay/pkg-descr
new file mode 100644
index 000000000000..3bab8b236cda
--- /dev/null
+++ b/games/cowsay/pkg-descr
@@ -0,0 +1,5 @@
+cowsay is a configurable talking ASCII cow (and other characters),
+written in Perl. It operates much as the figlet program does, and
+is written in the same spirit of silliness.
+
+WWW: http://www.nog.net/~tony/warez/cowsay.shtml
diff --git a/games/cowsay/pkg-plist b/games/cowsay/pkg-plist
new file mode 100644
index 000000000000..9c9f6398d6d3
--- /dev/null
+++ b/games/cowsay/pkg-plist
@@ -0,0 +1,51 @@
+bin/cowsay
+bin/cowthink
+man/man1/cowthink.1
+share/cows/beavis.zen.cow
+share/cows/bong.cow
+share/cows/bud-frogs.cow
+share/cows/bunny.cow
+share/cows/cheese.cow
+share/cows/cower.cow
+share/cows/daemon.cow
+share/cows/default.cow
+share/cows/dragon-and-cow.cow
+share/cows/dragon.cow
+share/cows/elephant-in-snake.cow
+share/cows/elephant.cow
+share/cows/eyes.cow
+share/cows/flaming-sheep.cow
+share/cows/ghostbusters.cow
+share/cows/head-in.cow
+share/cows/hellokitty.cow
+share/cows/kiss.cow
+share/cows/kitty.cow
+share/cows/koala.cow
+share/cows/kosh.cow
+share/cows/luke-koala.cow
+share/cows/mech-and-cow
+share/cows/meow.cow
+share/cows/milk.cow
+share/cows/moofasa.cow
+share/cows/moose.cow
+share/cows/mutilated.cow
+share/cows/ren.cow
+share/cows/satanic.cow
+share/cows/sheep.cow
+share/cows/skeleton.cow
+share/cows/small.cow
+share/cows/sodomized.cow
+share/cows/stegosaurus.cow
+share/cows/stimpy.cow
+share/cows/supermilker.cow
+share/cows/surgery.cow
+share/cows/telebears.cow
+share/cows/three-eyes.cow
+share/cows/turkey.cow
+share/cows/turtle.cow
+share/cows/tux.cow
+share/cows/udder.cow
+share/cows/vader-koala.cow
+share/cows/vader.cow
+share/cows/www.cow
+@dirrm share/cows