aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/salome/Makefile2
-rw-r--r--multimedia/vtkmpeg2encode/Makefile23
-rw-r--r--science/dtiquery/Makefile2
-rw-r--r--science/dtiquery/files/patch-Makefile.definitions4
4 files changed, 15 insertions, 16 deletions
diff --git a/cad/salome/Makefile b/cad/salome/Makefile
index 8e5e91e1cdd3..77f192d32443 100644
--- a/cad/salome/Makefile
+++ b/cad/salome/Makefile
@@ -6,7 +6,7 @@
PORTNAME= salome
PORTVERSION= 5.1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad science
MASTER_SITES= http://www.stasyan.com/devel/distfiles/
DISTNAME= src5.1.3
diff --git a/multimedia/vtkmpeg2encode/Makefile b/multimedia/vtkmpeg2encode/Makefile
index a2687bb3a181..a3b24f193b1c 100644
--- a/multimedia/vtkmpeg2encode/Makefile
+++ b/multimedia/vtkmpeg2encode/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vtkmpeg2encode
-PORTVERSION= 5.0.3
-PORTREVISION= 1
+PORTVERSION= 5.4.2
CATEGORIES= multimedia math
MASTER_SITES= http://www.vtk.org/files/support/ \
http://www.neuro.mcw.edu/Ports/distfiles/VTK5/
@@ -29,25 +28,25 @@ SUB_FILES= vtkmpeg2encode.3
MPEGLIB= libvtkMPEG2Encode
-PLIST_DIRS= include/vtk-5.0
+PLIST_DIRS= include/vtk-5.4
PLIST_FILES= lib/${MPEGLIB}.so.${PORTVERSION} \
- lib/${MPEGLIB}.so.5.0 \
+ lib/${MPEGLIB}.so.5.4 \
lib/${MPEGLIB}.so.5 \
lib/${MPEGLIB}.so \
- include/vtk-5.0/mpeg2encDllConfig.h \
- include/vtk-5.0/mpeg2enc_global.h \
- include/vtk-5.0/mpeg2enc.h \
- include/vtk-5.0/mpeg2enc_config.h \
- include/vtk-5.0/vlc.h
+ include/vtk-5.4/mpeg2encDllConfig.h \
+ include/vtk-5.4/mpeg2enc_global.h \
+ include/vtk-5.4/mpeg2enc.h \
+ include/vtk-5.4/mpeg2enc_config.h \
+ include/vtk-5.4/vlc.h
post-build:
${MV} ${WRKSRC}/${MPEGLIB}.so ${WRKSRC}/${MPEGLIB}.so.${PORTVERSION}
do-install:
- ${MKDIR} ${PREFIX}/include/vtk-5.0
+ ${MKDIR} ${PREFIX}/include/vtk-5.4
${INSTALL_DATA} ${WRKSRC}/${MPEGLIB}.so.${PORTVERSION} ${PREFIX}/lib
${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
- ${PREFIX}/lib/${MPEGLIB}.so.5.0
+ ${PREFIX}/lib/${MPEGLIB}.so.5.4
${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
${PREFIX}/lib/${MPEGLIB}.so.5
${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
@@ -57,7 +56,7 @@ do-install:
${WRKSRC}/mpeg2enc.h \
${WRKSRC}/mpeg2enc_config.h \
${WRKSRC}/vlc.h \
- ${PREFIX}/include/vtk-5.0
+ ${PREFIX}/include/vtk-5.4
${INSTALL_MAN} ${WRKDIR}/vtkmpeg2encode.3 ${MANPREFIX}/man/man3
post-install:
diff --git a/science/dtiquery/Makefile b/science/dtiquery/Makefile
index 3cfb045f13a6..c845fea5d7d9 100644
--- a/science/dtiquery/Makefile
+++ b/science/dtiquery/Makefile
@@ -9,7 +9,7 @@
PORTNAME= dtiquery
PORTVERSION= 1.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science biology
MASTER_SITES= http://graphics.stanford.edu/projects/dti/
diff --git a/science/dtiquery/files/patch-Makefile.definitions b/science/dtiquery/files/patch-Makefile.definitions
index 80334a3527fc..0471a7a2b2ba 100644
--- a/science/dtiquery/files/patch-Makefile.definitions
+++ b/science/dtiquery/files/patch-Makefile.definitions
@@ -15,8 +15,8 @@
-WX_CONFIG_BIN ?= /usr/X11R6/bin/wxgtk2-2.8-config
+WX_CONFIG_BIN ?= ${LOCALBASE}/bin/wxgtk2-2.8-config
- VTK_INCLUDE_PATHS ?= -I/usr/local/include/vtk-5.0/
- VTK_LIB_PATHS ?= -L/usr/local/lib/vtk-5.0/
+ VTK_INCLUDE_PATHS ?= -I/usr/local/include/vtk-5.4/
+ VTK_LIB_PATHS ?= -L/usr/local/lib/vtk-5.4/
WX_INCLUDE_PATHS ?= `$(WX_CONFIG_BIN) --cxxflags`
WX_LIB_PATHS ?= `$(WX_CONFIG_BIN) --libs` `$(WX_CONFIG_BIN) \
--gl-libs`