aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/md5deep/Makefile27
-rw-r--r--security/md5deep/distinfo2
-rw-r--r--security/md5deep/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e6a369f2dcbd..cda56ad05dc5 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -182,6 +182,7 @@
SUBDIR += makepasswd
SUBDIR += mcrypt
SUBDIR += md5crk
+ SUBDIR += md5deep
SUBDIR += mdcrack
SUBDIR += mhash
SUBDIR += mindterm-binary
diff --git a/security/md5deep/Makefile b/security/md5deep/Makefile
new file mode 100644
index 000000000000..bde726a0ee83
--- /dev/null
+++ b/security/md5deep/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: md5deep
+# Date created: 15 July 2004
+# Whom: Frank Laszlo <laszlof@vonostingroup.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= md5deep
+PORTVERSION= 1.3
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= laszlof@vonostingroup.com
+COMMENT= Program to compute MD5 and SHA1 message digests recursively
+
+ALL_TARGET= unix
+USE_REINPLACE= yes
+
+MAN1= md5deep.1 sha1deep.1
+
+PLIST_FILES= bin/md5deep bin/sha1deep
+
+post-patch:
+ @${REINPLACE_CMD} -e 's!/usr/local!${PREFIX}!g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/security/md5deep/distinfo b/security/md5deep/distinfo
new file mode 100644
index 000000000000..811109304683
--- /dev/null
+++ b/security/md5deep/distinfo
@@ -0,0 +1,2 @@
+MD5 (md5deep-1.3.tar.gz) = b747ef1eb7bc87df079dfa8cac750081
+SIZE (md5deep-1.3.tar.gz) = 27208
diff --git a/security/md5deep/pkg-descr b/security/md5deep/pkg-descr
new file mode 100644
index 000000000000..3b7f170c8acf
--- /dev/null
+++ b/security/md5deep/pkg-descr
@@ -0,0 +1,8 @@
+md5deep is a cross-platform set of programs to compute
+MD5 message digests or SHA-1 message digests on an arbitrary
+number of files. The programs run on Windows, Linux, *BSD,
+OS X, Solaris, and should run on most other platforms.
+md5deep is similar to the md5sum program found in the
+GNU Coreutils package, but has many additional features.
+
+WWW: http://md5deep.sourceforge.net