aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-openexr/Makefile29
-rw-r--r--graphics/py-openexr/distinfo3
-rw-r--r--graphics/py-openexr/pkg-descr7
-rw-r--r--graphics/py-openexr/pkg-plist4
5 files changed, 44 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 29d50ad16e50..4902a344484c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -782,6 +782,7 @@
SUBDIR += py-gvgen
SUBDIR += py-imaging
SUBDIR += py-ming
+ SUBDIR += py-openexr
SUBDIR += py-opengl
SUBDIR += py-paint
SUBDIR += py-poppler
diff --git a/graphics/py-openexr/Makefile b/graphics/py-openexr/Makefile
new file mode 100644
index 000000000000..7600617c8915
--- /dev/null
+++ b/graphics/py-openexr/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-openexr
+# Date created: 10 October 2010
+# Whom: James Bowman <jamesb-bsd@excamera.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openexr
+PORTVERSION= 1.2.0
+CATEGORIES= graphics python
+MASTER_SITES= http://excamera.com/files/ \
+ CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= OpenEXR-${PORTVERSION}
+
+MAINTAINER= jamesb-bsd@excamera.com
+COMMENT= Python module for ILM's OpenEXR image format and library
+
+LIB_DEPENDS= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+
+post-extract:
+ ${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/setup.py
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= OpenEXR
+MASTER_SITE_SUBDIR=source/O/OpenEXR
+
+.include <bsd.port.mk>
diff --git a/graphics/py-openexr/distinfo b/graphics/py-openexr/distinfo
new file mode 100644
index 000000000000..c3b574e73935
--- /dev/null
+++ b/graphics/py-openexr/distinfo
@@ -0,0 +1,3 @@
+MD5 (OpenEXR-1.2.0.tar.gz) = cbddfef9e499e7da30434a093707c6f2
+SHA256 (OpenEXR-1.2.0.tar.gz) = 1c2288b6099fdebe163e7efe45b4d2c4c4192e0b89f21cef5f1ac554134498eb
+SIZE (OpenEXR-1.2.0.tar.gz) = 9280
diff --git a/graphics/py-openexr/pkg-descr b/graphics/py-openexr/pkg-descr
new file mode 100644
index 000000000000..3cd11f282ddf
--- /dev/null
+++ b/graphics/py-openexr/pkg-descr
@@ -0,0 +1,7 @@
+OpenEXR is an image format developed by ILM. Its main innovation
+is support for high dynamic range; it supports floating point pixels.
+
+This Python module provides bindings for the OpenEXR C++ libraries.
+They allow you to read and write OpenEXR files from Python.
+
+WWW: http://www.excamera.com/sphinx/articles-openexr.html
diff --git a/graphics/py-openexr/pkg-plist b/graphics/py-openexr/pkg-plist
new file mode 100644
index 000000000000..967530ec2ae3
--- /dev/null
+++ b/graphics/py-openexr/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/OpenEXR.so
+%%PYTHON_SITELIBDIR%%/Imath.py
+%%PYTHON_SITELIBDIR%%/Imath.pyc
+%%PYTHON_SITELIBDIR%%/Imath.pyo