aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/soundgrab/Makefile6
-rw-r--r--devel/p5-Class-Tom/Makefile1
-rw-r--r--devel/p5-ConfigReader/Makefile9
-rw-r--r--devel/p5-File-ReadBackwards/Makefile1
-rw-r--r--devel/p5-PV/Makefile4
-rw-r--r--devel/perlconsole/Makefile31
-rw-r--r--mail/bayespam/Makefile4
-rw-r--r--net-mgmt/remarp/Makefile4
-rw-r--r--russian/p5-XML-Parser-encodings/Makefile2
-rw-r--r--www/cgi-lib.pl/Makefile2
-rw-r--r--www/htmlpp/Makefile6
-rw-r--r--www/p5-URI-Sequin/Makefile4
-rw-r--r--www/wwwstat/Makefile2
13 files changed, 35 insertions, 41 deletions
diff --git a/audio/soundgrab/Makefile b/audio/soundgrab/Makefile
index 7850b4514880..96b593eb83ec 100644
--- a/audio/soundgrab/Makefile
+++ b/audio/soundgrab/Makefile
@@ -20,10 +20,8 @@ RUN_DEPENDS= sox:${PORTSDIR}/audio/sox \
rawplay:${PORTSDIR}/audio/rawrec \
oggenc:${PORTSDIR}/audio/vorbis-tools \
flac:${PORTSDIR}/audio/flac \
- ${PERL_SITELIBDIR}/${PERL_VER}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
- ${PERL_SITELIBDIR}/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-
-PERL_SITELIBDIR= ${LOCALBASE}/lib/perl5/site_perl
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
USE_PERL5= yes
NO_BUILD= yes
diff --git a/devel/p5-Class-Tom/Makefile b/devel/p5-Class-Tom/Makefile
index 1a0d8ea668b8..108c73b71cda 100644
--- a/devel/p5-Class-Tom/Makefile
+++ b/devel/p5-Class-Tom/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
RUN_DEPENDS= ${BUILD_DEPENDS}
-SITE_PERL= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
PERL_CONFIGURE= yes
MAN3= Class::Tom.3
diff --git a/devel/p5-ConfigReader/Makefile b/devel/p5-ConfigReader/Makefile
index 67f9f1aed350..bc4b3ead024c 100644
--- a/devel/p5-ConfigReader/Makefile
+++ b/devel/p5-ConfigReader/Makefile
@@ -20,10 +20,9 @@ USE_PERL5= YES
NO_BUILD= YES
do-install:
- @ ${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/ConfigReader/
- @ ${INSTALL_DATA} ${WRKSRC}/DirectiveStyle.pm ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/ConfigReader/
- @ ${INSTALL_DATA} ${WRKSRC}/Spec.pm ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/ConfigReader/
- @ ${INSTALL_DATA} ${WRKSRC}/Values.pm ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/ConfigReader/
- @ ${INSTALL_DATA} ${WRKSRC}/ConfigReader.pod ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+ ${MKDIR} ${PREFIX}/${SITE_PERL_REL}/ConfigReader/
+ ${INSTALL_DATA} ${WRKSRC}/DirectiveStyle.pm ${WRKSRC}/Spec.pm \
+ ${WRKSRC}/Values.pm ${PREFIX}/${SITE_PERL_REL}/ConfigReader/
+ ${INSTALL_DATA} ${WRKSRC}/ConfigReader.pod ${PREFIX}/${SITE_PERL_REL}/
.include <bsd.port.mk>
diff --git a/devel/p5-File-ReadBackwards/Makefile b/devel/p5-File-ReadBackwards/Makefile
index a0fa9672e6b9..2cc2242e8cb8 100644
--- a/devel/p5-File-ReadBackwards/Makefile
+++ b/devel/p5-File-ReadBackwards/Makefile
@@ -17,7 +17,6 @@ COMMENT= File::ReadBackwards -- read a file backwards by lines
BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS= ${BUILD_DEPENDS}
-SITE_PERL= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
PERL_CONFIGURE= yes
MAN3= File::ReadBackwards.3
diff --git a/devel/p5-PV/Makefile b/devel/p5-PV/Makefile
index e2641a984d53..bd47987e412d 100644
--- a/devel/p5-PV/Makefile
+++ b/devel/p5-PV/Makefile
@@ -23,7 +23,7 @@ NO_BUILD= YES
PLIST_FILES= %%SITE_PERL%%/PV.pm
do-install:
- ${MKDIR} -m 755 ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
- ${INSTALL_DATA} ${WRKSRC}/PV.pm ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+ ${MKDIR} -m 755 ${PREFIX}/${SITE_PERL_REL}/
+ ${INSTALL_DATA} ${WRKSRC}/PV.pm ${PREFIX}/${SITE_PERL_REL}/
.include <bsd.port.mk>
diff --git a/devel/perlconsole/Makefile b/devel/perlconsole/Makefile
index 8a22a78f4f01..a39679c60e2f 100644
--- a/devel/perlconsole/Makefile
+++ b/devel/perlconsole/Makefile
@@ -8,18 +8,17 @@
PORTNAME= perlconsole
PORTVERSION= 0.4
CATEGORIES= devel
-MASTER_SITES= http://www.cpan.org/modules/by-module/Test/SUKRIA/
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SU/SUKRIA
MAINTAINER= jadawin@FreeBSD.org
COMMENT= A light program that lets you evaluate Perl code interactively
-RUN_DEPENDS= ${BASEP}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
- ${BASEP}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
- ${BASEP}/Module/Refresh.pm:${PORTSDIR}/devel/p5-Module-Refresh \
- ${BASEP}/Lexical/Persistence.pm:${PORTSDIR}/devel/p5-Lexical-Persistence \
- ${BASEP}/B/Keywords.pm:${PORTSDIR}/devel/p5-B-Keywords
-
-BASEP= ${SITE_PERL}
+RUN_DEPENDS= ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
+ ${SITE_PERL}/Module/Refresh.pm:${PORTSDIR}/devel/p5-Module-Refresh \
+ ${SITE_PERL}/Lexical/Persistence.pm:${PORTSDIR}/devel/p5-Lexical-Persistence \
+ ${SITE_PERL}/B/Keywords.pm:${PORTSDIR}/devel/p5-B-Keywords
USE_PERL5= yes
PERL_CONFIGURE= 5.8.0+
@@ -29,12 +28,12 @@ PORTDOCS= README \
CHANGES
PLIST_FILES= bin/perlconsole \
- lib/perl5/${PERL_VER}/PerlConsole/Commands.pm \
- lib/perl5/${PERL_VER}/PerlConsole/Console.pm \
- lib/perl5/${PERL_VER}/PerlConsole/Preferences.pm \
- lib/perl5/${PERL_VER}/PerlConsole.pm
+ ${SITE_PERL_REL}/PerlConsole/Commands.pm \
+ ${SITE_PERL_REL}/PerlConsole/Console.pm \
+ ${SITE_PERL_REL}/PerlConsole/Preferences.pm \
+ ${SITE_PERL_REL}/PerlConsole.pm
-PLIST_DIRS= lib/perl5/${PERL_VER}/PerlConsole
+PLIST_DIRS= ${SITE_PERL_REL}/PerlConsole
do-install:
.if !defined(NOPORTDOCS)
@@ -43,11 +42,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
- ${MKDIR} ${PREFIX}/lib/perl5/${PERL_VER}/PerlConsole/
+ ${MKDIR} ${PREFIX}/${SITE_PERL_REL}/PerlConsole/
${CP} -R ${WRKSRC}/lib/PerlConsole/ \
- ${PREFIX}/lib/perl5/${PERL_VER}/PerlConsole/
+ ${PREFIX}/${SITE_PERL_REL}/PerlConsole/
${CP} ${WRKSRC}/lib/PerlConsole.pm \
- ${PREFIX}/lib/perl5/${PERL_VER}/PerlConsole.pm
+ ${PREFIX}/${SITE_PERL_REL}/PerlConsole.pm
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/mail/bayespam/Makefile b/mail/bayespam/Makefile
index ac0325c91752..2dacadddbf6a 100644
--- a/mail/bayespam/Makefile
+++ b/mail/bayespam/Makefile
@@ -40,9 +40,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
- @${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Bayespam
+ @${MKDIR} ${PREFIX}/${SITE_PERL_REL}/Bayespam
@${INSTALL_DATA} ${WRKSRC}/Bayespam/Process.pm \
- ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Bayespam
+ ${PREFIX}/${SITE_PERL_REL}/Bayespam
.for file in ${FILES_SCRIPTS}
@${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
.endfor
diff --git a/net-mgmt/remarp/Makefile b/net-mgmt/remarp/Makefile
index 5b1d08cb9738..bb7adab3d977 100644
--- a/net-mgmt/remarp/Makefile
+++ b/net-mgmt/remarp/Makefile
@@ -31,10 +31,10 @@ pre-patch:
s|use lib "\$$Bin/../lib";||' ${WRKSRC}/lib/remarp/configure.pm
do-install:
- ${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/remarp
+ ${MKDIR} ${PREFIX}/${SITE_PERL_REL}/remarp
${MKDIR} ${REMARP_SPOOL}
${INSTALL_DATA} ${WRKSRC}/etc/remarp.conf ${PREFIX}/etc/remarp.conf.sample
- ${INSTALL_DATA} ${WRKSRC}/lib/remarp/*.pm ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/remarp
+ ${INSTALL_DATA} ${WRKSRC}/lib/remarp/*.pm ${PREFIX}/${SITE_PERL_REL}/remarp
${INSTALL_SCRIPT} ${WRKSRC}/sbin/remarp.pl ${PREFIX}/sbin/remarp
post-install:
diff --git a/russian/p5-XML-Parser-encodings/Makefile b/russian/p5-XML-Parser-encodings/Makefile
index dcba02c76c60..52eecef9f652 100644
--- a/russian/p5-XML-Parser-encodings/Makefile
+++ b/russian/p5-XML-Parser-encodings/Makefile
@@ -52,6 +52,6 @@ do-build:
do-install:
${INSTALL_DATA} ${WRKSRC}/*.enc \
- ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser/Encodings/
+ ${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/XML/Parser/Encodings/
.include <bsd.port.mk>
diff --git a/www/cgi-lib.pl/Makefile b/www/cgi-lib.pl/Makefile
index 8c81b3e17fca..da299730aba1 100644
--- a/www/cgi-lib.pl/Makefile
+++ b/www/cgi-lib.pl/Makefile
@@ -22,7 +22,7 @@ NO_WRKSUBDIR= YES
PLIST_FILES= %%SITE_PERL%%/cgi-lib.pl
EXTRACT_AFTER_ARGS= > cgi-lib.pl
-INSTALL_BASE= lib/perl5/site_perl/${PERL_VER}
+INSTALL_BASE= ${SITE_PERL_REL}
INSTALL_DIR= ${PREFIX}/${INSTALL_BASE}
do-install:
diff --git a/www/htmlpp/Makefile b/www/htmlpp/Makefile
index 9fa3a2c6ac9f..3e721fc6de13 100644
--- a/www/htmlpp/Makefile
+++ b/www/htmlpp/Makefile
@@ -26,10 +26,10 @@ do-build:
${MV} ${WRKDIR}/htmlpp.temp ${WRKDIR}/htmlpp
do-install:
- ${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+ ${MKDIR} ${PREFIX}/${SITE_PERL_REL}
${INSTALL_SCRIPT} ${WRKDIR}/htmlpp ${PREFIX}/bin/htmlpp
- ${INSTALL_DATA} ${WRKDIR}/htmlpp.d ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/htmlpp.d
- (cd ${WRKDIR}; for FILE in *.pl; do ${INSTALL_DATA} $${FILE} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/$${FILE}; done)
+ ${INSTALL_DATA} ${WRKDIR}/htmlpp.d ${PREFIX}/${SITE_PERL_REL}/htmlpp.d
+ (cd ${WRKDIR}; for FILE in *.pl; do ${INSTALL_DATA} $${FILE} ${PREFIX}/${SITE_PERL_REL}/$${FILE}; done)
(cd ${WRKDIR}; for FILE in *.def; do ${INSTALL_DATA} $${FILE} ${PREFIX}/bin/$${FILE}; done)
${INSTALL_DATA} ${WRKDIR}/guru_opt.fmt ${PREFIX}/bin/guru.fmt
(cd ${WRKDIR}; ${MKDIR} ${PREFIX}/share/doc/htmlpp; for FILE in *.htm; do ${INSTALL_DATA} $${FILE} ${PREFIX}/share/doc/htmlpp/$${FILE}; done)
diff --git a/www/p5-URI-Sequin/Makefile b/www/p5-URI-Sequin/Makefile
index 03a86201df62..d580168df987 100644
--- a/www/p5-URI-Sequin/Makefile
+++ b/www/p5-URI-Sequin/Makefile
@@ -21,9 +21,9 @@ MAN3= URI::Sequin.3
.ifndef (NOPORTDOCS)
post-install:
- @${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/URI/Sequin/examples
+ @${MKDIR} ${PREFIX}/${SITE_PERL_REL}/URI/Sequin/examples
@${INSTALL_DATA} ${WRKSRC}/example.pl ${WRKSRC}/ref?.log \
- ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/URI/Sequin/examples
+ ${PREFIX}/${SITE_PERL_REL}/URI/Sequin/examples
.endif
.include <bsd.port.mk>
diff --git a/www/wwwstat/Makefile b/www/wwwstat/Makefile
index 680f8264c8ae..6c196ae4ca7c 100644
--- a/www/wwwstat/Makefile
+++ b/www/wwwstat/Makefile
@@ -26,7 +26,7 @@ APACHE_COMPAT= yes
MAKE_ENV+= PERL5=${PERL5}
DIST_SUBDIR= wwwstat
MAN1= wwwstat.1 splitlog.1
-SITEPERL= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
+SITEPERL= ${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}
do-install:
@if [ ! -d ${SITEPERL} ]; then \