aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING18
-rw-r--r--databases/couchdb/Makefile2
-rw-r--r--databases/firebird20-server/Makefile2
-rw-r--r--databases/postgresql84-server/Makefile6
-rw-r--r--databases/postgresql90-server/Makefile6
-rw-r--r--databases/postgresql91-server/Makefile6
-rw-r--r--databases/postgresql92-server/Makefile6
-rw-r--r--databases/sqlite3/Makefile2
-rw-r--r--devel/boost-libs/Makefile2
-rw-r--r--devel/pecl-intl/Makefile4
-rw-r--r--devel/py-icu/Makefile4
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--emulators/xcpc/Makefile2
-rw-r--r--lang/parrot/Makefile3
-rw-r--r--lang/rakudo/Makefile2
-rw-r--r--math/R/Makefile1
-rw-r--r--net/yaz/Makefile1
-rw-r--r--textproc/dwdiff/Makefile1
-rw-r--r--textproc/ibus-qt/Makefile1
-rw-r--r--textproc/xaira/Makefile2
-rw-r--r--www/webkit-gtk2/Makefile2
21 files changed, 49 insertions, 26 deletions
diff --git a/UPDATING b/UPDATING
index 59b8fff0b499..33caf62f0c2b 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,24 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20101214:
+ AFFECTS: users of devel/icu
+ AUTHOR: bapt@FreeBSD.org
+
+ icu has been updated to version 4.6. Please rebuild all ports that depends
+ on it.
+
+ If you use portmaster:
+ # portmaster -r icu
+
+ If you use portupgrade:
+ # portupgrade -fr devel/icu
+
+ Note that devel/icu4 is now deprecated consider replacing it by devel/icu
+ # portmaster -o devel/icu devel/icu4
+ or
+ # env DISABLE_CONFLICTS=1 portupgrade -o devel/icu -f icu-4\*
+
20101211:
AFFECTS: users of devel/bugzilla, japanese/bugzilla and russian/bugzilla-ru
AUTHOR: tota@FreeBSD.org
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index 7cb7eab2e27d..1d9a04df4e11 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= couchdb
PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_APACHE}
diff --git a/databases/firebird20-server/Makefile b/databases/firebird20-server/Makefile
index d6e40709e82d..3ae964fa7dc5 100644
--- a/databases/firebird20-server/Makefile
+++ b/databases/firebird20-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= firebird
PORTVERSION= 2.0.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES?= databases
MASTER_SITES= SF/firebird/OldFiles
PKGNAMESUFFIX?= -server
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 432f397574cd..df3d2dbddb02 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -97,8 +97,8 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-OPTIONS+= ICU "Use ICU 3.x for unicode collation (server)" off
-OPTIONS+= ICU4 "Use ICU 4.x for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU 4.6 for unicode collation (server)" off
+OPTIONS+= ICU4 "Use ICU 4.4 for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
@@ -117,7 +117,7 @@ PATCHFILES+= pg-840-icu-2009-09-15.diff.gz:icu
LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
. else
-LIB_DEPENDS+= icudata.38:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
. endif
. endif
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 70a32eca1050..dc3eb4f1c7a1 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -97,8 +97,8 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-OPTIONS+= ICU "Use ICU 3.x for unicode collation (server)" off
-OPTIONS+= ICU4 "Use ICU 4.x for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU 4.6 for unicode collation (server)" off
+OPTIONS+= ICU4 "Use ICU 4.4 for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
@@ -116,7 +116,7 @@ PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
. if defined(WITH_ICU4)
LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
. else
-LIB_DEPENDS+= icudata.38:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
. endif
. endif
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index 70a32eca1050..dc3eb4f1c7a1 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -97,8 +97,8 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-OPTIONS+= ICU "Use ICU 3.x for unicode collation (server)" off
-OPTIONS+= ICU4 "Use ICU 4.x for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU 4.6 for unicode collation (server)" off
+OPTIONS+= ICU4 "Use ICU 4.4 for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
@@ -116,7 +116,7 @@ PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
. if defined(WITH_ICU4)
LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
. else
-LIB_DEPENDS+= icudata.38:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
. endif
. endif
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 70a32eca1050..dc3eb4f1c7a1 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -97,8 +97,8 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-OPTIONS+= ICU "Use ICU 3.x for unicode collation (server)" off
-OPTIONS+= ICU4 "Use ICU 4.x for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU 4.6 for unicode collation (server)" off
+OPTIONS+= ICU4 "Use ICU 4.4 for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
@@ -116,7 +116,7 @@ PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
. if defined(WITH_ICU4)
LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
. else
-LIB_DEPENDS+= icudata.38:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
. endif
. endif
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index f61c75331108..338cd0122571 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -113,7 +113,7 @@ CFLAGS+= -DSQLITE_ENABLE_RTREE=1
.if defined(WITH_ICU)
BUILD_DEPENDS+= ${LOCALBASE}/bin/icu-config:${PORTSDIR}/devel/icu
-LIB_DEPENDS+= icudata.38:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
CFLAGS+= -DSQLITE_ENABLE_ICU=1
CPPFLAGS+= `${LOCALBASE}/bin/icu-config --cppflags`
LDFLAGS+= `${LOCALBASE}/bin/icu-config --ldflags`
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index f45d736f8a3a..483ce9b00df8 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= boost-libs
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= Free portable C++ libraries (without Boost.Python)
USE_BZIP2= yes
diff --git a/devel/pecl-intl/Makefile b/devel/pecl-intl/Makefile
index fe7480389b8c..bd2b3b656493 100644
--- a/devel/pecl-intl/Makefile
+++ b/devel/pecl-intl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= intl
PORTVERSION= 1.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -17,7 +17,7 @@ DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= A PECL extension to support Internationalization(ICU)
-LIB_DEPENDS= icui18n.38:${PORTSDIR}/devel/icu
+LIB_DEPENDS= icui18n.46:${PORTSDIR}/devel/icu
USE_PHP= yes
USE_PHPEXT= yes
diff --git a/devel/py-icu/Makefile b/devel/py-icu/Makefile
index cb27b969c4fc..699afbbd51e8 100644
--- a/devel/py-icu/Makefile
+++ b/devel/py-icu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icu
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
MASTER_SITE_SUBDIR= source/P/PyICU
@@ -28,7 +28,7 @@ MAKE_ENV+= \
PYICU_LFLAGS="-L${PREFIX}/lib" \
PYICU_LIBRARIES="icui18n:icuuc:icudata"
-OPTIONS= ICU4 "Use ICU 4.x instead of 3.8" off
+OPTIONS= ICU4 "Use ICU 4.x instead of 4.6" off
.include <bsd.port.pre.mk>
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 55238966f5fe..4bdbc5fe9f98 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= open-vm-tools
PORTVERSION= ${BUILD_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators kld
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${RELEASE_DATE}
DISTNAME= open-vm-tools-${RELEASE_DATE}-${BUILD_VER}
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
index 2260ab8b81b5..a6605d7e1b61 100644
--- a/emulators/xcpc/Makefile
+++ b/emulators/xcpc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xcpc
PORTVERSION= 20070122
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index 8b7186f0cda7..9f01d039e509 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= parrot
PORTVERSION= ${PARROT_VERSION}
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/devel/${PORTVERSION}/
@@ -17,7 +18,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/pcre-config:${PORTSDIR}/devel/pcre
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- icudata.38:${PORTSDIR}/devel/icu
+ icudata.46:${PORTSDIR}/devel/icu
LICENSE= ART20
diff --git a/lang/rakudo/Makefile b/lang/rakudo/Makefile
index 1b12aa300db4..68fddb37cf1b 100644
--- a/lang/rakudo/Makefile
+++ b/lang/rakudo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rakudo
PORTVERSION= 2010.11
-PORTEPOCH= 1
+PORTEPOCH= 2
CATEGORIES= lang
MASTER_SITES= http://cloud.github.com/downloads/rakudo/star/
DISTNAME= ${PORTNAME}-star-${PORTVERSION}
diff --git a/math/R/Makefile b/math/R/Makefile
index adb0906349f1..ea43035ee5a9 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -12,6 +12,7 @@ PORTNAME= libRmath
PORTNAME= R
.endif
PORTVERSION= 2.11.1
+PORTREVISION= 1
CATEGORIES= math lang
MASTER_SITES= http://cran.r-project.org/src/base/R-2/ \
ftp://cran.r-project.org/pub/R/src/base/R-2/ \
diff --git a/net/yaz/Makefile b/net/yaz/Makefile
index ecacadd8650d..43a07308382e 100644
--- a/net/yaz/Makefile
+++ b/net/yaz/Makefile
@@ -7,6 +7,7 @@
PORTNAME= yaz
PORTVERSION= 4.0.12
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ftp.indexdata.dk/pub/yaz/
diff --git a/textproc/dwdiff/Makefile b/textproc/dwdiff/Makefile
index ad22fed1d4c6..6c5944430794 100644
--- a/textproc/dwdiff/Makefile
+++ b/textproc/dwdiff/Makefile
@@ -6,6 +6,7 @@
PORTNAME= dwdiff
PORTVERSION= 1.8.2
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://os.ghalkes.nl/dist/ \
http://www.logvinov.ru/files/dist/ \
diff --git a/textproc/ibus-qt/Makefile b/textproc/ibus-qt/Makefile
index f0366e5c9780..f6c2b903f649 100644
--- a/textproc/ibus-qt/Makefile
+++ b/textproc/ibus-qt/Makefile
@@ -6,6 +6,7 @@
PORTNAME= ibus-qt
PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
diff --git a/textproc/xaira/Makefile b/textproc/xaira/Makefile
index 519f1dcdd545..38fc4ef1799a 100644
--- a/textproc/xaira/Makefile
+++ b/textproc/xaira/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xaira
PORTVERSION= 1.23
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index f85cc7d91cad..54a75ca8f226 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -57,7 +57,7 @@ OPTIONS= VIDEO "Enable video support" on \
LIB_DEPENDS+= icutu.44:${PORTSDIR}/devel/icu4
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-WebCore_platform_text_TextBreakIterator.h
.else
-LIB_DEPENDS+= icutu.38:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= icutu.46:${PORTSDIR}/devel/icu
.endif
.if defined(WITH_VIDEO)