aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-Haval256/Makefile24
-rw-r--r--security/p5-Digest-Haval256/distinfo3
-rw-r--r--security/p5-Digest-Haval256/pkg-descr7
-rw-r--r--security/p5-Digest-Haval256/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 630190b14040..69f918cf3458 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -331,6 +331,7 @@
SUBDIR += p5-Digest
SUBDIR += p5-Digest-BubbleBabble
SUBDIR += p5-Digest-HMAC
+ SUBDIR += p5-Digest-Haval256
SUBDIR += p5-Digest-MD2
SUBDIR += p5-Digest-MD4
SUBDIR += p5-Digest-MD5
diff --git a/security/p5-Digest-Haval256/Makefile b/security/p5-Digest-Haval256/Makefile
new file mode 100644
index 000000000000..eb9596e9f49f
--- /dev/null
+++ b/security/p5-Digest-Haval256/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-Haval256
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-Haval256
+PORTVERSION= 1.0.5
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for Haval256 hash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::Haval256.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-Haval256/distinfo b/security/p5-Digest-Haval256/distinfo
new file mode 100644
index 000000000000..f4f5877c2e12
--- /dev/null
+++ b/security/p5-Digest-Haval256/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-Haval256-1.0.5.tar.gz) = 0c21dba52b2775837d6c1c93f21643b0
+SHA256 (Digest-Haval256-1.0.5.tar.gz) = cfe0e0fbc8b1ef2b57f09c3e12962a2a93a60a0069385938db1bbe3e48a9eb97
+SIZE (Digest-Haval256-1.0.5.tar.gz) = 24257
diff --git a/security/p5-Digest-Haval256/pkg-descr b/security/p5-Digest-Haval256/pkg-descr
new file mode 100644
index 000000000000..72a0c937589d
--- /dev/null
+++ b/security/p5-Digest-Haval256/pkg-descr
@@ -0,0 +1,7 @@
+Haval is a variable-length, variable-round one-way hash function designed by
+Yuliang Zheng, Josef Pieprzyk, and Jennifer Seberry. The number of rounds can
+be 3, 4, or 5, while the hash length can be 128, 160, 192, 224, or 256 bits.
+Thus, there are a total of 15 different outputs. For better security, however,
+this module implements the 5-round, 256-bit output.
+
+WWW: http://search.cpan.org/dist/Digest-Haval256
diff --git a/security/p5-Digest-Haval256/pkg-plist b/security/p5-Digest-Haval256/pkg-plist
new file mode 100644
index 000000000000..d56296269cec
--- /dev/null
+++ b/security/p5-Digest-Haval256/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/Haval256.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Haval256/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Haval256/Haval256.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Haval256/Haval256.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Haval256
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Digest/ 2>/dev/null || true