aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-Auth_RADIUS/Makefile26
-rw-r--r--net/pear-Auth_RADIUS/distinfo2
-rw-r--r--net/pear-Auth_RADIUS/pkg-descr6
4 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a4574e6a94e7..911a26d20b5b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -547,6 +547,7 @@
SUBDIR += pbnc
SUBDIR += pchar
SUBDIR += pcnfsd
+ SUBDIR += pear-Auth_RADIUS
SUBDIR += pear-Net_CheckIP
SUBDIR += pear-Net_DIME
SUBDIR += pear-Net_DNSBL
diff --git a/net/pear-Auth_RADIUS/Makefile b/net/pear-Auth_RADIUS/Makefile
new file mode 100644
index 000000000000..8f2258881771
--- /dev/null
+++ b/net/pear-Auth_RADIUS/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Auth_RADIUS
+# Date created: 11 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Auth_RADIUS
+PORTVERSION= 1.0.4
+CATEGORIES= net security pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR wrapper classes for the RADIUS PECL
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= radius
+
+CATEGORY= Auth
+FILES= RADIUS.php
+EXAMPLES= radius-acct.php radius-auth.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Auth_RADIUS/distinfo b/net/pear-Auth_RADIUS/distinfo
new file mode 100644
index 000000000000..e018092cda08
--- /dev/null
+++ b/net/pear-Auth_RADIUS/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Auth_RADIUS-1.0.4.tgz) = 1463850d06db8ed70a0aa2fadd6be0e5
+SIZE (PEAR/Auth_RADIUS-1.0.4.tgz) = 8232
diff --git a/net/pear-Auth_RADIUS/pkg-descr b/net/pear-Auth_RADIUS/pkg-descr
new file mode 100644
index 000000000000..a6cd0bb36efb
--- /dev/null
+++ b/net/pear-Auth_RADIUS/pkg-descr
@@ -0,0 +1,6 @@
+PEAR::Auth_RADIUS provides wrapper-classes for the RADIUS PECL.
+There are different Classes for the different authentication methods.
+If you are using CHAP-MD5 or MS-CHAP you need also the Crypt_CHAP package.
+If you are using MS-CHAP you need also the mhash and mcrypt extension.
+
+WWW: http://pear.php.net/package/Auth_RADIUS/