aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/clearsilver/Makefile36
-rw-r--r--www/clearsilver/pkg-plist120
-rw-r--r--www/http_get/Makefile6
-rw-r--r--www/http_load/Makefile6
-rw-r--r--www/p5-HTTPD-Log-Filter/Makefile3
-rw-r--r--www/p5-HTTPD-Log-Filter/pkg-plist2
-rw-r--r--www/p5-WWW-iTunesConnect/Makefile6
-rw-r--r--www/sitecopy/Makefile2
-rw-r--r--www/sitecopy/pkg-plist1
9 files changed, 130 insertions, 52 deletions
diff --git a/www/clearsilver/Makefile b/www/clearsilver/Makefile
index 515448eb55d5..445e955d954b 100644
--- a/www/clearsilver/Makefile
+++ b/www/clearsilver/Makefile
@@ -10,8 +10,7 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= A fast, powerful, and language-neutral template system
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-MANCOMPRESSED= no
+USES= gmake
CONFIGURE_ARGS= --disable-apache --disable-perl --disable-ruby \
--disable-java --disable-csharp
@@ -26,39 +25,6 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
-MAN3= cBroadcast.3 cCreate.3 cDestroy.3 cSignal.3 cWait.3 \
- cgi_cookie_authority.3 cgi_cookie_clear.3 cgi_cookie_set.3 \
- cgi_cs_init.3 cgi_debug_init.3 cgi_destroy.3 cgi_display.3 cgi_error.3 \
- cgi_filehandle.3 cgi_init.3 cgi_neo_error.3 cgi_output.3 cgi_parse.3 \
- cgi_redirect.3 cgi_redirect_uri.3 cgi_register_parse_cb.3 \
- cgi_url_escape.3 cgi_url_escape_more.3 cgi_url_unescape.3 \
- cgi_url_validate.3 \
- cgi_vredirect.3 cgiwrap_getenv.3 cgiwrap_init_emu.3 cgiwrap_init_std.3 \
- cgiwrap_iterenv.3 cgiwrap_putenv.3 cgiwrap_read.3 cgiwrap_write.3 \
- cgiwrap_writef.3 cgiwrap_writevf.3 cs_destroy.3 cs_dump.3 cs_init.3 \
- cs_parse_file.3 cs_parse_string.3 cs_register_esc_strfunc.3 \
- cs_register_fileload.3 cs_register_strfunc.3 cs_render.3 \
- dictCleanup.3 dictCreate.3 dictDestroy.3 dictModifyValue.3 dictNext.3 \
- dictReleaseLock.3 dictRemove.3 dictSearch.3 dictSetValue.3 fCreate.3 \
- fDestroy.3 fFind.3 fLock.3 fUnlock.3 filter_create_fd.3 \
- filter_create_fp.3 filter_wait.3 hdf_copy.3 hdf_destroy.3 hdf_dump.3 \
- hdf_dump_format.3 hdf_dump_str.3 hdf_get_attr.3 hdf_get_child.3 \
- hdf_get_copy.3 hdf_get_int_value.3 hdf_get_node.3 hdf_get_obj.3 \
- hdf_get_value.3 hdf_get_valuef.3 hdf_get_valuevf.3 hdf_init.3 \
- hdf_obj_attr.3 hdf_obj_child.3 hdf_obj_name.3 hdf_obj_next.3 \
- hdf_obj_top.3 hdf_obj_value.3 hdf_read_string.3 \
- hdf_read_string_ignore.3 hdf_register_fileload.3 hdf_remove_tree.3 \
- hdf_search_path.3 hdf_set_attr.3 hdf_set_buf.3 hdf_set_copy.3 \
- hdf_set_int_value.3 hdf_set_symlink.3 hdf_set_value.3 \
- hdf_set_valuef.3 hdf_sort_obj.3 hdf_write_file.3 \
- hdf_write_file_atomic.3 hdf_write_string.3 mCreate.3 \
- mDestroy.3 mLock.3 mUnlock.3 nerr_ignore.3 nerr_error_string.3 \
- nerr_error_traceback.3 nerr_handle.3 nerr_init.3 nerr_log_error.3 \
- nerr_match.3 nerr_pass.3 nerr_pass_ctx.3 nerr_register.3 \
- skipDelete.3 skipFreeList.3 skipInsert.3 skipNewList.3 skipNext.3 \
- skipRelease.3 skipSearch.3 wdb_keys.3
-
-NO_STAGE= yes
post-patch:
@# Remove CFLAGS when building the python module, pydistfile is used
@# and will do the right thing.
diff --git a/www/clearsilver/pkg-plist b/www/clearsilver/pkg-plist
index ea6aa6074ea5..2eba575c8008 100644
--- a/www/clearsilver/pkg-plist
+++ b/www/clearsilver/pkg-plist
@@ -1,6 +1,126 @@
bin/cs
bin/cs_static.cgi
bin/cstest
+man/man3/cBroadcast.3.gz
+man/man3/cCreate.3.gz
+man/man3/cDestroy.3.gz
+man/man3/cSignal.3.gz
+man/man3/cWait.3.gz
+man/man3/cgi_cookie_authority.3.gz
+man/man3/cgi_cookie_clear.3.gz
+man/man3/cgi_cookie_set.3.gz
+man/man3/cgi_cs_init.3.gz
+man/man3/cgi_debug_init.3.gz
+man/man3/cgi_destroy.3.gz
+man/man3/cgi_display.3.gz
+man/man3/cgi_error.3.gz
+man/man3/cgi_filehandle.3.gz
+man/man3/cgi_init.3.gz
+man/man3/cgi_neo_error.3.gz
+man/man3/cgi_output.3.gz
+man/man3/cgi_parse.3.gz
+man/man3/cgi_redirect.3.gz
+man/man3/cgi_redirect_uri.3.gz
+man/man3/cgi_register_parse_cb.3.gz
+man/man3/cgi_url_escape.3.gz
+man/man3/cgi_url_escape_more.3.gz
+man/man3/cgi_url_unescape.3.gz
+man/man3/cgi_url_validate.3.gz
+man/man3/cgi_vredirect.3.gz
+man/man3/cgiwrap_getenv.3.gz
+man/man3/cgiwrap_init_emu.3.gz
+man/man3/cgiwrap_init_std.3.gz
+man/man3/cgiwrap_iterenv.3.gz
+man/man3/cgiwrap_putenv.3.gz
+man/man3/cgiwrap_read.3.gz
+man/man3/cgiwrap_write.3.gz
+man/man3/cgiwrap_writef.3.gz
+man/man3/cgiwrap_writevf.3.gz
+man/man3/cs_destroy.3.gz
+man/man3/cs_dump.3.gz
+man/man3/cs_init.3.gz
+man/man3/cs_parse_file.3.gz
+man/man3/cs_parse_string.3.gz
+man/man3/cs_register_esc_strfunc.3.gz
+man/man3/cs_register_fileload.3.gz
+man/man3/cs_register_strfunc.3.gz
+man/man3/cs_render.3.gz
+man/man3/dictCleanup.3.gz
+man/man3/dictCreate.3.gz
+man/man3/dictDestroy.3.gz
+man/man3/dictModifyValue.3.gz
+man/man3/dictNext.3.gz
+man/man3/dictReleaseLock.3.gz
+man/man3/dictRemove.3.gz
+man/man3/dictSearch.3.gz
+man/man3/dictSetValue.3.gz
+man/man3/fCreate.3.gz
+man/man3/fDestroy.3.gz
+man/man3/fFind.3.gz
+man/man3/fLock.3.gz
+man/man3/fUnlock.3.gz
+man/man3/filter_create_fd.3.gz
+man/man3/filter_create_fp.3.gz
+man/man3/filter_wait.3.gz
+man/man3/hdf_copy.3.gz
+man/man3/hdf_destroy.3.gz
+man/man3/hdf_dump.3.gz
+man/man3/hdf_dump_format.3.gz
+man/man3/hdf_dump_str.3.gz
+man/man3/hdf_get_attr.3.gz
+man/man3/hdf_get_child.3.gz
+man/man3/hdf_get_copy.3.gz
+man/man3/hdf_get_int_value.3.gz
+man/man3/hdf_get_node.3.gz
+man/man3/hdf_get_obj.3.gz
+man/man3/hdf_get_value.3.gz
+man/man3/hdf_get_valuef.3.gz
+man/man3/hdf_get_valuevf.3.gz
+man/man3/hdf_init.3.gz
+man/man3/hdf_obj_attr.3.gz
+man/man3/hdf_obj_child.3.gz
+man/man3/hdf_obj_name.3.gz
+man/man3/hdf_obj_next.3.gz
+man/man3/hdf_obj_top.3.gz
+man/man3/hdf_obj_value.3.gz
+man/man3/hdf_read_string.3.gz
+man/man3/hdf_read_string_ignore.3.gz
+man/man3/hdf_register_fileload.3.gz
+man/man3/hdf_remove_tree.3.gz
+man/man3/hdf_search_path.3.gz
+man/man3/hdf_set_attr.3.gz
+man/man3/hdf_set_buf.3.gz
+man/man3/hdf_set_copy.3.gz
+man/man3/hdf_set_int_value.3.gz
+man/man3/hdf_set_symlink.3.gz
+man/man3/hdf_set_value.3.gz
+man/man3/hdf_set_valuef.3.gz
+man/man3/hdf_sort_obj.3.gz
+man/man3/hdf_write_file.3.gz
+man/man3/hdf_write_file_atomic.3.gz
+man/man3/hdf_write_string.3.gz
+man/man3/mCreate.3.gz
+man/man3/mDestroy.3.gz
+man/man3/mLock.3.gz
+man/man3/mUnlock.3.gz
+man/man3/nerr_error_string.3.gz
+man/man3/nerr_error_traceback.3.gz
+man/man3/nerr_handle.3.gz
+man/man3/nerr_ignore.3.gz
+man/man3/nerr_init.3.gz
+man/man3/nerr_log_error.3.gz
+man/man3/nerr_match.3.gz
+man/man3/nerr_pass.3.gz
+man/man3/nerr_pass_ctx.3.gz
+man/man3/nerr_register.3.gz
+man/man3/skipDelete.3.gz
+man/man3/skipFreeList.3.gz
+man/man3/skipInsert.3.gz
+man/man3/skipNewList.3.gz
+man/man3/skipNext.3.gz
+man/man3/skipRelease.3.gz
+man/man3/skipSearch.3.gz
+man/man3/wdb_keys.3.gz
include/ClearSilver/ClearSilver.h
include/ClearSilver/cgi/cgi.h
include/ClearSilver/cgi/cgiwrap.h
diff --git a/www/http_get/Makefile b/www/http_get/Makefile
index 706d3c8cae3c..110b397422e0 100644
--- a/www/http_get/Makefile
+++ b/www/http_get/Makefile
@@ -13,13 +13,11 @@ COMMENT= Dump http-contents to stdout
WRKSRC= ${WRKDIR}/http_get
MAKEFILE= ${FILESDIR}/Makefile.bsd
-MAN1= http_get.1
-MANCOMPRESSED= yes
-PLIST_FILES= bin/http_get
+PLIST_FILES= bin/http_get \
+ man/man1/http_get.1.gz
.ifndef NO_OPENSSL
USE_OPENSSL= yes
.endif
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/http_load/Makefile b/www/http_load/Makefile
index 46f9a8d54f1e..1c040e5fc807 100644
--- a/www/http_load/Makefile
+++ b/www/http_load/Makefile
@@ -12,13 +12,11 @@ COMMENT= Multiprocessing http performance test client
MAKEFILE= ${FILESDIR}/Makefile.bsd
-MAN1= http_load.1
-MANCOMPRESSED= yes
-PLIST_FILES= bin/http_load
+PLIST_FILES= bin/http_load \
+ man/man1/http_load.1.gz
.ifndef NO_OPENSSL
USE_OPENSSL= yes
.endif
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/p5-HTTPD-Log-Filter/Makefile b/www/p5-HTTPD-Log-Filter/Makefile
index 654de7ab4cb7..91361a06c701 100644
--- a/www/p5-HTTPD-Log-Filter/Makefile
+++ b/www/p5-HTTPD-Log-Filter/Makefile
@@ -15,8 +15,5 @@ RUN_DEPENDS= p5-IO-Zlib>=0:${PORTSDIR}/archivers/p5-IO-Zlib
USES= perl5
USE_PERL5= configure
-MAN1= exclude_robots.1
-MAN3= HTTPD::Log::Filter.3
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/p5-HTTPD-Log-Filter/pkg-plist b/www/p5-HTTPD-Log-Filter/pkg-plist
index 5be0be562b11..0041c55f9fde 100644
--- a/www/p5-HTTPD-Log-Filter/pkg-plist
+++ b/www/p5-HTTPD-Log-Filter/pkg-plist
@@ -1,4 +1,6 @@
bin/exclude_robots
+%%PERL5_MAN3%%/HTTPD::Log::Filter.3.gz
+man/man1/exclude_robots.1.gz
%%SITE_PERL%%/HTTPD/Log/Filter.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTPD/Log/Filter/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTPD/Log/Filter
diff --git a/www/p5-WWW-iTunesConnect/Makefile b/www/p5-WWW-iTunesConnect/Makefile
index 375a4dcb085f..c0c48cf857b2 100644
--- a/www/p5-WWW-iTunesConnect/Makefile
+++ b/www/p5-WWW-iTunesConnect/Makefile
@@ -21,13 +21,11 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= WWW::iTunesConnect.3
-
PLIST_FILES= %%SITE_PERL%%/WWW/iTunesConnect.pm \
- %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/iTunesConnect/.packlist
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/iTunesConnect/.packlist \
+ %%PERL5_MAN3%%/WWW::iTunesConnect.3.gz
PLIST_DIRS= %%SITE_PERL%%/WWW \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/iTunesConnect \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
index 8ede4fa9521b..21bfbc930ab8 100644
--- a/www/sitecopy/Makefile
+++ b/www/sitecopy/Makefile
@@ -22,7 +22,6 @@ CONFIGURE_ARGS= --with-neon --with-libxml2
USE_GNOME= libxml2
USE_GMAKE= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -39,7 +38,6 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl
.endif
-MAN1= sitecopy.1
post-patch:
@${REINPLACE_CMD} -e 's|;;|;|g' \
diff --git a/www/sitecopy/pkg-plist b/www/sitecopy/pkg-plist
index e8810cac29a6..5fff9d116975 100644
--- a/www/sitecopy/pkg-plist
+++ b/www/sitecopy/pkg-plist
@@ -1,4 +1,5 @@
bin/sitecopy
+man/man1/sitecopy.1.gz
%%DOCSDIR%%/NEWS
%%DOCSDIR%%/README
%%DOCSDIR%%/THANKS