aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/bogofilter-tc/Makefile26
2 files changed, 27 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index c219ef3b5c17..aeeea42078e8 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -34,6 +34,7 @@
SUBDIR += bogofilter
SUBDIR += bogofilter-qdbm
SUBDIR += bogofilter-sqlite
+ SUBDIR += bogofilter-tc
SUBDIR += bsfilter
SUBDIR += bsmtp
SUBDIR += bulk_mailer
diff --git a/mail/bogofilter-tc/Makefile b/mail/bogofilter-tc/Makefile
new file mode 100644
index 000000000000..c312ef0fcbcf
--- /dev/null
+++ b/mail/bogofilter-tc/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: bogofilter-tc
+# Date created: 2008-08-29
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bogofilter
+CATEGORIES= mail
+PKGNAMESUFFIX= -tc
+
+MAINTAINER= matthias.andree@gmx.de
+# Blanket approval for changes by Zach Thompson (address above)
+
+LIB_DEPENDS= tokyocabinet.7:${PORTSDIR}/databases/tokyocabinet
+
+CONFLICTS= bogofilter-[0-9]* [a-z][a-z]-bogofilter-[1-9]* bogofilter-sqlite-[0-9]* bogofilter-qdbm-[0-9]*
+
+CONFIGURE_ARGS= --with-database=tokyocabinet
+BF_CPPFLAGS= -I${LOCALBASE}/include
+BF_LIBS=
+DESCR= ${PKGDIR}/pkg-descr
+
+MASTERDIR= ${.CURDIR}/../bogofilter
+
+.include "${MASTERDIR}/Makefile"