aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/ocaml-event/Makefile9
-rw-r--r--devel/p5-Event-Lib/Makefile4
-rw-r--r--ftp/pftpx/Makefile4
-rw-r--r--lang/io/Makefile3
-rw-r--r--net/arpd/Makefile8
-rw-r--r--net/honeyd/Makefile9
-rw-r--r--net/nylon/Makefile7
-rw-r--r--net/openospfd-devel/Makefile3
-rw-r--r--net/openospfd/Makefile3
-rw-r--r--net/plb/Makefile4
-rw-r--r--net/trickle/Makefile6
-rw-r--r--net/vomit/Makefile6
-rw-r--r--security/fragroute/Makefile4
-rw-r--r--security/scanssh/Makefile4
-rw-r--r--security/stegdetect/Makefile3
-rw-r--r--security/tor-devel/Makefile3
-rw-r--r--security/tor/Makefile3
-rw-r--r--www/crawl/Makefile8
18 files changed, 45 insertions, 46 deletions
diff --git a/devel/ocaml-event/Makefile b/devel/ocaml-event/Makefile
index 401908d8da55..bcf205297602 100644
--- a/devel/ocaml-event/Makefile
+++ b/devel/ocaml-event/Makefile
@@ -7,7 +7,7 @@
PORTNAME= event
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.xs4all.nl/~mmzeeman/ocaml/
PKGNAMEPREFIX= ocaml-
@@ -17,7 +17,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= An ocaml wrapper for the libevent API
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= ${LIB_EVENT}:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
ALL_TARGET= all allopt
USE_GMAKE= yes
@@ -28,9 +28,6 @@ ALL_TARGET+= doc
PORTDOCS= *
.endif
-# libevent library
-LIB_EVENT= event-1.2.1
-
EXAMPLE_FILES= \
Makefile \
fifo_example.ml \
@@ -61,7 +58,7 @@ PLIST_FILES+= lib/ocaml/stublibs/${file}
post-configure:
# CFLAGS,PREFIX safeness
@${REINPLACE_CMD} -E -e \
- 's|^(EVENT_LIB=).*$$|\1-l${LIB_EVENT:R}|; \
+ 's|^(EVENT_LIB=).*$$|\1-levent|; \
s|^(EVENT_LIBDIR=).$$|\1${LOCALBASE}/lib|; \
s|^(EVENT_INCDIR=).$$|\1${LOCALBASE}/include|; \
s|^(CFLAGS).*$$|\1=${CFLAGS} -I\$$(EVENT_INCDIR)|' \
diff --git a/devel/p5-Event-Lib/Makefile b/devel/p5-Event-Lib/Makefile
index 3c7691c20289..fc7d8a49b396 100644
--- a/devel/p5-Event-Lib/Makefile
+++ b/devel/p5-Event-Lib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Event-Lib
PORTVERSION= 1.00
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Event
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fk@fabiankeil.de
COMMENT= Makes libevent(3) accessible with Perl
-LIB_DEPENDS= event-1.2:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
PERL_CONFIGURE= yes
diff --git a/ftp/pftpx/Makefile b/ftp/pftpx/Makefile
index 4b8b5dd3b1bb..dfb85d27b6e3 100644
--- a/ftp/pftpx/Makefile
+++ b/ftp/pftpx/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pftpx
PORTVERSION= 0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= http://www.sentia.org/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -14,7 +14,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= sullrich@gmail.com
COMMENT= Much enhanced ftp proxy for pf that supports most ftp protocols
-LIB_DEPENDS= event-1.2:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
MAN8= pftpx.8
diff --git a/lang/io/Makefile b/lang/io/Makefile
index 588e5f496bf6..15806c4d3e65 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -7,6 +7,7 @@
PORTNAME= io
PORTVERSION= 0.0.2006.05.02
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://io.urbanape.com/release/ \
http://www.sigusr1.org/~steve/
@@ -16,7 +17,7 @@ MAINTAINER= perky@FreeBSD.org
COMMENT= Small prototype-based programming language
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
- event-1.2.1:${PORTSDIR}/devel/libevent
+ event-1.2a:${PORTSDIR}/devel/libevent
USE_GMAKE= yes
diff --git a/net/arpd/Makefile b/net/arpd/Makefile
index dfbbbdf2b4e9..d41082cd4d2b 100644
--- a/net/arpd/Makefile
+++ b/net/arpd/Makefile
@@ -7,17 +7,15 @@
PORTNAME= arpd
PORTVERSION= 0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://niels.xtdnet.nl/honeyd/
MAINTAINER= yb@bashibuzuk.net
COMMENT= A daemon to service arp replies
-BUILD_DEPENDS= ${LOCALBASE}/include/dnet.h:${PORTSDIR}/net/libdnet \
- ${LOCALBASE}/include/event.h:${PORTSDIR}/devel/libevent
-RUN_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
- ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent \
+ dnet.1:${PORTSDIR}/net/libdnet
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index 0747609dda86..aaa1868aa639 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= honeyd
PORTVERSION= 1.5b
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.citi.umich.edu/u/provos/honeyd/ \
http://niels.xtdnet.nl/honeyd/
@@ -14,10 +15,10 @@ MASTER_SITES= http://www.citi.umich.edu/u/provos/honeyd/ \
MAINTAINER= wxs@atarininja.org
COMMENT= Simulate virtual network hosts (honeypots)
-BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
- ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent \
- ${LOCALBASE}/lib/libdnsres.a:${PORTSDIR}/devel/libdnsres \
- ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent \
+ dnet.1:${PORTSDIR}/net/libdnet \
+ dnsres.0:${PORTSDIR}/devel/libdnsres
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/nylon/Makefile b/net/nylon/Makefile
index b745a08f25ad..45e80798c54d 100644
--- a/net/nylon/Makefile
+++ b/net/nylon/Makefile
@@ -8,14 +8,14 @@
PORTNAME= nylon
PORTVERSION= 1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://monkey.org/~marius/nylon/
MAINTAINER= ports@FreeBSD.org
COMMENT= A Unix SOCKS 4 and 5 proxy server
-LIB_DEPENDS= event-1.2.1:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
USE_RC_SUBR= nylon.sh
@@ -28,9 +28,6 @@ MAN1= nylon.1
PLIST_FILES= bin/nylon etc/nylon.conf.sample
-post-patch:
- ${REINPLACE_CMD} -e 's/-levent/-levent-1.2/' ${WRKSRC}/configure
-
post-install:
${INSTALL_DATA} ${FILESDIR}/nylon.conf ${PREFIX}/etc/nylon.conf.sample
diff --git a/net/openospfd-devel/Makefile b/net/openospfd-devel/Makefile
index a2cfef3b83c6..0f2910b65cd6 100644
--- a/net/openospfd-devel/Makefile
+++ b/net/openospfd-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openospfd-devel
PORTVERSION= ${SNAPSHOT}
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenOSPFD/:openbsd \
${MASTER_SITE_LOCAL:S/$/:freebsd/g}
@@ -19,7 +20,7 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tgz
MAINTAINER= flz@FreeBSD.org
COMMENT= Free implementation of the Open Shortest Path First Protocol
-LIB_DEPENDS= event-1.2.1:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
CONFLICTS= zebra-0* quagga-0*
diff --git a/net/openospfd/Makefile b/net/openospfd/Makefile
index a2cfef3b83c6..0f2910b65cd6 100644
--- a/net/openospfd/Makefile
+++ b/net/openospfd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openospfd-devel
PORTVERSION= ${SNAPSHOT}
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenOSPFD/:openbsd \
${MASTER_SITE_LOCAL:S/$/:freebsd/g}
@@ -19,7 +20,7 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tgz
MAINTAINER= flz@FreeBSD.org
COMMENT= Free implementation of the Open Shortest Path First Protocol
-LIB_DEPENDS= event-1.2.1:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
CONFLICTS= zebra-0* quagga-0*
diff --git a/net/plb/Makefile b/net/plb/Makefile
index 679c6ac9cd41..884bef1a0920 100644
--- a/net/plb/Makefile
+++ b/net/plb/Makefile
@@ -7,14 +7,14 @@
PORTNAME= plb
PORTVERSION= 0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://plb.sunsite.dk/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= A high-performance HTTP load balancer
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
diff --git a/net/trickle/Makefile b/net/trickle/Makefile
index e7ba3b3d70c2..ff561f2f8484 100644
--- a/net/trickle/Makefile
+++ b/net/trickle/Makefile
@@ -7,17 +7,17 @@
PORTNAME= trickle
PORTVERSION= 1.06
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
MASTER_SITES= http://monkey.org/~marius/trickle/
MAINTAINER= mezz@FreeBSD.org
COMMENT= Lightweight, portable bandwidth shaper
-LIB_DEPENDS= event-1.2.1:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS+=--with-libevent=${LOCALBASE} \
--sysconfdir=${PREFIX}/etc
diff --git a/net/vomit/Makefile b/net/vomit/Makefile
index 75d5a4b1d730..eabfd629b8e1 100644
--- a/net/vomit/Makefile
+++ b/net/vomit/Makefile
@@ -7,15 +7,15 @@
PORTNAME= vomit
PORTVERSION= 0.2c
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net security
MASTER_SITES= http://vomit.xtdnet.nl/
MAINTAINER= ports@FreeBSD.org
COMMENT= Voice over misconfigured internet telephones
-BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent \
- ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent \
+ dnet.1:${PORTSDIR}/net/libdnet
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/security/fragroute/Makefile b/security/fragroute/Makefile
index ce110eb1b3bb..c39da8addec7 100644
--- a/security/fragroute/Makefile
+++ b/security/fragroute/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fragroute
PORTVERSION= 1.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security net
MASTER_SITES= http://monkey.org/~dugsong/fragroute/ \
${MASTER_SITE_PACKETSTORM}
@@ -17,7 +17,7 @@ MAINTAINER= onatan@gmail.com
COMMENT= A tool for intercepting, modifying and rewriting egress traffic
LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet \
- event-1:${PORTSDIR}/devel/libevent
+ event-1.2a:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-libdnet=${LOCALBASE} \
diff --git a/security/scanssh/Makefile b/security/scanssh/Makefile
index 24c6b085bba1..fd5533f44dd5 100644
--- a/security/scanssh/Makefile
+++ b/security/scanssh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scanssh
PORTVERSION= 2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net
MASTER_SITES= http://www.monkey.org/~provos/
@@ -15,7 +15,7 @@ MAINTAINER= kris@FreeBSD.org
COMMENT= Scans networks for open proxies, SSH, Web and SMTP servers
LIB_DEPENDS= dnet:${PORTSDIR}/net/libdnet \
- event:${PORTSDIR}/devel/libevent
+ event-1.2a:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= YES
PLIST_FILES= bin/scanssh
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index d961d34971f5..f1b08e8c747b 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -7,6 +7,7 @@
PORTNAME= stegdetect
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.outguess.org/ \
http://distfiles.master.finkmirrors.net/
@@ -15,7 +16,7 @@ MAINTAINER= rainer.alves@gmail.com
COMMENT= Automated tool for detecting steganographic content in JPEGs
.if !defined(WITHOUT_X11)
-BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
.endif
# Note: stegdetect includes a modified version of jpeg-6b linked statically
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index fbe2cd8a10d3..c530f6d6d33f 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tor
PORTVERSION= 0.1.2.3
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= http://tor.eff.org/dist/ \
http://mirror.onionland.org/dist/
@@ -17,7 +18,7 @@ MAINTAINER= peter.thoenen@yahoo.com
COMMENT= An anonymizing overlay network for TCP
RUN_DEPENDS= tsocks:${PORTSDIR}/net/tsocks
-LIB_DEPENDS= event-1.2:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
USE_OPENSSL= yes
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 642a2fd7291a..a09b1e8166f9 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tor
PORTVERSION= 0.1.1.25
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= http://tor.eff.org/dist/ \
http://mirror.onionland.org/dist/
@@ -15,7 +16,7 @@ MAINTAINER= peter.thoenen@yahoo.com
COMMENT= An anonymizing overlay network for TCP
RUN_DEPENDS= tsocks:${PORTSDIR}/net/tsocks
-LIB_DEPENDS= event-1.2:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.2a:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
USE_OPENSSL= yes
diff --git a/www/crawl/Makefile b/www/crawl/Makefile
index d77d83d9aea4..3bd125a1e465 100644
--- a/www/crawl/Makefile
+++ b/www/crawl/Makefile
@@ -7,18 +7,18 @@
PORTNAME= crawl
PORTVERSION= 0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://www.monkey.org/~provos/
MAINTAINER= ports@FreeBSD.org
COMMENT= A small, efficient web crawler with advanced features
-BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
-LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
+LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3 \
+ event-1.2a:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-libevent=${LOCALBASE} --program-transform-name=''
+CONFIGURE_ARGS= --with-libevent=${LOCALBASE} --program-transform-name=''
MAN1= crawl.1