aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING10
-rw-r--r--devel/ruby-gnustep/Makefile4
-rw-r--r--devel/ruby-pcsc-lite/Makefile7
-rw-r--r--devel/ruby-sdl/Makefile3
-rw-r--r--graphics/ruby-opengl/Makefile7
-rw-r--r--lang/ruby18/Makefile22
-rw-r--r--lang/ruby18/files/extrapatch-eval.c13
-rw-r--r--print/ruby-panda/Makefile7
-rw-r--r--textproc/ruby-sary/Makefile7
9 files changed, 38 insertions, 42 deletions
diff --git a/UPDATING b/UPDATING
index b6dd8428203c..c32d393e2aa2 100644
--- a/UPDATING
+++ b/UPDATING
@@ -7,6 +7,16 @@ time you update your ports collection, before attempting any port
upgrades.
20050224:
+ AFFECTS: users of lang/ruby18 and any apps that depend on ruby18
+ AUTHOR: mezz@FreeBSD.org
+
+ The theads support has been disabled again. It causes the more trouble, so
+ it now builds with ${PTHREAD_CFLAGS} and ${PTHREAD_LIBS}. It is recommend
+ you to rebuild any apps that depend on lang/ruby18. Do something like this:
+
+ portupgrade -rf ruby-1.8.2\*
+
+20050224:
AFFECTS: users of www/apache21
AUTHOR: clement@FreeBSD.org
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index 34f9d317a74c..3afb73221e24 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -59,10 +59,6 @@ COMBOLIBDIR= ${SYSLIBDIR}
MAKE_ENV+= GNUSTEP_FLATTENED=yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-BROKEN= "Systems prior to FreeBSD 502102 are out of support"
-.endif
-
.if ${MACHINE_ARCH} == "i386"
GNU_ARCH= ix86
.else
diff --git a/devel/ruby-pcsc-lite/Makefile b/devel/ruby-pcsc-lite/Makefile
index 2a2d33a5939a..e5705fb41f9b 100644
--- a/devel/ruby-pcsc-lite/Makefile
+++ b/devel/ruby-pcsc-lite/Makefile
@@ -30,11 +30,6 @@ WRKSRC= ${WRKDIR}/PCSC-ruby
DOCS= README.txt
EXAMPLES= examples/test.rb examples/pcsclient.rb
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-BROKEN= "Systems prior to FreeBSD 502102 are out of support"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}/
@@ -47,4 +42,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index 8f8addfb9f1d..be3ce572a1e8 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -42,9 +42,6 @@ DOCS_JA= NEWS.ja README.ja \
${RUBY_RD_HTML_FILES:N*.en.html}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-BROKEN= "Systems prior to FreeBSD 502102 are out of support"
-.endif
post-extract:
dir=`${RUBY_OPENGL_WRKSRC_CMD}`; \
diff --git a/graphics/ruby-opengl/Makefile b/graphics/ruby-opengl/Makefile
index 9cdac7bdae85..e5aa507add81 100644
--- a/graphics/ruby-opengl/Makefile
+++ b/graphics/ruby-opengl/Makefile
@@ -27,11 +27,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-ruby-dir="${LOCALBASE}" --with-x11-dir="${X11BASE}"
INSTALL_TARGET= site-install
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-BROKEN= "Systems prior to FreeBSD 502102 are out of support"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -41,4 +36,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index bf8e79600436..e50c2d715ab7 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR_RUBY}
@@ -42,10 +42,13 @@ RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
#USE_AUTOCONF= yes # does not work with 2.13; requires 2.53 or later
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--enable-shared
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="${PTHREAD_LIBS}"
.if defined(DEBUG)
CFLAGS+= -g
@@ -58,16 +61,8 @@ MAN1= ${RUBY_NAME}.1
LATEST_LINK= ruby-devel
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502102 && ${ARCH} != "sparc64"
-RUBY_ENABLE_PTHREAD?= public demand
-.endif
-
-.if defined(RUBY_ENABLE_PTHREAD) && ${RUBY_ENABLE_PTHREAD} != "no"
-CONFIGURE_ARGS+= --enable-pthread
-
-# There seems to be a bug in either gcc or libpthread that gets
-# (mini)ruby to malfunction..
-CFLAGS:= ${CFLAGS:N-march=*}
+.if ${OSVERSION} < 502102
+EXTRA_PATCHES= ${PATCHDIR}/extrapatch-eval.c
.endif
.if ${ARCH} == "ia64"
@@ -134,6 +129,11 @@ post-extract:
${MV} ${WRKSRC}/ext/dl/h2rb ${WRKSRC}/bin/
post-patch:
+.if ${OSVERSION} < 502102 || ${ARCH} == "sparc64" || ${ARCH} == "alpha"
+ ${REINPLACE_CMD} -e 's|-lc"|"|g' ${WRKSRC}/configure
+.endif
+ ${REINPLACE_CMD} -e 's|-l$$pthread_lib|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
${RM} -rf ${BUILD_WRKSRC}/ext/${d}
diff --git a/lang/ruby18/files/extrapatch-eval.c b/lang/ruby18/files/extrapatch-eval.c
new file mode 100644
index 000000000000..4d9785c75d7f
--- /dev/null
+++ b/lang/ruby18/files/extrapatch-eval.c
@@ -0,0 +1,13 @@
+--- eval.c.orig Wed Feb 23 15:54:03 2005
++++ eval.c Wed Feb 23 15:54:18 2005
+@@ -12,6 +12,10 @@
+
+ **********************************************************************/
+
++#ifdef _THREAD_SAFE
++#undef _THREAD_SAFE
++#endif
++
+ #include "ruby.h"
+ #include "node.h"
+ #include "env.h"
diff --git a/print/ruby-panda/Makefile b/print/ruby-panda/Makefile
index c223acb1c88e..d616790912ee 100644
--- a/print/ruby-panda/Makefile
+++ b/print/ruby-panda/Makefile
@@ -34,11 +34,6 @@ DOCS_JA= ChangeLog.ja README.ja TODO.ja \
doc/ref_ja.html doc/ref_ja.rd
EXAMPLES_EN= circles.rb main.rb morecircles.rb template.rb
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-BROKEN= "Systems prior to FreeBSD 502102 are out of support"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -55,4 +50,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/ruby-sary/Makefile b/textproc/ruby-sary/Makefile
index 863e8d3f08fe..544b32838f13 100644
--- a/textproc/ruby-sary/Makefile
+++ b/textproc/ruby-sary/Makefile
@@ -32,15 +32,10 @@ DOCS_EN= ChangeLog \
DOCS_JA= ${RUBY_RD_FILES:M*.ja.rd} \
${RUBY_RD_HTML_FILES:M*.ja.html}
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-BROKEN= "Systems prior to FreeBSD 502102 are out of support"
-.endif
-
post-install: doc-install
${INSTALL_SCRIPT} ${WRKSRC}/rsary.rb ${PREFIX}/bin/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
doc-install:
.if !defined(NOPORTDOCS)