aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/abook/Makefile2
-rw-r--r--mail/annoyance-filter/Makefile10
-rw-r--r--mail/courier-imap/Makefile7
-rw-r--r--mail/cyrus2courier/Makefile9
-rw-r--r--mail/evolution-exchange/Makefile2
-rw-r--r--mail/evolution/Makefile2
-rw-r--r--mail/fetchmail/Makefile14
-rw-r--r--mail/meta1/Makefile8
-rw-r--r--mail/pecl-esmtp/Makefile4
-rw-r--r--mail/spamilter/Makefile2
-rw-r--r--math/R/Makefile5
-rw-r--r--math/cgal/Makefile8
-rw-r--r--math/fftw3/Makefile6
-rw-r--r--math/jags/Makefile8
-rw-r--r--math/labplot/Makefile8
-rw-r--r--math/matrices/Makefile8
-rw-r--r--math/octave/Makefile4
-rw-r--r--math/scilab/Makefile2
-rw-r--r--misc/compat4x/Makefile28
-rw-r--r--misc/gnu-watch/Makefile8
-rw-r--r--misc/heyu2/Makefile11
-rw-r--r--misc/libhome/Makefile6
-rw-r--r--misc/libhome/pkg-plist8
-rw-r--r--misc/mbuffer/Makefile4
24 files changed, 20 insertions, 154 deletions
diff --git a/mail/abook/Makefile b/mail/abook/Makefile
index 3587b399eb71..aacf3d991354 100644
--- a/mail/abook/Makefile
+++ b/mail/abook/Makefile
@@ -35,7 +35,7 @@ PORTDOCS= ANNOUNCE AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
+.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
diff --git a/mail/annoyance-filter/Makefile b/mail/annoyance-filter/Makefile
index 7dcd2f63c7ef..a5d925ee82fe 100644
--- a/mail/annoyance-filter/Makefile
+++ b/mail/annoyance-filter/Makefile
@@ -21,13 +21,7 @@ GNU_CONFIGURE= yes
MAN1= annoyance-filter.1
DOCS= COPYING INSTALL README *.pdf
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-CFLAGS+= -I. ${CPPFLAGS}
-.else
-CFLAGS+= ${CPPFLAGS}
-.endif
+CFLAGS= ${CPPFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
@@ -38,4 +32,4 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index a597357b3801..c4a983116ade 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -163,17 +163,10 @@ post-install:
cd ${WRKSRC} && ( ${GMAKE} install-configure ; cd - )
@${ECHO_MSG} "In case you use authpam, you should put the following lines"
-.if ${OSVERSION} >= 500000
@${ECHO_MSG} "in your /etc/pam.d/imap"
@${ECHO_MSG} "auth required pam_unix.so try_first_pass"
@${ECHO_MSG} "account required pam_unix.so try_first_pass"
@${ECHO_MSG} "session required pam_permit.so"
-.else
- @${ECHO_MSG} "in your /etc/pam.conf"
- @${ECHO_MSG} "imap auth required pam_unix.so try_first_pass"
- @${ECHO_MSG} "imap account required pam_unix.so try_first_pass"
- @${ECHO_MSG} "imap session required pam_permit.so"
-.endif
@${ECHO_MSG} ""
@${ECHO_MSG} "You will have to run ${DATADIR}/mkimapdcert to create"
diff --git a/mail/cyrus2courier/Makefile b/mail/cyrus2courier/Makefile
index 5d5b74d1dad8..a887f07a57b9 100644
--- a/mail/cyrus2courier/Makefile
+++ b/mail/cyrus2courier/Makefile
@@ -22,13 +22,6 @@ ALL_TARGET= build
PLIST_FILES= bin/cyrus2courier
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-CFLAGS+= -I${LOCALBASE}/include
-MAKE_ARGS= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-.endif
-
post-patch:
@${REINPLACE_CMD} '/^CFLAGS*/d; /^LDFLAGS*/d; /^CC*/d' \
${WRKSRC}/src/Makefile.FreeBSD
@@ -36,4 +29,4 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/evolution-exchange/Makefile b/mail/evolution-exchange/Makefile
index cd31a1680fac..cf08e7a82a07 100644
--- a/mail/evolution-exchange/Makefile
+++ b/mail/evolution-exchange/Makefile
@@ -43,7 +43,7 @@ GCONF_SCHEMAS= apps_exchange_addressbook-${VERSION}.schemas
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000 && !defined(NO_KERBEROS) && \
+.if !defined(NO_KERBEROS) && \
exists(/usr/lib/libkrb5.so)
CONFIGURE_ARGS+= --with-krb5=/usr
.else
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 197352bad809..e973873501eb 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -91,7 +91,7 @@ PLIST_SUB+= DBUS=""
PLIST_SUB+= DBUS="@comment "
.endif
-.if ${OSVERSION} >= 500000 && !defined(NO_KERBEROS) && \
+.if !defined(NO_KERBEROS) && \
exists(/usr/lib/libkrb5.so)
CONFIGURE_ARGS+= --with-krb5=/usr
.else
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 2dc072cf3894..963fe6362454 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -114,26 +114,12 @@ pre-configure:
@${ECHO_CMD} ""
-.if ${OSVERSION} >= 500000
.if defined(KRB5_HOME)
@${ECHO_CMD} "Using Kerberos V support in ${KRB5_HOME}."
.else
@${ECHO_CMD} "Use KRB5_HOME=<directory> to enable Kerberos V support in <directory> (usually /usr)."
.endif
-.else
-# FreeBSD 4
-.if defined(MAKE_KERBEROS4)
-.if exists(/usr/lib/libkrb.a)
- @${ECHO_CMD} "Enabling Kerberos IV support in /usr."
-.else
- @${ECHO_CMD} "Kerberos IV is not installed on your system."
-.endif
-.else
- @${ECHO_CMD} "Use -DMAKE_KERBEROS4 to enable Kerberos IV support."
-.endif
-.endif
-
.if defined(WITH_GSSAPI)
.if defined(KRB5_HOME)
@${ECHO_CMD} "Enabling GSSAPI support in ${KRB5_HOME}."
diff --git a/mail/meta1/Makefile b/mail/meta1/Makefile
index 9d2b2dfc47f2..db7e5c9515c7 100644
--- a/mail/meta1/Makefile
+++ b/mail/meta1/Makefile
@@ -44,6 +44,8 @@ PLIST_SUB+= NOLOGIN=${NOLOGIN_CMD}
EXTRA_SBIN= libcheck/noroot libconf/tree libmta/statit \
libmta/t-hostname checks/t-getgroup
+NOLOGIN_CMD?= /usr/sbin/nologin
+
# Options to define Features:
# META1_WITHOUT_TLS=yes
# META1_WITHOUT_SASL=yes
@@ -181,10 +183,4 @@ UID!= ${ID} -u
post-build: test
.endif
-.if ${OSVERSION} < 500000
-NOLOGIN_CMD?= /sbin/nologin
-.else
-NOLOGIN_CMD?= /usr/sbin/nologin
-.endif
-
.include <bsd.port.post.mk>
diff --git a/mail/pecl-esmtp/Makefile b/mail/pecl-esmtp/Makefile
index c4b6dc49f8a0..45765205637a 100644
--- a/mail/pecl-esmtp/Makefile
+++ b/mail/pecl-esmtp/Makefile
@@ -25,10 +25,6 @@ OPTIONS= RE2C "Enable re2c to regenerate PHP parsers" on
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not build on FreeBSD 4.x
-.endif
-
.if defined(WITH_RE2C)
BUILD_DEPENDS+= re2c:${PORTSDIR}/devel/re2c
.endif
diff --git a/mail/spamilter/Makefile b/mail/spamilter/Makefile
index 6e7c96531b4d..015cb01e5ae9 100644
--- a/mail/spamilter/Makefile
+++ b/mail/spamilter/Makefile
@@ -64,11 +64,9 @@ pre-configure:
${WRKSRC}/docs/docs.html ${WRKSRC}/docs/docs.txt
xpost-configure:
-.if ${OSVERSION} > 500000
${REINPLACE_CMD} \
-e "s| install-ipfwmtad | |" \
${WRKSRC}/Makefile
-.endif
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/spamilter.sh \
diff --git a/math/R/Makefile b/math/R/Makefile
index e81bac2c6434..0685876349c1 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -154,11 +154,6 @@ INFO= R-FAQ R-admin R-data R-exts R-intro R-lang
CONFIGURE_ENV+= R_PAPERSIZE=letter
.endif
-.if ${OSVERSION} < 500000
-CONFIGURE_ARGS+= --disable-mbcs
-BROKEN= does not compile
-.endif
-
.if ${OSVERSION} < 600000
CONFIGURE_ENV+= MAKEINFO=${LOCALBASE}/bin/makeinfo
BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index c0ee29532747..510847e45abb 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -32,12 +32,6 @@ PORTDOCS= *
INVOKE= cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not build on FreeBSD 4.x
-.endif
-
post-patch:
@for d in ${WRKSRC}/include/CGAL ${WRKSRC}/examples ${WRKDIR}/doc_html/cgal_manual; do \
${FIND} $$d -name '*.orig' -delete; \
@@ -76,4 +70,4 @@ cgal-install:
${FIND} * -type d -exec ${MKDIR} "${DST}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DST}/{}" \;
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index cbd4ab3caaad..a74071d83a30 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -47,15 +47,9 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS:N-O:N-O*} -O2 -ffast-math -fomit-frame-pointer"
.if ${FFTW3_FLAVOR}=="default" && ${MACHINE_CPU:Msse}
# !!Detect SSE and not SSE2!!
CONFIGURE_ARGS+=--enable-sse2
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
.else
.if ${FFTW3_FLAVOR}=="float" && ${MACHINE_CPU:Msse}
CONFIGURE_ARGS+=--enable-sse
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
.endif
.endif
.if ${MACHINE_CPU:M3dnow}
diff --git a/math/jags/Makefile b/math/jags/Makefile
index 7b4c17b2eb67..1b6ac5b1c122 100644
--- a/math/jags/Makefile
+++ b/math/jags/Makefile
@@ -37,12 +37,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib F77="${F77}"
USE_FORTRAN= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on 4.x"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -53,4 +47,4 @@ post-install:
-s ':^bugs-examples/*::' )
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index ac97fce54d53..6c776c7fdc83 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -44,12 +44,6 @@ CONFIGURE_ARGS+=--program-prefix='' --disable-cdf \
MAN1= LabPlot.1 labplot.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on 4.x
-.endif
-
#This needs some more work before enabling this feature
#.if defined(WITH_VTK)
#LIB_DEPENDS+= vtkRendering.1:${PORTSDIR}/math/vtk
@@ -64,4 +58,4 @@ IGNORE= does not compile on 4.x
#CONFIGURE_ARGS+= --enable-vtk
#.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/matrices/Makefile b/math/matrices/Makefile
index 35baf9b222b8..d6bd98cfd857 100644
--- a/math/matrices/Makefile
+++ b/math/matrices/Makefile
@@ -20,10 +20,4 @@ PLIST_FILES= bin/${PORTNAME}
MAN1= ${PORTNAME}.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 195478d88ba7..c47bd21371d5 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -48,10 +48,6 @@ SUB_LIST= OCTAVE_VERSION="${OCTAVE_VERSION}"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on FreeBSD 4.x
-.endif
-
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 5c503b4b19a6..9f6b1523236c 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -59,7 +59,7 @@ CONFIGURE_ARGS+= --without-pvm
USE_GNOME= pkgconfig gtk20 libgtkhtml vte
CONFIGURE_ARGS+= --with-gtk2
PLIST_SUB+= GTK2="" NOGTK2="@comment "
-.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
+.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
.else
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index 3bfcf57a41db..752ba4554ac2 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -36,7 +36,6 @@ COMPAT4X_ARCH= ${ARCH}
RUN_DEPENDS+= ${LOCALBASE}/share/compat/locale/UTF-8/LC_CTYPE:${PORTSDIR}/misc/localedata
.endif
-.if ${OSVERSION} >= 500000
COMPAT4X_OSVERSION= 5.3
PLIST= ${.CURDIR}/pkg-plist.freebsd5
.if ${ARCH} == i386
@@ -56,23 +55,6 @@ COMPAT4X_DISTFILES= ${PORTNAME}.aa \
.else
IGNORE= in unsupported (FreeBSD 4.x did not run on this architecture)
.endif
-.else
-COMPAT4X_OSVERSION= 4.10
-PLIST= ${.CURDIR}/pkg-plist.freebsd4
-.if ${ARCH} == i386
-COMPAT4X_DISTFILES= ${PORTNAME}.aa \
- ${PORTNAME}.ab \
- ${PORTNAME}.ac \
- ${PORTNAME}.ad
-.elif ${ARCH} == alpha
-COMPAT4X_DISTFILES= ${PORTNAME}.aa \
- ${PORTNAME}.ab \
- ${PORTNAME}.ac \
- ${PORTNAME}.ad
-.else
-IGNORE= unsupported architecture
-.endif
-.endif
.if ${COMPAT4X_ARCH} == i386
PLIST_SUB+= I386_ONLY=""
@@ -105,24 +87,18 @@ FREEBSD4_LIBS= libc_r.so.4 libperl.so.3
COMPAT4X_PORTVERSION= ${COMPAT4X_OSVERSION}.${COMPAT4X_OSRELDATE}
COMPAT4X_MASTER_SITES= ftp://current.FreeBSD.org/pub/FreeBSD/%SUBDIR%/
COMPAT4X_MASTER_SITE_SUBDIR= snapshots/${COMPAT4X_ARCH}/${COMPAT4X_OSVERSION}-${COMPAT4X_OSBRANCH}-${COMPAT4X_OSRELDATE}-JPSNAP/${PORTNAME}
-.elif ${COMPAT4X_OSVERSION} == "5.3"
+.else ${COMPAT4X_OSVERSION} == "5.3"
COMPAT4X_PORTVERSION= ${COMPAT4X_OSVERSION}
COMPAT4X_MASTER_SITES= ${MASTER_SITE_LOCAL}
COMPAT4X_MASTER_SITE_SUBDIR= kris/${COMPAT4X_ARCH}
-.else
-COMPAT4X_PORTVERSION= ${COMPAT4X_OSVERSION}
-COMPAT4X_MASTER_SITES= ${MASTER_SITE_FREEBSD_ORG}
-COMPAT4X_MASTER_SITE_SUBDIR= releases/${COMPAT4X_ARCH}/${COMPAT4X_OSVERSION}-RELEASE/${PORTNAME}
.endif
do-extract:
@${MKDIR} ${WRKDIR}
@(cd ${DISTDIR}/${DIST_SUBDIR} && ${CAT} ${DISTFILES} | ${TAR} -xzf - -C ${WRKDIR} )
-.if ${OSVERSION} >= 500000
.for lib in ${FREEBSD4_LIBS}
@${MV} ${WRKSRC}/${lib} ${WRKSRC}/${lib}.compat4x
.endfor
-.endif
.if !defined(FORCE_VULNERABLE_OPENSSL)
.for lib in ${OPENSSL_LIBS}
@${RM} -f ${WRKSRC}/${lib}
@@ -132,11 +108,9 @@ do-extract:
do-install:
@${MKDIR} ${TARGET_DIR}
${INSTALL_DATA} ${WRKSRC}/* ${TARGET_DIR}/
-.if ${OSVERSION} >= 500000
.for lib in ${FREEBSD4_LIBS}
${LN} -sf ${lib}.compat4x ${TARGET_DIR}/${lib}
.endfor
-.endif
# Include to automatic install file in libdata/ldconfig{,32}
.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
diff --git a/misc/gnu-watch/Makefile b/misc/gnu-watch/Makefile
index ef45ccc5b100..35f95f226d3f 100644
--- a/misc/gnu-watch/Makefile
+++ b/misc/gnu-watch/Makefile
@@ -25,12 +25,6 @@ LDFLAGS+= -lncurses
MAN1= gnu-watch.1
PLIST_FILES= bin/${UNIQUENAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-watch.c
-.endif
-
do-build:
${CC} ${CFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.c \
-o ${WRKSRC}/${UNIQUENAME}
@@ -39,4 +33,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${UNIQUENAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/watch.1 ${MANPREFIX}/man/man1/${UNIQUENAME}.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/heyu2/Makefile b/misc/heyu2/Makefile
index 25569c841fde..b618f0480d32 100644
--- a/misc/heyu2/Makefile
+++ b/misc/heyu2/Makefile
@@ -28,24 +28,15 @@ MAN5= x10config.5 \
x10sched.5 \
x10scripts.5
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -E 's|/usr/local|${PREFIX}|g; \
s,(CC) =,\1 ?=,g; \
s,(CFLAGS) =,\1 +=,g' \
${WRKSRC}/Configure
-.if ${OSVERSION} >= 500000
@${REINPLACE_CMD} -e 's|<.*termio[s]*.h|<sys/ttycom.h|g' \
${WRKSRC}/cm17a.c \
${WRKSRC}/xsync.c \
${WRKSRC}/xwrite.c
-.else
- @${REINPLACE_CMD} -e 's|<.*termio[s]*.h|<sys/termios.h|g' \
- ${WRKSRC}/cm17a.c \
- ${WRKSRC}/xsync.c \
- ${WRKSRC}/xwrite.c
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/heyu ${PREFIX}/bin
@@ -57,4 +48,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/x10config.sample ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/x10.sched.sample ${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/libhome/Makefile b/misc/libhome/Makefile
index cf4d6f2d5870..42a7b9094acd 100644
--- a/misc/libhome/Makefile
+++ b/misc/libhome/Makefile
@@ -81,12 +81,6 @@ CONFIGURE_ARGS+= --without-pgsql
MAN5= home.conf.5
MAN8= home_proxy.8
-.if ${OSVERSION} < 500000
-PLIST_SUB= NSS="@comment "
-.else
-PLIST_SUB= NSS=""
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig ${WRKSRC}/configure
.if defined(WITH_BDB)
diff --git a/misc/libhome/pkg-plist b/misc/libhome/pkg-plist
index 6579e31472e1..82e8f17cc618 100644
--- a/misc/libhome/pkg-plist
+++ b/misc/libhome/pkg-plist
@@ -17,7 +17,7 @@ lib/libhome-preload.a
lib/libhome-preload.la
lib/libhome-preload.so
lib/libhome-preload.so.1
-%%NSS%%lib/nss_home_proxy.a
-%%NSS%%lib/nss_home_proxy.la
-%%NSS%%lib/nss_home_proxy.so
-%%NSS%%lib/nss_home_proxy.so.1
+lib/nss_home_proxy.a
+lib/nss_home_proxy.la
+lib/nss_home_proxy.so
+lib/nss_home_proxy.so.1
diff --git a/misc/mbuffer/Makefile b/misc/mbuffer/Makefile
index 7d9ee45a0d14..34fb704af5d7 100644
--- a/misc/mbuffer/Makefile
+++ b/misc/mbuffer/Makefile
@@ -24,10 +24,6 @@ MAN1= ${PORTNAME}.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= needs C99 functions
-.endif
-
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64" || ${ARCH} == "ia64"
CFLAGS+= -m64
.endif