aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-BBS-Client/Makefile25
-rw-r--r--net/p5-BBS-Client/distinfo3
-rw-r--r--net/p5-BBS-Client/pkg-descr4
-rw-r--r--net/p5-BBS-Client/pkg-plist9
5 files changed, 42 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9ebf5b301e40..7fe0a0c33ddc 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -437,6 +437,7 @@
SUBDIR += p5-AddressBook
SUBDIR += p5-Amazon-SQS-Simple
SUBDIR += p5-Apache2-SOAP
+ SUBDIR += p5-BBS-Client
SUBDIR += p5-BBS-UserInfo
SUBDIR += p5-BBS-UserInfo-Maple3
SUBDIR += p5-BBS-UserInfo-Maple3itoc
diff --git a/net/p5-BBS-Client/Makefile b/net/p5-BBS-Client/Makefile
new file mode 100644
index 000000000000..25072b20a3f8
--- /dev/null
+++ b/net/p5-BBS-Client/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-BBS-Client
+# Date created: 2008-05-30
+# Whom: Yi-Jheng, Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BBS-Client
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/C/CO/CORNELIUS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= A Client Module For BBS Systems
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= BBS::Client.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-BBS-Client/distinfo b/net/p5-BBS-Client/distinfo
new file mode 100644
index 000000000000..a9fc658aff09
--- /dev/null
+++ b/net/p5-BBS-Client/distinfo
@@ -0,0 +1,3 @@
+MD5 (BBS-Client-0.03.tar.gz) = 91c0244dfe6cb82751df2880d89241e4
+SHA256 (BBS-Client-0.03.tar.gz) = 711c726bb21e940b946cde89ddd66bc29359cc16859283786da01c1aaa82316e
+SIZE (BBS-Client-0.03.tar.gz) = 6921
diff --git a/net/p5-BBS-Client/pkg-descr b/net/p5-BBS-Client/pkg-descr
new file mode 100644
index 000000000000..3f6f434d51b4
--- /dev/null
+++ b/net/p5-BBS-Client/pkg-descr
@@ -0,0 +1,4 @@
+BBS::Client - A Client Module For BBS Systems
+
+Author: Yo-An Lin <cornelius@cpan.org>
+WWW: http://search.cpan.org/dist/BBS-Client/
diff --git a/net/p5-BBS-Client/pkg-plist b/net/p5-BBS-Client/pkg-plist
new file mode 100644
index 000000000000..545612f29940
--- /dev/null
+++ b/net/p5-BBS-Client/pkg-plist
@@ -0,0 +1,9 @@
+bin/bbs_get.pl
+bin/bbs_listen.pl
+%%SITE_PERL%%/BBS/Client.pm
+%%SITE_PERL%%/BBS/Client/Scheme.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BBS/Client/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BBS/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BBS
+@dirrmtry %%SITE_PERL%%/BBS/Client
+@dirrmtry %%SITE_PERL%%/BBS