aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/ebview-gtk2/Makefile6
-rw-r--r--japanese/ebview/Makefile6
2 files changed, 12 insertions, 0 deletions
diff --git a/japanese/ebview-gtk2/Makefile b/japanese/ebview-gtk2/Makefile
index 3e3eac11406e..db7e9564785b 100644
--- a/japanese/ebview-gtk2/Makefile
+++ b/japanese/ebview-gtk2/Makefile
@@ -28,6 +28,12 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+post-patch:
+.for file in src/dictheading.c
+ cd ${WRKSRC} && ${MV} ${file} ${file}.pre_iconv \
+ && iconv -c -t ascii ${file}.pre_iconv > ${file} || ${TRUE}
+.endfor
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/japanese/ebview/Makefile b/japanese/ebview/Makefile
index 3e3eac11406e..db7e9564785b 100644
--- a/japanese/ebview/Makefile
+++ b/japanese/ebview/Makefile
@@ -28,6 +28,12 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+post-patch:
+.for file in src/dictheading.c
+ cd ${WRKSRC} && ${MV} ${file} ${file}.pre_iconv \
+ && iconv -c -t ascii ${file}.pre_iconv > ${file} || ${TRUE}
+.endfor
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}