aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/mplayer2/Makefile2
-rw-r--r--multimedia/mplayer2/files/patch-libmpdemux-demuxer.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index e69180c478ce..3ccef7c218f7 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mplayer2
PORTVERSION= ${MPLAYER2_PORT_VERSION}
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= multimedia audio
MASTER_SITES= LOCAL/gblach/
diff --git a/multimedia/mplayer2/files/patch-libmpdemux-demuxer.h b/multimedia/mplayer2/files/patch-libmpdemux-demuxer.h
new file mode 100644
index 000000000000..87b5bb38e4ef
--- /dev/null
+++ b/multimedia/mplayer2/files/patch-libmpdemux-demuxer.h
@@ -0,0 +1,11 @@
+--- libmpdemux/demuxer.h.orig 2014-09-19 05:04:22.000000000 +0200
++++ libmpdemux/demuxer.h 2014-09-19 05:01:57.000000000 +0200
+@@ -121,7 +121,7 @@
+ #define SEEK_BACKWARD (1 << 3)
+
+ // demux_lavf can pass lavf buffers using FF_INPUT_BUFFER_PADDING_SIZE instead
+-#define MP_INPUT_BUFFER_PADDING_SIZE 16
++#define MP_INPUT_BUFFER_PADDING_SIZE 32
+
+ typedef struct demux_stream {
+ int buffer_pos; // current buffer position