aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile29
-rw-r--r--www/p5-HTTP-MobileAgent-Plugin-Locator/distinfo2
-rw-r--r--www/p5-HTTP-MobileAgent-Plugin-Locator/pkg-descr3
-rw-r--r--www/p5-HTTP-MobileAgent-Plugin-Locator/pkg-plist18
5 files changed, 53 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f51cad696277..b4c93f102a14 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1066,6 +1066,7 @@
SUBDIR += p5-HTTP-Message
SUBDIR += p5-HTTP-MobileAgent
SUBDIR += p5-HTTP-MobileAgent-Plugin-Charset
+ SUBDIR += p5-HTTP-MobileAgent-Plugin-Locator
SUBDIR += p5-HTTP-MobileAttribute
SUBDIR += p5-HTTP-Negotiate
SUBDIR += p5-HTTP-Parser
diff --git a/www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile b/www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile
new file mode 100644
index 000000000000..a51763260a58
--- /dev/null
+++ b/www/p5-HTTP-MobileAgent-Plugin-Locator/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: HTTP::MobileAgent::Plugin::Locator
+# Date created: 05 Jul 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-MobileAgent-Plugin-Locator
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Mobile location information plugin for p5-HTTP-MobileAgent
+
+RUN_DEPENDS= \
+ p5-Geo-Coordinates-Converter>=0.10:${PORTSDIR}/science/p5-Geo-Coordinates-Converter \
+ p5-Geo-Coordinates-Converter-iArea>=0.11:${PORTSDIR}/science/p5-Geo-Coordinates-Converter-iArea \
+ p5-HTTP-MobileAgent>=0.31:${PORTSDIR}/www/p5-HTTP-MobileAgent \
+ p5-UNIVERSAL-can>0:${PORTSDIR}/devel/p5-UNIVERSAL-can \
+ p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::MobileAgent::Plugin::Locator.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-MobileAgent-Plugin-Locator/distinfo b/www/p5-HTTP-MobileAgent-Plugin-Locator/distinfo
new file mode 100644
index 000000000000..9e1cda895c3b
--- /dev/null
+++ b/www/p5-HTTP-MobileAgent-Plugin-Locator/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTTP-MobileAgent-Plugin-Locator-0.04.tar.gz) = 800dee2a8ec713a390c30ef13aa76cd018005df4a17c2f4c1ea36b18ef0f6f74
+SIZE (HTTP-MobileAgent-Plugin-Locator-0.04.tar.gz) = 24064
diff --git a/www/p5-HTTP-MobileAgent-Plugin-Locator/pkg-descr b/www/p5-HTTP-MobileAgent-Plugin-Locator/pkg-descr
new file mode 100644
index 000000000000..71412b24e12b
--- /dev/null
+++ b/www/p5-HTTP-MobileAgent-Plugin-Locator/pkg-descr
@@ -0,0 +1,3 @@
+Handling mobile location information plugin for HTTP::MobileAgent.
+
+WWW: http://search.cpan.org/dist/HTTP-MobileAgent-Plugin-Locator/
diff --git a/www/p5-HTTP-MobileAgent-Plugin-Locator/pkg-plist b/www/p5-HTTP-MobileAgent-Plugin-Locator/pkg-plist
new file mode 100644
index 000000000000..67590b684c35
--- /dev/null
+++ b/www/p5-HTTP-MobileAgent-Plugin-Locator/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MobileAgent/Plugin/Locator/.packlist
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator.pm
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/Base.pm
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/DoCoMo/BasicLocation.pm
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/DoCoMo/GPS.pm
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/EZweb/BasicLocation.pm
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/EZweb/GPS.pm
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/SoftBank/BasicLocation.pm
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/SoftBank/GPS.pm
+%%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/Willcom/BasicLocation.pm
+@dirrm %%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/Willcom
+@dirrm %%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/SoftBank
+@dirrm %%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/EZweb
+@dirrm %%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator/DoCoMo
+@dirrm %%SITE_PERL%%/HTTP/MobileAgent/Plugin/Locator
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAgent/Plugin
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MobileAgent/Plugin/Locator
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MobileAgent/Plugin