aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/sjeng/Makefile25
-rw-r--r--games/sjeng/distinfo3
-rw-r--r--games/sjeng/pkg-descr6
4 files changed, 35 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index a7222587c3e3..404bf56d6550 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -546,6 +546,7 @@
SUBDIR += shaaft
SUBDIR += shootingstar
SUBDIR += six
+ SUBDIR += sjeng
SUBDIR += sl
SUBDIR += slashem-tty
SUBDIR += slune
diff --git a/games/sjeng/Makefile b/games/sjeng/Makefile
new file mode 100644
index 000000000000..f9e61467528b
--- /dev/null
+++ b/games/sjeng/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: sjeng
+# Date created: 18 Feb 2006
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sjeng
+PORTVERSION= 11.2
+CATEGORIES= games
+MASTER_SITES= http://sjeng.org/ftp/
+DISTNAME= Sjeng-Free-${PORTVERSION}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Chess engine supporting chess variations
+
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgdbm"
+
+PLIST_FILES= bin/sjeng
+
+.include <bsd.port.mk>
diff --git a/games/sjeng/distinfo b/games/sjeng/distinfo
new file mode 100644
index 000000000000..9a6cb14659a2
--- /dev/null
+++ b/games/sjeng/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sjeng-Free-11.2.tar.gz) = 6561e740b7af703c16701304697d2870
+SHA256 (Sjeng-Free-11.2.tar.gz) = aaf584d12e79f8e366710d40cc02a27a7927dd924234421107b2fb8e84cfd727
+SIZE (Sjeng-Free-11.2.tar.gz) = 174019
diff --git a/games/sjeng/pkg-descr b/games/sjeng/pkg-descr
new file mode 100644
index 000000000000..5bfc02612b90
--- /dev/null
+++ b/games/sjeng/pkg-descr
@@ -0,0 +1,6 @@
+Sjeng was an attempt to create a bughouse & crazyhouse playing program that
+can attain a level comparable to what the best human players are capable of.
+Newer versions of Sjeng also play standard, suicide, giveaway and losers
+chess.
+
+WWW: http://sjeng.org/indexold.html