aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/bbkeys/Makefile2
-rw-r--r--x11-wm/bbkeys/files/patch-src_KeyClient.cpp14
2 files changed, 15 insertions, 1 deletions
diff --git a/x11-wm/bbkeys/Makefile b/x11-wm/bbkeys/Makefile
index ff6bfa5623d2..d3503109f304 100644
--- a/x11-wm/bbkeys/Makefile
+++ b/x11-wm/bbkeys/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bbkeys
PORTVERSION= 0.9.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/x11-wm/bbkeys/files/patch-src_KeyClient.cpp b/x11-wm/bbkeys/files/patch-src_KeyClient.cpp
new file mode 100644
index 000000000000..89200e5f00ca
--- /dev/null
+++ b/x11-wm/bbkeys/files/patch-src_KeyClient.cpp
@@ -0,0 +1,14 @@
+--- src/KeyClient.cpp.orig Thu Jun 9 09:07:14 2005
++++ src/KeyClient.cpp Thu Jun 9 09:10:24 2005
+@@ -102,6 +102,11 @@
+ _netclient = new Netclient(this->display());
+ _active = _clients.end();
+
++ // Initialize uninitialized pointers to NULL
++ _keybindings = NULL;
++ config_check_timer = NULL;
++
++
+ initialize();
+ }
+