aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/hdf5-18/Makefile3
-rw-r--r--science/hdf5-18/distinfo4
-rw-r--r--science/hdf5-18/files/patch-src-H5FDdirect.c12
-rw-r--r--science/hdf5-18/pkg-plist11
4 files changed, 21 insertions, 9 deletions
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
index f7694f8f5812..b4e4fcb85865 100644
--- a/science/hdf5-18/Makefile
+++ b/science/hdf5-18/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hdf5
-PORTVERSION= 1.8.7
+PORTVERSION= 1.8.8
CATEGORIES= science archivers graphics
MASTER_SITES= ftp://ftp.hdfgroup.org/HDF5/prev-releases/hdf5-${PORTVERSION}/src/
#DISTNAME= ${PORTNAME}-${PORTVERSION}-patch1
@@ -62,6 +62,7 @@ post-patch:
-e 's|/share/hdf5_examples|/${EXAMPLESDIR_REL}|' \
-e 's|(INSTALL)|(INSTALL_DATA)|' \
`${FIND} ${WRKSRC} -regex '.*/examples/Makefile.in'`
+ @${REINPLACE_CMD} -e 's|\[ -a|\[ -f|g' `${FIND} ${WRKSRC} -name \*.sh\*`
.if defined(NOPORTEXAMPLES)
@${REINPLACE_CMD} -e '/^install:/ s|install-examples||' ${WRKSRC}/Makefile.in
.endif
diff --git a/science/hdf5-18/distinfo b/science/hdf5-18/distinfo
index e7ab2fd45d3f..1110b3803bbf 100644
--- a/science/hdf5-18/distinfo
+++ b/science/hdf5-18/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hdf5-1.8.7.tar.bz2) = 771761c9bec30b9a4137fa59ef88fdafdb0f4f35d1db0fd655f2591d19570fec
-SIZE (hdf5-1.8.7.tar.bz2) = 5710170
+SHA256 (hdf5-1.8.8.tar.bz2) = b0ebb0b5478c6c0427631d4ad08f96e39f1b09fde615aa98d2a1b8fb7f6dced3
+SIZE (hdf5-1.8.8.tar.bz2) = 5827394
diff --git a/science/hdf5-18/files/patch-src-H5FDdirect.c b/science/hdf5-18/files/patch-src-H5FDdirect.c
index f46dbe251b5a..9e58a20ac27f 100644
--- a/science/hdf5-18/files/patch-src-H5FDdirect.c
+++ b/science/hdf5-18/files/patch-src-H5FDdirect.c
@@ -1,11 +1,11 @@
---- src/H5FDdirect.c.orig 2008-09-24 22:02:07.000000000 +0800
-+++ src/H5FDdirect.c 2008-09-24 22:02:38.000000000 +0800
+--- ./src/H5FDdirect.c.orig 2011-11-07 14:11:30.000000000 -0800
++++ ./src/H5FDdirect.c 2011-12-21 16:50:03.000000000 -0800
@@ -29,6 +29,8 @@
* this file. */
/* #define _XOPEN_SOURCE 600 */
-+#define O_DIRECT 0x00010000
++#define O_DIRECT 0x00010000
+
- #include "H5private.h" /* Generic Functions */
- #include "H5Eprivate.h" /* Error handling */
- #include "H5Fprivate.h" /* File access */
+ #include "H5private.h" /* Generic Functions */
+ #include "H5Eprivate.h" /* Error handling */
+ #include "H5Fprivate.h" /* File access */ \ No newline at end of file
diff --git a/science/hdf5-18/pkg-plist b/science/hdf5-18/pkg-plist
index 570b66becea8..21b8eb7f1c07 100644
--- a/science/hdf5-18/pkg-plist
+++ b/science/hdf5-18/pkg-plist
@@ -90,8 +90,12 @@ include/H5public.h
include/H5version.h
%%FORTRAN%%include/h5_dble_interface.mod
%%FORTRAN%%include/h5a.mod
+%%FORTRAN%%include/h5a_provisional.mod
%%FORTRAN%%include/h5d.mod
+%%FORTRAN%%include/h5d_provisional.mod
+%%FORTRAN%%include/h5ds.mod
%%FORTRAN%%include/h5e.mod
+%%FORTRAN%%include/h5e_provisional.mod
%%FORTRAN%%include/h5f.mod
%%FORTRAN%%include/h5fortran_types.mod
%%FORTRAN%%include/h5g.mod
@@ -99,13 +103,19 @@ include/H5version.h
%%FORTRAN%%include/h5i.mod
%%FORTRAN%%include/h5im.mod
%%FORTRAN%%include/h5l.mod
+%%FORTRAN%%include/h5l_provisional.mod
%%FORTRAN%%include/h5lib.mod
+%%FORTRAN%%include/h5lib_provisional.mod
%%FORTRAN%%include/h5lt.mod
%%FORTRAN%%include/h5o.mod
+%%FORTRAN%%include/h5o_provisional.mod
%%FORTRAN%%include/h5p.mod
+%%FORTRAN%%include/h5p_provisional.mod
%%FORTRAN%%include/h5r.mod
+%%FORTRAN%%include/h5r_provisional.mod
%%FORTRAN%%include/h5s.mod
%%FORTRAN%%include/h5t.mod
+%%FORTRAN%%include/h5t_provisional.mod
%%FORTRAN%%include/h5tb.mod
%%FORTRAN%%include/h5z.mod
include/hdf5.h
@@ -188,6 +198,7 @@ lib/libhdf5_hl_cpp.so.7
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hl/c/ptExampleFL.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hl/c/ptExampleVL.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hl/c/run-hlc-ex.sh
+%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hl/fortran/ex_ds1.f90
%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hl/fortran/exlite.f90
%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hl/fortran/run-hlfortran-ex.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hl/run-hl-ex.sh