aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/mtop/Makefile3
-rw-r--r--databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile9
-rw-r--r--databases/p5-DBIx-Class-EncodeColumns/Makefile9
-rw-r--r--databases/p5-DBIx-Class-InflateColumn-FS/Makefile8
-rw-r--r--databases/p5-DBIx-Sequence/Makefile3
-rw-r--r--databases/p5-DBIx-Skinny/Makefile8
-rw-r--r--databases/p5-SQL-Abstract-More/Makefile3
-rw-r--r--databases/percona-toolkit/Makefile3
-rw-r--r--databases/postgresql_autodoc/Makefile2
-rw-r--r--editors/color-mate/Makefile8
-rw-r--r--editors/fte/Makefile9
-rw-r--r--editors/p5-Vimana/Makefile9
-rw-r--r--editors/zile/Makefile3
-rw-r--r--textproc/p5-ElasticSearch-SearchBuilder/Makefile3
-rw-r--r--textproc/p5-ElasticSearch/Makefile3
-rw-r--r--textproc/p5-String-HexConvert/Makefile3
-rw-r--r--textproc/p5-String-Urandom/Makefile8
-rw-r--r--textproc/p5-texcount/Makefile3
-rw-r--r--textproc/yodl/Makefile9
19 files changed, 42 insertions, 64 deletions
diff --git a/databases/mtop/Makefile b/databases/mtop/Makefile
index 5e5f71452857..6e6fce419760 100644
--- a/databases/mtop/Makefile
+++ b/databases/mtop/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses \
p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-Net>=0:${PORTSDIR}/net/p5-Net
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= mkill.1 mtop.1
diff --git a/databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile b/databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile
index 5d622f70d717..46d039d5cfa5 100644
--- a/databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile
+++ b/databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-DBI-Plugin-DeepAbstractSearch
-# Date created: 2011-02-15
-# Whom: milki <milki@rescomp.berkeley.edy>
-#
+# Created by: milki <milki@rescomp.berkeley.edy>
# $FreeBSD$
-#
PORTNAME= Class-DBI-Plugin-DeepAbstractSearch
PORTVERSION= 0.08
@@ -25,7 +21,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::DBI::Plugin::DeepAbstractSearch.3
.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-EncodeColumns/Makefile b/databases/p5-DBIx-Class-EncodeColumns/Makefile
index b513d47ea43f..d0127fffad3c 100644
--- a/databases/p5-DBIx-Class-EncodeColumns/Makefile
+++ b/databases/p5-DBIx-Class-EncodeColumns/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBIx-Class-EncodeColumns
-# Date created: 24 May 2008
-# Whom: Vladimir Timofeev <vovkasm@gmail.com>
-#
+# Created by: Vladimir Timofeev <vovkasm@gmail.com>
# $FreeBSD$
-#
PORTNAME= DBIx-Class-EncodeColumns
PORTVERSION= 0.02
@@ -17,7 +13,8 @@ COMMENT= Handle column encodings
RUN_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class
BUILD_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= DBIx::Class::EncodeColumns.3
diff --git a/databases/p5-DBIx-Class-InflateColumn-FS/Makefile b/databases/p5-DBIx-Class-InflateColumn-FS/Makefile
index 3b26f82f2c78..80d1c793c9a7 100644
--- a/databases/p5-DBIx-Class-InflateColumn-FS/Makefile
+++ b/databases/p5-DBIx-Class-InflateColumn-FS/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: DBIx::Class::InflateColumn::FS
-# Date created: 18 Mar 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= DBIx-Class-InflateColumn-FS
PORTVERSION= 0.01007
@@ -21,7 +16,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-DBICx-TestDatabase>=0:${PORTSDIR}/databases/p5-DBICx-TestDatabase
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::InflateColumn::FS.3 \
DBIx::Class::InflateColumn::FS::ResultSet.3
diff --git a/databases/p5-DBIx-Sequence/Makefile b/databases/p5-DBIx-Sequence/Makefile
index a08d4f930f28..f9f7ce904e43 100644
--- a/databases/p5-DBIx-Sequence/Makefile
+++ b/databases/p5-DBIx-Sequence/Makefile
@@ -13,7 +13,8 @@ COMMENT= DBIx::Sequence - A simple SQL92 ID generator
BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Sequence.3
diff --git a/databases/p5-DBIx-Skinny/Makefile b/databases/p5-DBIx-Skinny/Makefile
index ec419f4a4d7a..a002b2e1b64b 100644
--- a/databases/p5-DBIx-Skinny/Makefile
+++ b/databases/p5-DBIx-Skinny/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: DBIx::Skinny
-# Date created: 19 Nov 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= DBIx-Skinny
PORTVERSION= 0.0742
@@ -24,7 +19,8 @@ RUN_DEPENDS= \
p5-Class-Load>0:${PORTSDIR}/devel/p5-Class-Load
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Skinny.3 \
DBIx::Skinny::Iterator.3 \
diff --git a/databases/p5-SQL-Abstract-More/Makefile b/databases/p5-SQL-Abstract-More/Makefile
index eaf8ff210db5..66a32b1028a6 100644
--- a/databases/p5-SQL-Abstract-More/Makefile
+++ b/databases/p5-SQL-Abstract-More/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-MRO-Compat>0:${PORTSDIR}/devel/p5-MRO-Compat \
p5-SQL-Abstract>=1.73:${PORTSDIR}/databases/p5-SQL-Abstract
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SQL::Abstract::More.3
diff --git a/databases/percona-toolkit/Makefile b/databases/percona-toolkit/Makefile
index f9ac9c3ef67a..cd539615fcbb 100644
--- a/databases/percona-toolkit/Makefile
+++ b/databases/percona-toolkit/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
p5-DBI>=1.46:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= percona-toolkit.1 \
pt-agent.1 \
diff --git a/databases/postgresql_autodoc/Makefile b/databases/postgresql_autodoc/Makefile
index a0b01ba25fdd..dba704ce1701 100644
--- a/databases/postgresql_autodoc/Makefile
+++ b/databases/postgresql_autodoc/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
CONFIGURE_ARGS+=--datadir=${DATADIR}
MAN1= postgresql_autodoc.1
diff --git a/editors/color-mate/Makefile b/editors/color-mate/Makefile
index 7aac8b52cd7e..a5da69f29e34 100644
--- a/editors/color-mate/Makefile
+++ b/editors/color-mate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: color-mate for emacs
-# Date created: 99/09/29
-# Whom: Satoshi Taoka <taoka@FreeBSD.org>
-#
+# Created by: Satoshi Taoka <taoka@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= color-mate
PORTVERSION= 10.6.4
@@ -14,7 +10,7 @@ MASTER_SITES= http://www.netlab.is.tsukuba.ac.jp/~yokota/archive/
MAINTAINER= sarumaru@jp.FreeBSD.org
COMMENT= Color customizing module for Emacsen
-USE_PERL5= yes
+USES= perl5
EMACSDIR= ${PREFIX}/share/emacs/site-lisp
ELISPDIR= ${EMACSDIR}/color-mate
diff --git a/editors/fte/Makefile b/editors/fte/Makefile
index c89ceb79287c..4b9cf249e1d1 100644
--- a/editors/fte/Makefile
+++ b/editors/fte/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fte
-# Date created: 8 May 2000
-# Whom: gelf
-#
+# Created by: gelf
# $FreeBSD$
-#
PORTNAME= fte
PORTVERSION= 20051115
@@ -21,7 +17,8 @@ WRKSRC= ${WRKDIR}/fte
USE_XORG= x11 xpm
USE_ZIP= yes
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
post-patch:
@${REINPLACE_CMD} -e 's,^PREFIX=,PREFIX?=,' \
diff --git a/editors/p5-Vimana/Makefile b/editors/p5-Vimana/Makefile
index 3a91a69c9700..f5cb7446ee97 100644
--- a/editors/p5-Vimana/Makefile
+++ b/editors/p5-Vimana/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Vimana
-# Date created: 2009-08-25
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Vimana
PORTVERSION= 2010.09303
@@ -34,7 +30,8 @@ RUN_DEPENDS= vim>=0:${PORTSDIR}/editors/vim \
p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= vimana.1 vim_record.1
MAN3= Vimana.3 \
diff --git a/editors/zile/Makefile b/editors/zile/Makefile
index e1dd7ccf8d80..ed80254b7384 100644
--- a/editors/zile/Makefile
+++ b/editors/zile/Makefile
@@ -13,7 +13,8 @@ LIB_DEPENDS= gc:${PORTSDIR}/devel/boehm-gc
BUILD_DEPENDS= ${LOCALBASE}/bin/help2man:${PORTSDIR}/misc/help2man
USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-regex
diff --git a/textproc/p5-ElasticSearch-SearchBuilder/Makefile b/textproc/p5-ElasticSearch-SearchBuilder/Makefile
index ab6c93e327e4..4abca56fad78 100644
--- a/textproc/p5-ElasticSearch-SearchBuilder/Makefile
+++ b/textproc/p5-ElasticSearch-SearchBuilder/Makefile
@@ -16,7 +16,8 @@ TEST_DEPENDS= p5-Test-Deep>=:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ElasticSearch::SearchBuilder.3
diff --git a/textproc/p5-ElasticSearch/Makefile b/textproc/p5-ElasticSearch/Makefile
index 6d4f5e188b7e..b9df7d96d421 100644
--- a/textproc/p5-ElasticSearch/Makefile
+++ b/textproc/p5-ElasticSearch/Makefile
@@ -36,7 +36,8 @@ RUN_DEPENDS:= p5-ElasticSearch-SearchBuilder>=0:${PORTSDIR}/textproc/p5-ElasticS
TEST_DEPENDS= p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ElasticSearch.3 \
ElasticSearch::Error.3 \
diff --git a/textproc/p5-String-HexConvert/Makefile b/textproc/p5-String-HexConvert/Makefile
index 1bdad52eaf24..d0f9ff7f1426 100644
--- a/textproc/p5-String-HexConvert/Makefile
+++ b/textproc/p5-String-HexConvert/Makefile
@@ -13,7 +13,8 @@ COMMENT= String::HexConver - Converts ascii strings to hex and reverse
WRKSRC= ${WRKDIR}/${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::HexConvert.3
diff --git a/textproc/p5-String-Urandom/Makefile b/textproc/p5-String-Urandom/Makefile
index 9ba8332b1eda..22816a9c0146 100644
--- a/textproc/p5-String-Urandom/Makefile
+++ b/textproc/p5-String-Urandom/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: String::Urandom
-# Date created: 31 Dec 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= String-Urandom
PORTVERSION= 0.16
@@ -18,7 +13,8 @@ RUN_DEPENDS= \
p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::Urandom.3
diff --git a/textproc/p5-texcount/Makefile b/textproc/p5-texcount/Makefile
index 3d47a8cdf7ab..e14a746d2b37 100644
--- a/textproc/p5-texcount/Makefile
+++ b/textproc/p5-texcount/Makefile
@@ -16,7 +16,8 @@ COMMENT= Perl module for LaTeX statistics
NO_BUILD= yes
USE_ZIP= YES
-USE_PERL5_RUN= YES
+USES= perl5
+USE_PERL5= run
PLIST_FILES+= bin/texcount
diff --git a/textproc/yodl/Makefile b/textproc/yodl/Makefile
index 9e552c468bed..74283389b9d6 100644
--- a/textproc/yodl/Makefile
+++ b/textproc/yodl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: yodl
-# Date created: 22 Oct 1997
-# Whom: Donald Burr <dburr@FreeBSD.org>
-#
+# Created by: Donald Burr <dburr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= yodl
PORTVERSION= 3.00.0
@@ -22,7 +18,8 @@ BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
bash:${PORTSDIR}/shells/bash \
gsed:${PORTSDIR}/textproc/gsed
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
.if !defined(NO_INSTALL_MANPAGES)
MANCOMPRESSED= no