aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/fcrackzip/Makefile37
-rw-r--r--security/fcrackzip/distinfo2
-rw-r--r--security/fcrackzip/pkg-descr6
4 files changed, 46 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index cda56ad05dc5..0ee9c8a50156 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -77,6 +77,7 @@
SUBDIR += fakebo
SUBDIR += fakeident
SUBDIR += fakeroot
+ SUBDIR += fcrackzip
SUBDIR += find-zlib
SUBDIR += find_ddos
SUBDIR += finger_mysql
diff --git a/security/fcrackzip/Makefile b/security/fcrackzip/Makefile
new file mode 100644
index 000000000000..8f7d8a747435
--- /dev/null
+++ b/security/fcrackzip/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fcrackzip
+# Date created: 16 Jul 2004
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fcrackzip
+PORTVERSION= 0.3
+CATEGORIES= security archivers
+MASTER_SITES= http://www.goof.com/pcg/marc/data/
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= Portable, fast and featureful ZIP password cracker
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GETOPT_LONG=yes
+USE_PERL5_BUILD=yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/fcrackzip bin/fcrackzipinfo
+.if !defined(NOPORTDOCS)
+MAN1= fcrackzip.1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/zipinfo/fcrackzipinfo/g' ${WRKSRC}/zipinfo.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/fcrackzip ${PREFIX}/bin/
+ @${INSTALL_PROGRAM} ${WRKSRC}/zipinfo ${PREFIX}/bin/fcrackzipinfo
+.if !defined(NOPORTDOCS)
+ @${INSTALL_MAN} ${WRKSRC}/fcrackzip.1 ${PREFIX}/man/man1/
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/fcrackzip/distinfo b/security/fcrackzip/distinfo
new file mode 100644
index 000000000000..01534ecd7f1c
--- /dev/null
+++ b/security/fcrackzip/distinfo
@@ -0,0 +1,2 @@
+MD5 (fcrackzip-0.3.tar.gz) = b45ee7f1491252be1d466036fb433de0
+SIZE (fcrackzip-0.3.tar.gz) = 103038
diff --git a/security/fcrackzip/pkg-descr b/security/fcrackzip/pkg-descr
new file mode 100644
index 000000000000..18a238f69224
--- /dev/null
+++ b/security/fcrackzip/pkg-descr
@@ -0,0 +1,6 @@
+Fcrackzip is a fast and featureful ZIP password cracker, written in
+portable C (and optional x86 assembly). It allows the user to recover
+forgotten ZIP archive passwords, using either a brute force or
+dictionary attack on the provided files.
+
+WWW: http://www.goof.com/pcg/marc/fcrackzip.html