aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/xloadimage/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index 153b83559b16..1b6aabbecda7 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -9,25 +9,22 @@
DISTNAME= xloadimage.4.1
PKGNAME= xloadimage-4.1
CATEGORIES= x11
-MASTER_SITES= ftp://ftp.cdrom.com/pub/X11/R5contrib/
+MASTER_SITES= ftp://ftp.x.org/R5contrib/ \
+ ftp://ftp.freesoftware.com/pub/X11/R5contrib/
MAINTAINER= jmz@FreeBSD.org
-MAN1= xloadimage.1
-MANCOMPRESSED= yes
-
-USE_GMAKE= yes
USE_X_PREFIX= yes
-
ALL_TARGET=
+MAN1= xloadimage.1
do-configure:
- cd ${WRKSRC} && make configure </dev/null
- cd ${WRKSRC} && ${ECHO} SYSPATHFILE=${X11BASE}/lib/X11/app-defaults/Xloadimage >> Makefile
+ cd ${WRKSRC} && ${MAKE} configure </dev/null
+ cd ${WRKSRC} && ${ECHO} SYSPATHFILE=${PREFIX}/lib/X11/app-defaults/Xloadimage >> Makefile
do-install:
- cd ${WRKSRC} && ${INSTALL_PROGRAM} xloadimage uufilter ${X11BASE}/bin
- cd ${WRKSRC} && ${INSTALL_DATA} xloadimagerc ${X11BASE}/lib/X11/app-defaults/Xloadimage
- cd ${WRKSRC} && ${SED} -e s:/usr/lib/X11/Xloadimage:${X11BASE}/lib/X11/app-defaults/Xloadimage: < xloadimage.man |${GZIP_CMD} >${X11BASE}/man/man1/xloadimage.1.gz
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} xloadimage uufilter ${PREFIX}/bin
+ cd ${WRKSRC} && ${INSTALL_DATA} xloadimagerc ${PREFIX}/lib/X11/app-defaults/Xloadimage
+ cd ${WRKSRC} && ${SED} -e s:/usr/lib/X11/Xloadimage:${PREFIX}/lib/X11/app-defaults/Xloadimage: < xloadimage.man >${PREFIX}/man/man1/xloadimage.1
.include <bsd.port.mk>