aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-virtualenvwrapper/Makefile9
-rw-r--r--devel/py-virtualenvwrapper/pkg-descr2
2 files changed, 7 insertions, 4 deletions
diff --git a/devel/py-virtualenvwrapper/Makefile b/devel/py-virtualenvwrapper/Makefile
index 6a403bdaf8d5..5f6f417822e7 100644
--- a/devel/py-virtualenvwrapper/Makefile
+++ b/devel/py-virtualenvwrapper/Makefile
@@ -3,13 +3,13 @@
PORTNAME= virtualenvwrapper
PORTVERSION= 4.8.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
-COMMENT= Set of extensions to virtualenv
+COMMENT= Enhancements to virtualenv
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -33,11 +33,14 @@ DOCS_VARS= PYDISTUTILS_BUILD_TARGET+=build_sphinx \
NO_ARCH= yes
post-patch:
- @${REINPLACE_CMD} \
+ ${REINPLACE_CMD} \
-e 's|$$(command \\which python)|${PYTHON_CMD}|1' \
-e 's|="virtualenv"|="virtualenv${UNIQUE_SUFFIX}"|1' \
-e 's|="virtualenv-clone"|="virtualenv-clone${UNIQUE_SUFFIX}"|1' \
${WRKSRC}/${PORTNAME}.sh
+ ${REINPLACE_CMD} \
+ -e 's|which virtualenvwrapper.sh|which ${PORTNAME}.sh${UNIQUE_SUFFIX}|' \
+ ${WRKSRC}/${PORTNAME}_lazy.sh
post-patch-DOCS-on:
@${REINPLACE_CMD} -e 's|python setup.py|${PYTHON_CMD} setup.py|' \
diff --git a/devel/py-virtualenvwrapper/pkg-descr b/devel/py-virtualenvwrapper/pkg-descr
index 396ecf54d669..887b86dd4fdf 100644
--- a/devel/py-virtualenvwrapper/pkg-descr
+++ b/devel/py-virtualenvwrapper/pkg-descr
@@ -5,4 +5,4 @@ managing your development workflow, making it easier to work on more
than one project at a time without introducing conflicts in their
dependencies.
-WWW: http://virtualenvwrapper.readthedocs.org/en/latest/index.html
+WWW: https://virtualenvwrapper.readthedocs.io/