aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/libopensync-plugin-python/Makefile7
-rw-r--r--devel/art/Makefile8
-rw-r--r--games/ldmud/Makefile2
-rw-r--r--games/maitretarot/Makefile7
-rw-r--r--misc/gnome-devel-docs/Makefile8
-rw-r--r--multimedia/libbluray/Makefile2
-rw-r--r--security/lasso/Makefile1
-rw-r--r--security/pinentry/Makefile2
-rw-r--r--sysutils/policykit/Makefile2
-rw-r--r--textproc/p5-XML-GDOME/Makefile8
10 files changed, 15 insertions, 32 deletions
diff --git a/deskutils/libopensync-plugin-python/Makefile b/deskutils/libopensync-plugin-python/Makefile
index fb39d4b5fde8..b30d317d6e8c 100644
--- a/deskutils/libopensync-plugin-python/Makefile
+++ b/deskutils/libopensync-plugin-python/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libopensync-plugin-python
-# Date created: 18 July 2008
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
+# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-#
PORTNAME= libopensync-plugin-python
PORTVERSION= 0.22
@@ -17,6 +13,7 @@ LIB_DEPENDS= opensync.0:${PORTSDIR}/devel/libopensync022
CONFLICTS= libopensync-plugin-python-devel-[0-9]*
+USES= pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_PYTHON= yes
diff --git a/devel/art/Makefile b/devel/art/Makefile
index 4815ce45c800..897b9d339e87 100644
--- a/devel/art/Makefile
+++ b/devel/art/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: art
-# Date created: 2011-11-05
-# Whom: Vladimir Gorelov <virtual.lark@gmail.com>
-#
+# Created by: Vladimir Gorelov <virtual.lark@gmail.com>
# $FreeBSD$
-#
PORTNAME= art
PORTVERSION= 0.9.01
@@ -18,7 +14,7 @@ LICENSE= GPLv3
LIB_DEPENDS= xml++-2.6:${PORTSDIR}/textproc/libxml++26
-USE_GMAKE= yes
+USES= gmake pkgconfig
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/artlibgen/src/artlibgen ${PREFIX}/bin
diff --git a/games/ldmud/Makefile b/games/ldmud/Makefile
index 29267c50b51b..a9faf3129097 100644
--- a/games/ldmud/Makefile
+++ b/games/ldmud/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
USE_OPENSSL= yes
-USES= iconv
+USES= iconv pkgconfig
CONFIGURE_ARGS+=--libdir=${DATADIR} \
--bindir=${PREFIX}/sbin \
--enable-use-pcre \
diff --git a/games/maitretarot/Makefile b/games/maitretarot/Makefile
index e292ffd33bab..68a81846b0c7 100644
--- a/games/maitretarot/Makefile
+++ b/games/maitretarot/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: maitretarot
-# Date created: Sun 7 mar 2004
-# Whom: thierry@pompo.net
-#
+# Created by: thierry@pompo.net
# $FreeBSD$
-#
PORTNAME= maitretarot
PORTVERSION= 0.1.98
@@ -17,6 +13,7 @@ COMMENT= Server side of MaitreTarot, a Tarot card game
LIB_DEPENDS= maitretarot.0:${PORTSDIR}/games/libmaitretarot
+USES= pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20 libxml2
diff --git a/misc/gnome-devel-docs/Makefile b/misc/gnome-devel-docs/Makefile
index 3c33a5035c97..331f7a72cf55 100644
--- a/misc/gnome-devel-docs/Makefile
+++ b/misc/gnome-devel-docs/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnome-devel-docs
-# Date created: 2007-09-18
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/misc/gnome-devel-docs/Makefile,v 1.22 2010/09/29 15:17:53 kwm Exp $
-#
PORTNAME= gnome-devel-docs
PORTVERSION= 2.32.0
@@ -20,7 +16,7 @@ RUN_DEPENDS= gnome-doc-prepare:${PORTSDIR}/textproc/gnome-doc-utils
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomehier
INSTALLS_OMF= yes
diff --git a/multimedia/libbluray/Makefile b/multimedia/libbluray/Makefile
index f039bf0a855a..807e1c4aaad0 100644
--- a/multimedia/libbluray/Makefile
+++ b/multimedia/libbluray/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
# dlopen dependencies, libbdplus not yet available
LIB_DEPENDS+= libaacs.so:${PORTSDIR}/multimedia/libaacs
-USES= iconv
+USES= iconv pkgconfig
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_AUTOTOOLS= autoconf aclocal automake libtool
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 974411dfd8e5..7d04c7e2e4ef 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -15,6 +15,7 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
CONFIGURE_ARGS+= --disable-java --disable-php4 --with-zlib
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GNOME= gnomehack glib20 libxml2
USE_LDCONFIG= yes
USE_OPENSSL= yes
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index d457ba30fa11..8fc862ffc386 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
CONFLICTS_INSTALL?= pinentry-[a-z]*
USE_BZIP2= yes
-USES= iconv gmake
+USES= iconv gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-pinentry-qt
INFO= pinentry
diff --git a/sysutils/policykit/Makefile b/sysutils/policykit/Makefile
index 91c666547ce5..ab2195d3f637 100644
--- a/sysutils/policykit/Makefile
+++ b/sysutils/policykit/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
USERS= polkit
GROUPS= polkit
-USES= pathfix
+USES= pathfix pkgconfig
USE_GNOME= glib20 intlhack
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/textproc/p5-XML-GDOME/Makefile b/textproc/p5-XML-GDOME/Makefile
index ded6a935f207..e06793cc312f 100644
--- a/textproc/p5-XML-GDOME/Makefile
+++ b/textproc/p5-XML-GDOME/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XML::GDOME
-# Date created: 2003-10-02
-# Whom: Stefan Esser <se@FreeBSD.org>
-#
+# Created by: Stefan Esser <se@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= XML-GDOME
PORTVERSION= 0.86
@@ -20,7 +16,7 @@ RUN_DEPENDS= p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
BUILD_DEPENDS:= ${RUN_DEPENDS}
-USES= perl5
+USES= perl5 pkgconfig
USE_PERL5= configure
MAN3= XML::GDOME.3 \